summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Thode <prometheanfire@gentoo.org>2015-05-07 23:04:45 +0000
committerMatt Thode <prometheanfire@gentoo.org>2015-05-07 23:04:45 +0000
commit925629f020b0deceb46ae9554bae53bff44481ec (patch)
treebd32eda5b311f74f683ad5bc62d3edc12a57fde5 /sys-cluster/nova/nova-2015.1.9999.ebuild
parentRemove old. (diff)
downloadhistorical-925629f020b0deceb46ae9554bae53bff44481ec.tar.gz
historical-925629f020b0deceb46ae9554bae53bff44481ec.tar.bz2
historical-925629f020b0deceb46ae9554bae53bff44481ec.zip
fixed doc generation
Package-Manager: portage-2.2.18/cvs/Linux x86_64 Manifest-Sign-Key: 0x33ED3FD25AFC78BA
Diffstat (limited to 'sys-cluster/nova/nova-2015.1.9999.ebuild')
-rw-r--r--sys-cluster/nova/nova-2015.1.9999.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sys-cluster/nova/nova-2015.1.9999.ebuild b/sys-cluster/nova/nova-2015.1.9999.ebuild
index 449cf1245d7c..85469e07af08 100644
--- a/sys-cluster/nova/nova-2015.1.9999.ebuild
+++ b/sys-cluster/nova/nova-2015.1.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2015.1.9999.ebuild,v 1.2 2015/05/04 15:09:48 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2015.1.9999.ebuild,v 1.3 2015/05/07 23:04:40 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -24,6 +24,7 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
<dev-python/pbr-1.0[${PYTHON_USEDEP}]
app-admin/sudo"
+# barbicanclient is in here for doc generation
RDEPEND="
sqlite? (
>=dev-python/sqlalchemy-0.9.7[sqlite,${PYTHON_USEDEP}]
@@ -67,6 +68,8 @@ RDEPEND="
<dev-python/python-neutronclient-2.5.0[${PYTHON_USEDEP}]
>=dev-python/python-glanceclient-0.15.0[${PYTHON_USEDEP}]
<dev-python/python-glanceclient-0.18.0[${PYTHON_USEDEP}]
+ >=dev-python/python-barbicanclient-3.0.1[${PYTHON_USEDEP}]
+ <dev-python/python-barbicanclient-3.1.0[${PYTHON_USEDEP}]
>=dev-python/six-1.9.0[${PYTHON_USEDEP}]
>=dev-python/stevedore-1.3.0[${PYTHON_USEDEP}]
<dev-python/stevedore-1.4.0[${PYTHON_USEDEP}]
@@ -125,11 +128,12 @@ pkg_setup() {
fi
enewgroup nova
enewuser nova -1 -1 /var/lib/nova nova
+ sed -i 's/python/python2\.7/g' tools/config/generate_sample.sh || die
}
python_compile() {
distutils-r1_python_compile
- ./tools/config/generate_sample.sh -b ./ -p nova -o etc/nova
+ ./tools/config/generate_sample.sh -b ./ -p nova -o etc/nova || die
}
python_install() {