summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Thode <prometheanfire@gentoo.org>2015-05-15 18:25:10 +0000
committerMatt Thode <prometheanfire@gentoo.org>2015-05-15 18:25:10 +0000
commitb24d6135163199be4da5937626f44f4e6c83fd5f (patch)
treedcc4282f9cec997e4cd420929e8bc3e8a601d1a3 /sys-cluster/nova/nova-2015.1.9999.ebuild
parentCreate symlinks for texdoc. (diff)
downloadhistorical-b24d6135163199be4da5937626f44f4e6c83fd5f.tar.gz
historical-b24d6135163199be4da5937626f44f4e6c83fd5f.tar.bz2
historical-b24d6135163199be4da5937626f44f4e6c83fd5f.zip
adding udev scripts for bug 536500
Package-Manager: portage-2.2.18/cvs/Linux x86_64 Manifest-Sign-Key: 0x33ED3FD25AFC78BA
Diffstat (limited to 'sys-cluster/nova/nova-2015.1.9999.ebuild')
-rw-r--r--sys-cluster/nova/nova-2015.1.9999.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/sys-cluster/nova/nova-2015.1.9999.ebuild b/sys-cluster/nova/nova-2015.1.9999.ebuild
index 1327b8f89ce2..068cdb1ec057 100644
--- a/sys-cluster/nova/nova-2015.1.9999.ebuild
+++ b/sys-cluster/nova/nova-2015.1.9999.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2015.1.9999.ebuild,v 1.8 2015/05/15 07:30:26 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2015.1.9999.ebuild,v 1.9 2015/05/15 18:25:04 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
-inherit distutils-r1 eutils git-2 linux-info multilib user
+inherit distutils-r1 eutils git-2 linux-info multilib udev user
DESCRIPTION="A cloud computing fabric controller (main part of an IaaS system) written in Python"
HOMEPAGE="https://launchpad.net/nova"
@@ -15,7 +15,7 @@ EGIT_BRANCH="stable/kilo"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS=""
-IUSE="+compute compute-only +kvm +novncproxy openvswitch +rabbitmq sqlite mysql postgres xen"
+IUSE="+compute compute-only +kvm +novncproxy openvswitch +rabbitmq sqlite mysql postgres xen iscsi"
REQUIRED_USE="!compute-only? ( || ( mysql postgres sqlite ) )
compute-only? ( compute !novncproxy !rabbitmq !mysql !postgres !sqlite )
compute? ( ^^ ( kvm xen ) )"
@@ -185,4 +185,12 @@ python_install() {
insinto /etc/sudoers.d/
insopts -m 0600 -o root -g root
doins "${FILESDIR}/nova-sudoers"
+
+ if use iscsi ; then
+ # Install udev rules for handle iscsi disk with right links under /dev
+ udev_newrules "${FILESDIR}/openstack-scsi-disk.rules" 60-openstack-scsi-disk.rules
+
+ insinto /etc/nova/
+ doins "${FILESDIR}/scsi-openscsi-link.sh"
+ fi
}