summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/accountsservice/accountsservice-0.6.29-r1.ebuild')
-rw-r--r--sys-apps/accountsservice/accountsservice-0.6.29-r1.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/sys-apps/accountsservice/accountsservice-0.6.29-r1.ebuild b/sys-apps/accountsservice/accountsservice-0.6.29-r1.ebuild
deleted file mode 100644
index 7b7e94da12c6..000000000000
--- a/sys-apps/accountsservice/accountsservice-0.6.29-r1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/accountsservice/accountsservice-0.6.29-r1.ebuild,v 1.9 2014/04/18 19:51:09 swift Exp $
-
-EAPI="4"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-VALA_MIN_API_VERSION="0.16"
-VALA_USE_DEPEND="vapigen"
-
-inherit eutils gnome2 systemd vala
-
-DESCRIPTION="D-Bus interfaces for querying and manipulating user account information"
-HOMEPAGE="http://www.fedoraproject.org/wiki/Features/UserAccountDialog"
-SRC_URI="http://www.freedesktop.org/software/${PN}/${P}.tar.xz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~ia64 ~ppc ~ppc64 ~sparc x86"
-IUSE="doc +introspection selinux systemd vala"
-REQUIRED_USE="vala? ( introspection )"
-
-# Want glib-2.30 for gdbus
-RDEPEND=">=dev-libs/glib-2.30:2
- sys-auth/polkit
- introspection? ( >=dev-libs/gobject-introspection-0.9.12 )
- selinux? ( sec-policy/selinux-accountsd )
- systemd? ( >=sys-apps/systemd-186 )
- !systemd? ( sys-auth/consolekit )"
-DEPEND="${RDEPEND}
- dev-libs/libxslt
- dev-util/gdbus-codegen
- >=dev-util/gtk-doc-am-1.15
- >=dev-util/intltool-0.40
- sys-devel/gettext
- virtual/pkgconfig
- doc? (
- app-text/docbook-xml-dtd:4.1.2
- app-text/xmlto )
- vala? (
- >=dev-lang/vala-0.16.1-r1
- $(vala_depend) )"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-0.6.21-gentoo-system-users.patch"
- epatch "${FILESDIR}/${P}-32bit-crash.patch" # bug #445894, fixed in 0.6.30
- use vala && vala_src_prepare
- gnome2_src_prepare
-}
-
-src_configure() {
- DOCS="AUTHORS NEWS README TODO"
- G2CONF="${G2CONF}
- --disable-static
- --disable-more-warnings
- --localstatedir="${EPREFIX}"/var
- --docdir="${EPREFIX}"/usr/share/doc/${PF}
- $(use_enable doc docbook-docs)
- $(use_enable introspection)
- $(use_enable vala)
- $(use_enable systemd)
- $(systemd_with_unitdir)"
- gnome2_src_configure
-}