summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/cman/cman-1.02.00-r1.ebuild')
-rw-r--r--sys-cluster/cman/cman-1.02.00-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-cluster/cman/cman-1.02.00-r1.ebuild b/sys-cluster/cman/cman-1.02.00-r1.ebuild
new file mode 100644
index 000000000000..da9bd9fdf536
--- /dev/null
+++ b/sys-cluster/cman/cman-1.02.00-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cman/cman-1.02.00-r1.ebuild,v 1.1 2006/07/13 18:42:18 xmerlin Exp $
+
+inherit eutils
+
+CVS_RELEASE="20060713"
+MY_P="cluster-${PV}"
+
+DESCRIPTION="general-purpose symmetric cluster manager"
+HOMEPAGE="http://sources.redhat.com/cluster/"
+SRC_URI="ftp://sources.redhat.com/pub/cluster/releases/${MY_P}.tar.gz
+ mirror://gentoo/${PN}-${PV}-${CVS_RELEASE}-cvs.patch.gz
+ http://dev.gentoo.org/~xmerlin/gfs/${PN}-${PV}-${CVS_RELEASE}-cvs.patch.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=">=sys-cluster/ccs-1.02.00-r1
+ >=sys-cluster/cman-headers-1.02.00-r1"
+
+RDEPEND="virtual/libc"
+
+S="${WORKDIR}/${MY_P}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${WORKDIR}/${PN}-${PV}-${CVS_RELEASE}-cvs.patch || die
+}
+
+src_compile() {
+ ./configure || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ newinitd ${FILESDIR}/${PN}.rc ${PN} || die
+ newconfd ${FILESDIR}/${PN}.conf ${PN} || die
+}