aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2017-04-13 19:52:26 -0700
committerSteve Arnold <nerdboy@gentoo.org>2017-04-13 19:52:26 -0700
commitd4d7b907a8cf41c00e466483532cb58267916931 (patch)
treecefeefa3fd9ec21280fb15dc14616de6873779e2 /x11-libs/libdrm-armada
parentx11-libs/libdrm: update latest versions for foss graphics (diff)
downloadarm-d4d7b907a8cf41c00e466483532cb58267916931.tar.gz
arm-d4d7b907a8cf41c00e466483532cb58267916931.tar.bz2
arm-d4d7b907a8cf41c00e466483532cb58267916931.zip
x11-libs/libdrm-armada: add static-libs use flag and patch
Signed-off-by: Steve Arnold <nerdboy@gentoo.org>
Diffstat (limited to 'x11-libs/libdrm-armada')
-rw-r--r--x11-libs/libdrm-armada/files/libdrm-armada-fix-qa-add-missing-includes.patch14
-rw-r--r--x11-libs/libdrm-armada/libdrm-armada-9999.ebuild6
2 files changed, 18 insertions, 2 deletions
diff --git a/x11-libs/libdrm-armada/files/libdrm-armada-fix-qa-add-missing-includes.patch b/x11-libs/libdrm-armada/files/libdrm-armada-fix-qa-add-missing-includes.patch
new file mode 100644
index 0000000..31624a6
--- /dev/null
+++ b/x11-libs/libdrm-armada/files/libdrm-armada-fix-qa-add-missing-includes.patch
@@ -0,0 +1,14 @@
+diff --git a/armada_bufmgr.c b/armada_bufmgr.c
+index f552a31..341d29e 100644
+--- a/armada_bufmgr.c
++++ b/armada_bufmgr.c
+@@ -4,6 +4,9 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <errno.h>
++#include <sys/types.h>
++#include <unistd.h>
++#include <sys/ioctl.h>
+ #include <sys/fcntl.h>
+ #include <sys/mman.h>
+ #include <time.h>
diff --git a/x11-libs/libdrm-armada/libdrm-armada-9999.ebuild b/x11-libs/libdrm-armada/libdrm-armada-9999.ebuild
index a8122df..43a6710 100644
--- a/x11-libs/libdrm-armada/libdrm-armada-9999.ebuild
+++ b/x11-libs/libdrm-armada/libdrm-armada-9999.ebuild
@@ -5,6 +5,8 @@
EAPI=5
EGIT_REPO_URI="https://github.com/sarnold/libdrm-armada.git"
+## upstream doesn't have patch yet
+# git://git.armlinux.org.uk/~rmk/libdrm-armada.git
AUTOTOOLS_AUTORECONF=1
@@ -15,7 +17,7 @@ HOMEPAGE="http://git.armlinux.org.uk/cgit/libdrm-armada.git"
KEYWORDS="~arm ~arm-linux"
SLOT="0"
-IUSE=""
+IUSE="static-libs"
RDEPEND="media-libs/mesa[egl,gles1,gles2]"
@@ -25,7 +27,7 @@ DEPEND="${RDEPEND}
#AUTOTOOLS_IN_SOURCE_BUILD=1
src_configure() {
- autotools-utils_src_configure
+ autotools-utils_src_configure $(use_enable static-libs static)
}
src_compile() {