aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2018-04-12 23:02:22 -0700
committerSteve Arnold <nerdboy@gentoo.org>2018-04-12 23:02:22 -0700
commit831028d4bea272f79479abf936b0ce6fae8db737 (patch)
tree6984b62000a6a1dc099991c043ef7bc6da9008dd /x11-libs/libetnaviv/libetnaviv-20170616.ebuild
parentx11-base/xorg-drivers: remove old input drivers (diff)
downloadarm-831028d4bea272f79479abf936b0ce6fae8db737.tar.gz
arm-831028d4bea272f79479abf936b0ce6fae8db737.tar.bz2
arm-831028d4bea272f79479abf936b0ce6fae8db737.zip
x11-libs/libetnaviv: update keyeorded version, test xf86-video-armada
Signed-off-by: Steve Arnold <nerdboy@gentoo.org>
Diffstat (limited to 'x11-libs/libetnaviv/libetnaviv-20170616.ebuild')
-rw-r--r--x11-libs/libetnaviv/libetnaviv-20170616.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-libs/libetnaviv/libetnaviv-20170616.ebuild b/x11-libs/libetnaviv/libetnaviv-20170616.ebuild
new file mode 100644
index 0000000..f2ca84b
--- /dev/null
+++ b/x11-libs/libetnaviv/libetnaviv-20170616.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools
+
+MY_PN="${PN/_/}"
+P="${MY_PN}-${PV}"
+
+if [ "${PV}" = "99999999" ]; then
+ EGIT_REPO_URI="git://github.com/etnaviv/etna_viv"
+ inherit git-r3
+ EGIT_COMMIT="f64d77abbb54433bd5de955c20afddc6eb4f4cb1"
+ KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.gz"
+ KEYWORDS="~arm"
+fi
+
+DESCRIPTION="FOSS driver headers for the Vivante GCxxx series of embedded GPUs"
+HOMEPAGE="https://github.com/etnaviv/etna_viv"
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND=">=x11-libs/libdrm-2.4.74:=[video_cards_vivante]
+ virtual/pkgconfig"
+
+MERGE_TYPE="binary"
+
+src_install() {
+ insinto /usr/include/etnaviv
+ doins src/etnaviv/*.h attic/etnaviv/*.h
+}
+