aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2017-04-13 19:21:48 -0700
committerSteve Arnold <nerdboy@gentoo.org>2017-04-13 19:21:48 -0700
commitb0634433de8853df924c98fb7f119689a6db74e1 (patch)
tree528320dd17d3d2b2e351150fe56957d3095c55e0 /x11-libs/libetnaviv/libetnaviv-99999999.ebuild
parentvirtual/opengl: update keywords (diff)
downloadarm-b0634433de8853df924c98fb7f119689a6db74e1.tar.gz
arm-b0634433de8853df924c98fb7f119689a6db74e1.tar.bz2
arm-b0634433de8853df924c98fb7f119689a6db74e1.zip
x11-libs/libetnaviv: add "version" to get full legacy library
Signed-off-by: Steve Arnold <nerdboy@gentoo.org>
Diffstat (limited to 'x11-libs/libetnaviv/libetnaviv-99999999.ebuild')
-rw-r--r--x11-libs/libetnaviv/libetnaviv-99999999.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-libs/libetnaviv/libetnaviv-99999999.ebuild b/x11-libs/libetnaviv/libetnaviv-99999999.ebuild
new file mode 100644
index 0000000..fe7549f
--- /dev/null
+++ b/x11-libs/libetnaviv/libetnaviv-99999999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools
+
+MY_PN="${PN/_/}"
+P="${MY_PN}-${PV}"
+
+if [ "${PV}" = "99999999" ]; then
+ EGIT_REPO_URI="git://github.com/etnaviv/etna_viv"
+ inherit git-r3
+ KEYWORDS=""
+ IUSE="src"
+else
+ # this commit is 1 before the attic-move; if you want to try
+ # building the src, you might start here...
+ COMMIT_ID="3815bcc09ccef173987f2d346a947a9b7e502762"
+ SRC_URI="https://github.com/etnaviv/${PN}/archive/${COMMIT_ID}.tar.gz -> ${P}-git.tar.gz"
+ KEYWORDS="~arm"
+ IUSE=""
+ S=${WORKDIR}/${PN}-${COMMIT_ID}
+fi
+
+DESCRIPTION="FOSS driver headers for the Vivante GCxxx series of embedded GPUs"
+HOMEPAGE="https://github.com/etnaviv/etna_viv"
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND=">=x11-libs/libdrm-2.4.74:=[video_cards_vivante]
+ virtual/pkgconfig"
+
+MERGE_TYPE="binary"
+
+#S="${WORKDIR}/${P}"
+
+src_install() {
+ insinto /usr/include/etnaviv
+
+ if use src; then
+ doins -r src attic
+ else
+ doins src/etnaviv/*.h attic/etnaviv/*.h
+ fi
+}
+