aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-libs/libetnaviv/libetnaviv-9999.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-libs/libetnaviv/libetnaviv-9999.ebuild b/x11-libs/libetnaviv/libetnaviv-9999.ebuild
new file mode 100644
index 0000000..7123d31
--- /dev/null
+++ b/x11-libs/libetnaviv/libetnaviv-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools
+
+MY_PN="${PN/_/}"
+P="${MY_PN}-${PV}"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="git://github.com/etnaviv/etna_viv"
+ inherit git-r3
+ KEYWORDS="~arm"
+else
+ # this commit is 1 before the attic-move; if you want to try
+ # building the src, you might start here...
+ COMMIT_ID="3815bcc09ccef173987f2d346a947a9b7e502762"
+ SRC_URI="https://github.com/etnaviv/${PN}/archive/${COMMIT_ID}.tar.gz -> ${P}-git.tar.gz"
+ KEYWORDS="~arm"
+ IUSE=""
+ S=${WORKDIR}/${PN}-${COMMIT_ID}
+fi
+
+DESCRIPTION="FOSS driver headers for the Vivante GCxxx series of embedded GPUs"
+HOMEPAGE="https://github.com/etnaviv/etna_viv"
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND=">=x11-libs/libdrm-2.4.74:=[video_cards_vivante]
+ virtual/pkgconfig"
+
+MERGE_TYPE="binary"
+
+#S="${WORKDIR}/${P}"
+
+src_install() {
+ insinto /usr/include/etnaviv
+ doins src/etnaviv/*.h attic/etnaviv/*.h
+}
+