aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-20 01:44:18 +0000
committerSam James <sam@gentoo.org>2022-07-20 01:44:18 +0000
commit7fffbe38e2f6cca5b91a5d52a94ae11489586008 (patch)
treef28fedfb76ba05f19537b2a3285af90b89940592
parentdev-util/mono-docbrowser: treeclean (broken) (diff)
downloaddotnet-7fffbe38e2f6cca5b91a5d52a94ae11489586008.tar.gz
dotnet-7fffbe38e2f6cca5b91a5d52a94ae11489586008.tar.bz2
dotnet-7fffbe38e2f6cca5b91a5d52a94ae11489586008.zip
dev-dotnet/nuget: drop 2.8.1, 2.8.3, 2.8.7, 2.8.7-r1, 2.8.7-r2
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-dotnet/nuget/Manifest4
-rw-r--r--dev-dotnet/nuget/nuget-2.8.1.ebuild62
-rw-r--r--dev-dotnet/nuget/nuget-2.8.3.ebuild63
-rw-r--r--dev-dotnet/nuget/nuget-2.8.7-r1.ebuild62
-rw-r--r--dev-dotnet/nuget/nuget-2.8.7-r2.ebuild64
-rw-r--r--dev-dotnet/nuget/nuget-2.8.7.ebuild61
6 files changed, 1 insertions, 315 deletions
diff --git a/dev-dotnet/nuget/Manifest b/dev-dotnet/nuget/Manifest
index c839c59..9d93024 100644
--- a/dev-dotnet/nuget/Manifest
+++ b/dev-dotnet/nuget/Manifest
@@ -1,3 +1 @@
-DIST nuget-2.8.1.tar.gz 12467801 SHA256 f08e408ff2d672f1d83251564c0b8bf9d37508d785d3e05ee737c91116a9aed8 SHA512 c512ee324f97d814d18435712c22a78f9f036eed6889fd3d7e89736579112266c8a708050270b0ac9a08dbe0920f8bacfd331eb798ee00c60d46583352014bc8 WHIRLPOOL 12ed23551ea690343366a6b3777c6868576d0dd441ce6e0a9d398a91e682af2a82705794ba2b25a459a2db0c74a6edb8714f3b3c255a69f3759f1d85ac9f016c
-DIST nuget-2.8.3.tar.gz 14240757 SHA256 8ca0cc2e3ec753338472011c8591c2e4d924e81bd12d9fab1c24d5a4903c61ec SHA512 a1447042f77fdb0d63caaf49d64208ac0ab072ab1caf7f5edaeb936f3e26fac7ad80c3af51b12086cb2b9bb63df32e8da244894c4cd4946373ff86cb7a4e130d WHIRLPOOL cc4cb8fb7f8e92f756c5aa05022e6cca843cace591cfe3f8ea585f286d4002eb8b255cf8946cd9c3e3b3945480ddfe30868b4ad1e069329bb59f8b37051cf990
-DIST nuget-2.8.7.tar.gz 22865700 SHA256 9e1328392a49e71a68c8b7a3130a2835a2303f7757ccc9d4f44f87bc40f8f94d SHA512 5a658d801aa6486e04f559c0924208de3791b2e4f86ff8b412c886becd5647608a1a9a3907dff0b766a4bb57c9897dfca78e66076265dbdacb6b14d571bfc4b5 WHIRLPOOL 39df814213007302718b5d8bd4954d999652839c18be1c7d8c862fff46eb97eebda8786cffa6aae43774655671a025a6bfdb2189f2ba358483508971a91cc809
+DIST nuget-2.8.7.tar.gz 22865700 BLAKE2B c8024571a74e4ea4f1b3be006883c1053527a8cfec4599468df25db79e788fe2d42b611f720b4134b485e1ad3761ad0368d108fc39acdba3d934e27e2429c507 SHA512 5a658d801aa6486e04f559c0924208de3791b2e4f86ff8b412c886becd5647608a1a9a3907dff0b766a4bb57c9897dfca78e66076265dbdacb6b14d571bfc4b5
diff --git a/dev-dotnet/nuget/nuget-2.8.1.ebuild b/dev-dotnet/nuget/nuget-2.8.1.ebuild
deleted file mode 100644
index 8f87e89..0000000
--- a/dev-dotnet/nuget/nuget-2.8.1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_DOTNET="net45"
-
-inherit dotnet eutils gac
-
-DESCRIPTION="Nuget - .NET Package Manager"
-HOMEPAGE="https://nuget.codeplex.com"
-SRC_URI="https://github.com/mrward/nuget/archive/Release-${PV}-MonoDevelop.tar.gz -> ${P}.tar.gz"
-S=${WORKDIR}/nuget-Release-${PV}-MonoDevelop
-
-LICENSE="Apache-2.0"
-SLOT="0"
-
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-# Mask 3.2.0 because of mcs compiler bug : https://stackoverflow.com/a/17926731/238232
-# it fixed in 3.2.3
-DEPEND=">=dev-lang/mono-3.2.3
- <=dev-dotnet/xdt-for-monodevelop-2.8.2
- !dev-dotnet/nuget"
-RDEPEND="${DEPEND}"
-
-# note about blocking nuget:
-# there are at least two versions of it - on from mono, one from mrward
-# see https://bugzilla.xamarin.com/show_bug.cgi?id=27693
-# i think version from mrward is enough for now,
-# that is why there is no slotted install or two different names/locations
-
-pkg_setup() {
- dotnet_pkg_setup
- mozroots --import --sync --machine
-}
-
-src_prepare() {
- sed -i -e 's@RunTests@ @g' "${S}/Build/Build.proj" || die
- cp "${FILESDIR}/rsa-4096.snk" "${S}/src/Core/" || die
- epatch "${FILESDIR}/add-keyfile-option-to-csproj.patch"
- sed -i -E -e "s#(\[assembly: InternalsVisibleTo(.*)\])#/* \1 */#g" "src/Core/Properties/AssemblyInfo.cs" || die
- epatch "${FILESDIR}/strongnames-for-ebuild-2.8.1.patch"
-}
-
-src_configure() {
- export EnableNuGetPackageRestore="true"
-}
-
-src_compile() {
-# xbuild Build/Build.proj /p:Configuration=Release /p:TreatWarningsAsErrors=false /tv:4.0 /p:TargetFrameworkVersion="v${FRAMEWORK}" /p:Configuration="Mono Release" /t:GoMono || die
- source ./build.sh || die
-}
-
-src_install() {
- elog "Installing NuGet.Core.dll into GAC"
- egacinstall "src/Core/obj/Mono Release/NuGet.Core.dll"
- elog "Installing NuGet console application"
- insinto /usr/lib/mono/NuGet/"${FRAMEWORK}"/
- doins src/CommandLine/obj/Mono\ Release/NuGet.exe
- make_wrapper nuget "mono /usr/lib/mono/NuGet/${FRAMEWORK}/NuGet.exe"
-}
diff --git a/dev-dotnet/nuget/nuget-2.8.3.ebuild b/dev-dotnet/nuget/nuget-2.8.3.ebuild
deleted file mode 100644
index 2115fb1..0000000
--- a/dev-dotnet/nuget/nuget-2.8.3.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_DOTNET="net45"
-
-inherit dotnet eutils gac
-
-DESCRIPTION="Nuget - .NET Package Manager"
-HOMEPAGE="https://nuget.codeplex.com"
-SRC_URI="https://github.com/mrward/nuget/archive/Release-${PV}-MonoDevelop.tar.gz -> ${P}.tar.gz"
-S=${WORKDIR}/nuget-Release-${PV}-MonoDevelop
-
-LICENSE="Apache-2.0"
-SLOT="0"
-
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-# Mask 3.2.0 because of mcs compiler bug : https://stackoverflow.com/a/17926731/238232
-# it fixed in 3.2.3
-DEPEND=">=dev-lang/mono-3.2.3
- <=dev-dotnet/xdt-for-monodevelop-2.8.2
- !dev-dotnet/nuget-codeplex"
-RDEPEND="${DEPEND}"
-
-# note about blocking nuget:
-# there are at least two versions of it - on from mono, one from mrward
-# see https://bugzilla.xamarin.com/show_bug.cgi?id=27693
-# i think version from mrward is enough for now,
-# that is why there is no slotted install or two different names/locations
-
-pkg_setup() {
- addwrite "/usr/share/.mono/keypairs"
- dotnet_pkg_setup
- mozroots --import --sync --machine
-}
-
-src_prepare() {
- sed -i -e 's@RunTests@ @g' "${S}/Build/Build.proj" || die
- cp "${FILESDIR}/rsa-4096.snk" "${S}/src/Core/" || die
- epatch "${FILESDIR}/add-keyfile-option-to-csproj.patch"
- sed -i -E -e "s#(\[assembly: InternalsVisibleTo(.*)\])#/* \1 */#g" "src/Core/Properties/AssemblyInfo.cs" || die
- epatch "${FILESDIR}/strongnames-for-ebuild-2.8.1.patch"
-}
-
-src_configure() {
- export EnableNuGetPackageRestore="true"
-}
-
-src_compile() {
-# xbuild Build/Build.proj /p:Configuration=Release /p:TreatWarningsAsErrors=false /tv:4.0 /p:TargetFrameworkVersion="v${FRAMEWORK}" /p:Configuration="Mono Release" /t:GoMono || die
- source ./build.sh || die
-}
-
-src_install() {
- elog "Installing NuGet.Core.dll into GAC"
- egacinstall "src/Core/obj/Mono Release/NuGet.Core.dll"
- elog "Installing NuGet console application"
- insinto /usr/lib/mono/NuGet/"${FRAMEWORK}"/
- doins src/CommandLine/obj/Mono\ Release/NuGet.exe
- make_wrapper nuget "mono /usr/lib/mono/NuGet/${FRAMEWORK}/NuGet.exe"
-}
diff --git a/dev-dotnet/nuget/nuget-2.8.7-r1.ebuild b/dev-dotnet/nuget/nuget-2.8.7-r1.ebuild
deleted file mode 100644
index 679c402..0000000
--- a/dev-dotnet/nuget/nuget-2.8.7-r1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_DOTNET="net45"
-
-inherit dotnet eutils gac
-
-# This ebuild provides a forked version of nuget modified to work with MonoDevelop.
-# See https://bugzilla.xamarin.com/show_bug.cgi?id=27693
-# dev-dotnet/nuget-codeplex provides the upstream version.
-
-DESCRIPTION="Nuget - .NET Package Manager"
-HOMEPAGE="https://nuget.codeplex.com"
-SRC_URI="https://github.com/mrward/nuget/archive/Release-${PV}-MonoDevelop.tar.gz -> ${P}.tar.gz"
-S=${WORKDIR}/nuget-Release-${PV}-MonoDevelop
-
-LICENSE="Apache-2.0"
-SLOT="0"
-
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-# Mask 3.2.0 because of mcs compiler bug : https://stackoverflow.com/a/17926731/238232
-# it fixed in 3.2.3
-DEPEND=">=dev-lang/mono-3.2.3
- <=dev-dotnet/xdt-for-monodevelop-2.8.2
- !dev-dotnet/nuget-codeplex
- app-misc/ca-certificates"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- addwrite "/usr/share/.mono/keypairs"
- dotnet_pkg_setup
- cert-sync /etc/ssl/certs/ca-certificates.crt
-}
-
-src_prepare() {
- sed -i -e 's@RunTests@ @g' "${S}/Build/Build.proj" || die
- cp "${FILESDIR}/rsa-4096.snk" "${S}/src/Core/" || die
- epatch "${FILESDIR}/add-keyfile-option-to-csproj.patch"
- sed -i -E -e "s#(\[assembly: InternalsVisibleTo(.*)\])#/* \1 */#g" "src/Core/Properties/AssemblyInfo.cs" || die
- epatch "${FILESDIR}/strongnames-for-ebuild-2.8.1.patch"
-}
-
-src_configure() {
- export EnableNuGetPackageRestore="true"
-}
-
-src_compile() {
-# xbuild Build/Build.proj /p:Configuration=Release /p:TreatWarningsAsErrors=false /tv:4.0 /p:TargetFrameworkVersion="v${FRAMEWORK}" /p:Configuration="Mono Release" /t:GoMono || die
- source ./build.sh || die
-}
-
-src_install() {
- elog "Installing NuGet.Core.dll into GAC"
- egacinstall "src/Core/obj/Mono Release/NuGet.Core.dll"
- elog "Installing NuGet console application"
- insinto /usr/lib/mono/NuGet/"${FRAMEWORK}"/
- doins src/CommandLine/obj/Mono\ Release/NuGet.exe
- make_wrapper nuget "mono /usr/lib/mono/NuGet/${FRAMEWORK}/NuGet.exe"
-}
diff --git a/dev-dotnet/nuget/nuget-2.8.7-r2.ebuild b/dev-dotnet/nuget/nuget-2.8.7-r2.ebuild
deleted file mode 100644
index 5ae6f39..0000000
--- a/dev-dotnet/nuget/nuget-2.8.7-r2.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-KEYWORDS="~amd64 ~x86"
-
-USE_DOTNET="net45"
-
-inherit dotnet eutils gac
-
-# This ebuild provides a forked version of nuget modified to work with MonoDevelop.
-# See https://bugzilla.xamarin.com/show_bug.cgi?id=27693
-# dev-dotnet/nuget-codeplex provides the upstream version.
-
-DESCRIPTION="Nuget - .NET Package Manager"
-HOMEPAGE="https://nuget.codeplex.com"
-SRC_URI="https://github.com/mrward/nuget/archive/Release-${PV}-MonoDevelop.tar.gz -> ${P}.tar.gz"
-S=${WORKDIR}/nuget-Release-${PV}-MonoDevelop
-
-LICENSE="Apache-2.0"
-SLOT="0"
-
-IUSE=""
-
-# Mask 3.2.0 because of mcs compiler bug : https://stackoverflow.com/a/17926731/238232
-# it fixed in 3.2.3
-DEPEND=">=dev-lang/mono-3.2.3
- <=dev-dotnet/xdt-for-monodevelop-2.8.2[gac]
- !dev-dotnet/nuget-codeplex
- app-misc/ca-certificates"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- addwrite "/usr/share/.mono/keypairs"
- dotnet_pkg_setup
- cert-sync /etc/ssl/certs/ca-certificates.crt
-}
-
-src_prepare() {
- sed -i -e 's@RunTests@ @g' "${S}/Build/Build.proj" || die
- cp "${FILESDIR}/rsa-4096.snk" "${S}/src/Core/" || die
- eapply "${FILESDIR}/add-keyfile-option-to-csproj-r2.patch"
- sed -i -E -e "s#(\[assembly: InternalsVisibleTo(.*)\])#/* \1 */#g" "src/Core/Properties/AssemblyInfo.cs" || die
- eapply "${FILESDIR}/strongnames-for-ebuild-2.8.1-r2.patch"
- default
-}
-
-src_configure() {
- export EnableNuGetPackageRestore="true"
-}
-
-src_compile() {
-# xbuild Build/Build.proj /p:Configuration=Release /p:TreatWarningsAsErrors=false /tv:4.0 /p:TargetFrameworkVersion="v${FRAMEWORK}" /p:Configuration="Mono Release" /t:GoMono || die
- source ./build.sh || die
-}
-
-src_install() {
- elog "Installing NuGet.Core.dll into GAC"
- egacinstall "src/Core/obj/Mono Release/NuGet.Core.dll"
- elog "Installing NuGet console application"
- insinto /usr/lib/mono/NuGet/"${FRAMEWORK}"/
- doins src/CommandLine/obj/Mono\ Release/NuGet.exe
- make_wrapper nuget "mono /usr/lib/mono/NuGet/${FRAMEWORK}/NuGet.exe"
-}
diff --git a/dev-dotnet/nuget/nuget-2.8.7.ebuild b/dev-dotnet/nuget/nuget-2.8.7.ebuild
deleted file mode 100644
index 0e51f5a..0000000
--- a/dev-dotnet/nuget/nuget-2.8.7.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_DOTNET="net45"
-
-inherit dotnet eutils gac
-
-# This ebuild provides a forked version of nuget modified to work with MonoDevelop.
-# See https://bugzilla.xamarin.com/show_bug.cgi?id=27693
-# dev-dotnet/nuget-codeplex provides the upstream version.
-
-DESCRIPTION="Nuget - .NET Package Manager"
-HOMEPAGE="https://nuget.codeplex.com"
-SRC_URI="https://github.com/mrward/nuget/archive/Release-${PV}-MonoDevelop.tar.gz -> ${P}.tar.gz"
-S=${WORKDIR}/nuget-Release-${PV}-MonoDevelop
-
-LICENSE="Apache-2.0"
-SLOT="0"
-
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-# Mask 3.2.0 because of mcs compiler bug : https://stackoverflow.com/a/17926731/238232
-# it fixed in 3.2.3
-DEPEND=">=dev-lang/mono-3.2.3
- <=dev-dotnet/xdt-for-monodevelop-2.8.2
- !dev-dotnet/nuget-codeplex"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- addwrite "/usr/share/.mono/keypairs"
- dotnet_pkg_setup
- mozroots --import --sync --machine
-}
-
-src_prepare() {
- sed -i -e 's@RunTests@ @g' "${S}/Build/Build.proj" || die
- cp "${FILESDIR}/rsa-4096.snk" "${S}/src/Core/" || die
- epatch "${FILESDIR}/add-keyfile-option-to-csproj.patch"
- sed -i -E -e "s#(\[assembly: InternalsVisibleTo(.*)\])#/* \1 */#g" "src/Core/Properties/AssemblyInfo.cs" || die
- epatch "${FILESDIR}/strongnames-for-ebuild-2.8.1.patch"
-}
-
-src_configure() {
- export EnableNuGetPackageRestore="true"
-}
-
-src_compile() {
-# xbuild Build/Build.proj /p:Configuration=Release /p:TreatWarningsAsErrors=false /tv:4.0 /p:TargetFrameworkVersion="v${FRAMEWORK}" /p:Configuration="Mono Release" /t:GoMono || die
- source ./build.sh || die
-}
-
-src_install() {
- elog "Installing NuGet.Core.dll into GAC"
- egacinstall "src/Core/obj/Mono Release/NuGet.Core.dll"
- elog "Installing NuGet console application"
- insinto /usr/lib/mono/NuGet/"${FRAMEWORK}"/
- doins src/CommandLine/obj/Mono\ Release/NuGet.exe
- make_wrapper nuget "mono /usr/lib/mono/NuGet/${FRAMEWORK}/NuGet.exe"
-}