aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsenShnurkov <Arsen.Shnurkov@gmail.com>2016-08-18 23:29:23 +0300
committerArsenShnurkov <Arsen.Shnurkov@gmail.com>2016-08-18 23:29:23 +0300
commita5e86f39103c1d30d964e3ef751d6724683d2cca (patch)
tree248bec51d34b2e3eaefecb746c4ed449090904d7 /dev-dotnet/eto-parse
parentnuspec version is now 1.4.0.201509070 (diff)
downloaddotnet-a5e86f39103c1d30d964e3ef751d6724683d2cca.tar.gz
dotnet-a5e86f39103c1d30d964e3ef751d6724683d2cca.tar.bz2
dotnet-a5e86f39103c1d30d964e3ef751d6724683d2cca.zip
adding to gac
Diffstat (limited to 'dev-dotnet/eto-parse')
-rw-r--r--dev-dotnet/eto-parse/eto-parse-1.4.0_p20150907.ebuild23
1 files changed, 12 insertions, 11 deletions
diff --git a/dev-dotnet/eto-parse/eto-parse-1.4.0_p20150907.ebuild b/dev-dotnet/eto-parse/eto-parse-1.4.0_p20150907.ebuild
index 5efd728..743beff 100644
--- a/dev-dotnet/eto-parse/eto-parse-1.4.0_p20150907.ebuild
+++ b/dev-dotnet/eto-parse/eto-parse-1.4.0_p20150907.ebuild
@@ -3,8 +3,12 @@
# $Id$
EAPI=6
+
+USE_DOTNET="net45"
inherit mono-env dotnet gac nupkg
+IUSE="${USE_DOTNET} developer nupkg debug"
+
NAME="Eto.Parse"
HOMEPAGE="https://github.com/picoe/${NAME}"
@@ -22,8 +26,6 @@ KEYWORDS="~amd64 ~x86"
# notes on testing, from https://devmanual.gentoo.org/ebuild-writing/functions/src_test/index.html
# FEATURES+="test"
-USE_DOTNET="net45"
-IUSE="${USE_DOTNET} developer nupkg debug"
# there is no "test" in IUSE, because test project and solution are not build
# there is no "gac" in IUSE, because utilities for patching are not ready
@@ -93,7 +95,7 @@ src_prepare() {
}
src_compile() {
- exbuild "${METAFILETOBUILD}"
+ exbuild_strong "${METAFILETOBUILD}"
enuspec "${NUSPEC_FILE}"
}
@@ -104,14 +106,13 @@ src_test() {
}
src_install() {
- # ebuild is not ready for gac install
- #DIR=""
- #if use debug; then
- # DIR="Debug"
- #else
- # DIR="Release"
- #fi
- # egacinstall "Eto.Parse/bin/${DIR}/net40/Eto.Parse.dll"
+ DIR=""
+ if use debug; then
+ DIR="Debug"
+ else
+ DIR="Release"
+ fi
+ egacinstall "Eto.Parse/bin/${DIR}/net40/Eto.Parse.dll"
enupkg "${WORKDIR}/${NAME}.${NUSPEC_VERSION}.nupkg"
}