aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsenShnurkov <ArsenShnurkov@users.noreply.github.com>2017-10-30 20:38:28 +0300
committerArsenShnurkov <ArsenShnurkov@users.noreply.github.com>2017-10-30 20:38:28 +0300
commit6b3bd2685edd99bf254dfbfa71e9c06161b1dcaf (patch)
treea129a67e26f52d4df99e64b43fdfa6f59f5d4bf8 /dev-dotnet/techtalk-specflow
parentdigest created (diff)
downloaddotnet-6b3bd2685edd99bf254dfbfa71e9c06161b1dcaf.tar.gz
dotnet-6b3bd2685edd99bf254dfbfa71e9c06161b1dcaf.tar.bz2
dotnet-6b3bd2685edd99bf254dfbfa71e9c06161b1dcaf.zip
compilation implemented
Diffstat (limited to 'dev-dotnet/techtalk-specflow')
-rw-r--r--dev-dotnet/techtalk-specflow/files/TechTalk.SpecFlow-1.2.0.0.csproj92
-rw-r--r--dev-dotnet/techtalk-specflow/techtalk-specflow-1.2.0.0.ebuild4
2 files changed, 94 insertions, 2 deletions
diff --git a/dev-dotnet/techtalk-specflow/files/TechTalk.SpecFlow-1.2.0.0.csproj b/dev-dotnet/techtalk-specflow/files/TechTalk.SpecFlow-1.2.0.0.csproj
new file mode 100644
index 0000000..ef9eacb
--- /dev/null
+++ b/dev-dotnet/techtalk-specflow/files/TechTalk.SpecFlow-1.2.0.0.csproj
@@ -0,0 +1,92 @@
+<?xml version="1.0" encoding="utf-8"?>
+<Project ToolsVersion="3.5" DefaultTargets="Build" xmlns="http://schemas.microsoft.com/developer/msbuild/2003">
+ <PropertyGroup>
+ <Configuration Condition=" '$(Configuration)' == '' ">Debug</Configuration>
+ <Platform Condition=" '$(Platform)' == '' ">AnyCPU</Platform>
+ <ProjectGuid>{413EE28C-4F89-4C6F-BA1E-2CDEE4CD43B4}</ProjectGuid>
+ <OutputType>Library</OutputType>
+ <AppDesignerFolder>Properties</AppDesignerFolder>
+ <RootNamespace>TechTalk.SpecFlow</RootNamespace>
+ <AssemblyName>TechTalk.SpecFlow</AssemblyName>
+ </PropertyGroup>
+ <PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Debug|AnyCPU' ">
+ <DebugSymbols>true</DebugSymbols>
+ <DebugType>full</DebugType>
+ <Optimize>false</Optimize>
+ <OutputPath>bin\Debug\</OutputPath>
+ <DefineConstants>DEBUG;TRACE</DefineConstants>
+ <ErrorReport>prompt</ErrorReport>
+ <WarningLevel>4</WarningLevel>
+ </PropertyGroup>
+ <PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Release|AnyCPU' ">
+ <DebugType>pdbonly</DebugType>
+ <Optimize>true</Optimize>
+ <OutputPath>bin\Release\</OutputPath>
+ <DefineConstants>TRACE</DefineConstants>
+ <ErrorReport>prompt</ErrorReport>
+ <WarningLevel>4</WarningLevel>
+ </PropertyGroup>
+ <ItemGroup>
+ <Reference Include="System" />
+ <Reference Include="System.Configuration" />
+ <Reference Include="System.Core" />
+ <Reference Include="System.Xml.Linq" />
+ <Reference Include="System.Data.DataSetExtensions" />
+ <Reference Include="System.Data" />
+ <Reference Include="System.Xml" />
+ </ItemGroup>
+ <ItemGroup>
+ <Compile Include="..\VersionInfo.cs">
+ <Link>VersionInfo.cs</Link>
+ </Compile>
+ <Compile Include="StepArgumentTypeConverter.cs" />
+ <Compile Include="Attributes.cs" />
+ <Compile Include="ErrorHandling\BindingException.cs" />
+ <Compile Include="BindingMatch.cs" />
+ <Compile Include="BindingRegistry.cs" />
+ <Compile Include="BindingType.cs" />
+ <Compile Include="Configuration\ConfigurationSectionHandler.cs" />
+ <Compile Include="Configuration\RuntimeConfiguration.cs" />
+ <Compile Include="ErrorHandling\MissingStepDefinitionException.cs" />
+ <Compile Include="ErrorHandling\PendingStepException.cs" />
+ <Compile Include="ErrorHandling\SpecFlowException.cs" />
+ <Compile Include="EventBinding.cs" />
+ <Compile Include="FeatureContext.cs" />
+ <Compile Include="FeatureInfo.cs" />
+ <Compile Include="ITestRunner.cs" />
+ <Compile Include="SpecFlowContext.cs" />
+ <Compile Include="StepArgs.cs" />
+ <Compile Include="StringExtensions.cs" />
+ <Compile Include="Tracing\DefaultListener.cs" />
+ <Compile Include="ErrorHandling\ErrorProvider.cs" />
+ <Compile Include="Tracing\LanguageHelper.cs" />
+ <Compile Include="Tracing\StepDefinitonSkeletonProvider.cs" />
+ <Compile Include="Tracing\StepFormatter.cs" />
+ <Compile Include="UnitTestProvider\MsTestRuntimeProvider.cs" />
+ <Compile Include="UnitTestProvider\NUnitRuntimeProvider.cs" />
+ <Compile Include="ScenarioContext.cs" />
+ <Compile Include="ScenarioBlock.cs" />
+ <Compile Include="ScenarioInfo.cs" />
+ <Compile Include="StepBinding.cs" />
+ <Compile Include="Table.cs" />
+ <Compile Include="TestRunner.cs" />
+ <Compile Include="Properties\AssemblyInfo.cs" />
+ <Compile Include="ObjectContainer.cs" />
+ <Compile Include="Tracing\TestTracer.cs" />
+ <Compile Include="UnitTestProvider\IUnitTestRuntimeProvider.cs" />
+ <Compile Include="Tracing\ITraceListener.cs" />
+ </ItemGroup>
+ <ItemGroup>
+ <EmbeddedResource Include="..\Languages.xml">
+ <Link>Languages.xml</Link>
+ </EmbeddedResource>
+ </ItemGroup>
+ <Import Project="$(MSBuildToolsPath)\Microsoft.CSharp.targets" />
+ <!-- To modify your build process, add your task inside one of the targets below and uncomment it.
+ Other similar extension points exist, see Microsoft.Common.targets.
+ <Target Name="BeforeBuild">
+ </Target>
+ <Target Name="AfterBuild">
+ </Target>
+ -->
+</Project> \ No newline at end of file
diff --git a/dev-dotnet/techtalk-specflow/techtalk-specflow-1.2.0.0.ebuild b/dev-dotnet/techtalk-specflow/techtalk-specflow-1.2.0.0.ebuild
index 0dbd17d..427e485 100644
--- a/dev-dotnet/techtalk-specflow/techtalk-specflow-1.2.0.0.ebuild
+++ b/dev-dotnet/techtalk-specflow/techtalk-specflow-1.2.0.0.ebuild
@@ -30,7 +30,7 @@ RDEPEND="${CDEPEND}
DEPEND="${CDEPEND}
"
-PATH_TO_PROJ="TechTalk.SpecFlow"
+PATH_TO_PROJ="Runtime"
METAFILE_TO_BUILD="TechTalk.SpecFlow"
ASSEMBLY_NAME="TechTalk.SpecFlow"
@@ -48,7 +48,7 @@ function output_filename ( ) {
}
src_prepare() {
- #cp "${FILESDIR}/${METAFILE_TO_BUILD}-${PV}.csproj" "${S}/${PATH_TO_PROJ}/${METAFILE_TO_BUILD}.csproj" || die
+ cp "${FILESDIR}/${METAFILE_TO_BUILD}-${PV}.csproj" "${S}/${PATH_TO_PROJ}/${METAFILE_TO_BUILD}.csproj" || die
#cp "${FILESDIR}/CommonAssemblyInfo-${PV}.cs" "${S}/${PATH_TO_PROJ}/../CommonAssemblyInfo.cs" || die
eapply_user
}