aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormpkh <cynede@gentoo.org>2017-11-01 21:54:28 +0400
committerGitHub <noreply@github.com>2017-11-01 21:54:28 +0400
commitf65f7141ea71957bcd872e828699247100bbcb4c (patch)
treea95704393b47b939338799a15cb848b37c558653 /dev-dotnet
parentMerge pull request #350 from ArsenShnurkov/msbuildtasks (diff)
parentcompilation completed (diff)
downloaddotnet-f65f7141ea71957bcd872e828699247100bbcb4c.tar.gz
dotnet-f65f7141ea71957bcd872e828699247100bbcb4c.tar.bz2
dotnet-f65f7141ea71957bcd872e828699247100bbcb4c.zip
Merge pull request #351 from ArsenShnurkov/CastleDynamicProxy
dev-dotnet/castle-dynamicproxy
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/castle-dynamicproxy/Manifest2
-rw-r--r--dev-dotnet/castle-dynamicproxy/castle-dynamicproxy-2.1.0.0.ebuild115
-rw-r--r--dev-dotnet/castle-dynamicproxy/files/Castle.Core-vs2008-2.1.0.0.csproj45
-rw-r--r--dev-dotnet/castle-dynamicproxy/files/Castle.DynamicProxy-vs2008-2.1.0.0.csproj49
-rw-r--r--dev-dotnet/castle-dynamicproxy/metadata.xml14
5 files changed, 225 insertions, 0 deletions
diff --git a/dev-dotnet/castle-dynamicproxy/Manifest b/dev-dotnet/castle-dynamicproxy/Manifest
new file mode 100644
index 0000000..6f4ac2d
--- /dev/null
+++ b/dev-dotnet/castle-dynamicproxy/Manifest
@@ -0,0 +1,2 @@
+DIST castle-dynamicproxy-2.1.0.0.tar.gz 14675360 SHA256 c7da835231db28932c7badac60cd608e5ecc4cf3f5df93293550cd6167b3c9cd SHA512 475fce0def23ac83f7933c3b6383775a3abf122c94fb82424ee3c50f11e89db79f79e3afd5b70c755ee91fbb871dd97583a1d9cef842a43f9bb021bc6ca49588 WHIRLPOOL 834cabee0c3e5cbe859d1e3bb7224b8a01bf847707c93048fa9b70df49de9a86ed08ecd5de89bc549135db895f055ed220a869090b026d81d330eff6c1cce0c2
+DIST mono.snk 596 SHA256 44a83944d57c37da4e7872967f1fd4b445af18cdcbe8d17a0e3f5e5ce553c78a SHA512 7f3c4a3bd3eb64769a24be714f603d2c69642d8ff636792b9fb57a5be9b93479d8fbb6872e3243cdc4cc50d9dfc402f55910da339b46e2caf307c59124547541 WHIRLPOOL ad49dd306d751e2b36c0dc87c3d0330efcd380a32526ebb797cd05176066d45fdfbf93b1e4e52c5419ba769557fffa16ed3960b9bdce563f610fe37d4d4d9d67
diff --git a/dev-dotnet/castle-dynamicproxy/castle-dynamicproxy-2.1.0.0.ebuild b/dev-dotnet/castle-dynamicproxy/castle-dynamicproxy-2.1.0.0.ebuild
new file mode 100644
index 0000000..2387629
--- /dev/null
+++ b/dev-dotnet/castle-dynamicproxy/castle-dynamicproxy-2.1.0.0.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+KEYWORDS="~amd64 ~x86"
+
+RESTRICT="mirror"
+
+SLOT="0"
+
+USE_DOTNET="net45"
+inherit msbuild gac
+IUSE="+${USE_DOTNET}"
+
+NAME="Core"
+HOMEPAGE="http://www.castleproject.org"
+
+EGIT_COMMIT="9a033d8a69535e9078a3344e1ceddf18b60f9324"
+SRC_URI="https://github.com/castleproject/${NAME}/archive/${EGIT_COMMIT}.tar.gz -> ${PF}.tar.gz
+ https://github.com/mono/mono/raw/master/mcs/class/mono.snk"
+S="${WORKDIR}/${NAME}-${EGIT_COMMIT}"
+
+DESCRIPTION="simple set of tools to speed up the development"
+LICENSE="Apache-2.0" # https://github.com/castleproject/Core/blob/master/LICENSE
+
+CDEPEND="|| ( >=dev-lang/mono-5.4.0.167 <dev-lang/mono-9999 )
+ "
+
+RDEPEND="${CDEPEND}
+ "
+
+DEPEND="${CDEPEND}
+ "
+
+PROJECT_PATH1="Core/Castle.Core"
+PROJECT_PATH2="Tools/Castle.DynamicProxy2/Castle.DynamicProxy"
+PROJECT_NAME1="Castle.Core-vs2008"
+PROJECT_NAME2="Castle.DynamicProxy-vs2008"
+PROJECT_OUT1="Castle.Core"
+PROJECT_OUT2="Castle.DynamicProxy2"
+
+KEY2="${DISTDIR}/mono.snk"
+ASSEMBLY_VERSION="2.1.0.0"
+
+function output_filename1 ( ) {
+ local DIR=""
+ if use debug; then
+ DIR="Debug"
+ else
+ DIR="Release"
+ fi
+ echo "${PROJECT_PATH1}/bin/${DIR}/${PROJECT_OUT1}.dll"
+}
+
+function output_filename2 ( ) {
+ local DIR=""
+ if use debug; then
+ DIR="Debug"
+ else
+ DIR="Release"
+ fi
+ echo "${PROJECT_PATH2}/bin/${DIR}/${PROJECT_OUT2}.dll"
+}
+
+src_prepare() {
+ # copy (replace) project files
+ cp "${FILESDIR}/${PROJECT_NAME1}-${PV}.csproj" "${S}/${PROJECT_PATH1}/${PROJECT_NAME1}.csproj" || die
+ cp "${FILESDIR}/${PROJECT_NAME2}-${PV}.csproj" "${S}/${PROJECT_PATH2}/${PROJECT_NAME2}.csproj" || die
+ # create version info files
+ cat <<-METADATA >"${S}/Core/Castle.Core/AssemblyInfo.cs" || die
+ [assembly: System.Reflection.AssemblyVersion("2.1.0.0")]
+ METADATA
+ cat <<-METADATA >"${S}/Tools/Castle.DynamicProxy2/Castle.DynamicProxy/AssemblyInfo.cs" || die
+ [assembly: System.Reflection.AssemblyVersion("2.1.0.0")]
+ METADATA
+ # other initialization
+ eapply_user
+}
+
+src_compile() {
+ emsbuild /p:SignAssembly=true /p:PublicSign=true "/p:AssemblyOriginatorKeyFile=${KEY2}" "${S}/${PROJECT_PATH2}/${PROJECT_NAME2}.csproj"
+ sn -R "$(output_filename1)" "${KEY2}" || die
+ sn -R "$(output_filename2)" "${KEY2}" || die
+}
+
+src_install() {
+ insinto "/gac"
+ doins "$(output_filename1)"
+ doins "$(output_filename2)"
+}
+
+pkg_preinst()
+{
+ echo mv "${D}/gac/${PROJECT_OUT1}.dll" "${T}/${PROJECT_OUT1}.dll"
+ echo mv "${D}/gac/${PROJECT_OUT2}.dll" "${T}/${PROJECT_OUT2}.dll"
+ mv "${D}/gac/${PROJECT_OUT1}.dll" "${T}/${PROJECT_OUT1}.dll" || die
+ mv "${D}/gac/${PROJECT_OUT2}.dll" "${T}/${PROJECT_OUT2}.dll" || die
+ echo rm -rf "${D}/gac"
+ rm -rf "${D}/gac" || die
+}
+
+pkg_postinst()
+{
+ egacadd "${T}/${PROJECT_OUT1}.dll"
+ egacadd "${T}/${PROJECT_OUT2}.dll"
+ rm "${T}/${PROJECT_OUT1}.dll" || die
+ rm "${T}/${PROJECT_OUT2}.dll" || die
+}
+
+pkg_prerm()
+{
+ egacdel "${PROJECT_OUT1}, Version=${ASSEMBLY_VERSION}, Culture=neutral, PublicKeyToken=0738eb9f132ed756"
+ egacdel "${PROJECT_OUT2}, Version=${ASSEMBLY_VERSION}, Culture=neutral, PublicKeyToken=0738eb9f132ed756"
+}
diff --git a/dev-dotnet/castle-dynamicproxy/files/Castle.Core-vs2008-2.1.0.0.csproj b/dev-dotnet/castle-dynamicproxy/files/Castle.Core-vs2008-2.1.0.0.csproj
new file mode 100644
index 0000000..ffd4cdb
--- /dev/null
+++ b/dev-dotnet/castle-dynamicproxy/files/Castle.Core-vs2008-2.1.0.0.csproj
@@ -0,0 +1,45 @@
+<?xml version="1.0" encoding="utf-8"?>
+<Project DefaultTargets="Build" xmlns="http://schemas.microsoft.com/developer/msbuild/2003">
+ <PropertyGroup>
+ <Configuration Condition=" '$(Configuration)' == '' ">Debug</Configuration>
+ <Platform Condition=" '$(Platform)' == '' ">AnyCPU</Platform>
+ <ProjectGuid>{E4FA5B53-7D36-429E-8E5C-53D5479242BA}</ProjectGuid>
+ <OutputType>Library</OutputType>
+ <RootNamespace>Castle</RootNamespace>
+ <AssemblyName>Castle.Core</AssemblyName>
+ <AppDesignerFolder>Properties</AppDesignerFolder>
+ </PropertyGroup>
+ <PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Debug|AnyCPU' ">
+ <DefineConstants>TRACE;DEBUG;DOTNET40</DefineConstants>
+ <OutputPath>bin\Debug\</OutputPath>
+ <DebugSymbols>true</DebugSymbols>
+ <Optimize>false</Optimize>
+ <DebugType>full</DebugType>
+ </PropertyGroup>
+ <PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Release|AnyCPU' ">
+ <DefineConstants>TRACE;DOTNET40</DefineConstants>
+ <OutputPath>bin\Release\</OutputPath>
+ <Optimize>true</Optimize>
+ <DebugType>pdbonly</DebugType>
+ <DebugSymbols>false</DebugSymbols>
+ </PropertyGroup>
+ <PropertyGroup>
+ <AllowUnsafeBlocks>false</AllowUnsafeBlocks>
+ <NoStdLib>false</NoStdLib>
+ <WarningLevel>4</WarningLevel>
+ <NoWarn>1591</NoWarn>
+ <ErrorReport>prompt</ErrorReport>
+ </PropertyGroup>
+ <ItemGroup>
+ <Reference Include="System" />
+ <Reference Include="System.Core" />
+ <Reference Include="System.Configuration" />
+ <Reference Include="System.Xml" />
+ <Reference Include="System.Web" />
+ </ItemGroup>
+ <ItemGroup>
+ <Compile Include="**/*.cs" />
+ </ItemGroup>
+ <Import Project="$(MSBuildBinPath)\Microsoft.CSharp.targets" />
+</Project>
+
diff --git a/dev-dotnet/castle-dynamicproxy/files/Castle.DynamicProxy-vs2008-2.1.0.0.csproj b/dev-dotnet/castle-dynamicproxy/files/Castle.DynamicProxy-vs2008-2.1.0.0.csproj
new file mode 100644
index 0000000..52cee76
--- /dev/null
+++ b/dev-dotnet/castle-dynamicproxy/files/Castle.DynamicProxy-vs2008-2.1.0.0.csproj
@@ -0,0 +1,49 @@
+<?xml version="1.0" encoding="utf-8"?>
+<Project DefaultTargets="Build" xmlns="http://schemas.microsoft.com/developer/msbuild/2003">
+ <PropertyGroup>
+ <Configuration Condition=" '$(Configuration)' == '' ">Debug</Configuration>
+ <Platform Condition=" '$(Platform)' == '' ">AnyCPU</Platform>
+ <ProjectGuid>{2DE7CC8C-6F06-43BC-A7B6-9466BEDEAC28}</ProjectGuid>
+ <OutputType>Library</OutputType>
+ <RootNamespace>Castle.DynamicProxy</RootNamespace>
+ <AssemblyName>Castle.DynamicProxy2</AssemblyName>
+ </PropertyGroup>
+ <PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Debug|AnyCPU' ">
+ <DefineConstants>TRACE;DEBUG;PHYSICALASSEMBLY</DefineConstants>
+ <OutputPath>bin\Debug\</OutputPath>
+ <DebugSymbols>true</DebugSymbols>
+ <Optimize>false</Optimize>
+ <DebugType>full</DebugType>
+ </PropertyGroup>
+ <PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Release|AnyCPU' ">
+ <DefineConstants>TRACE;PHYSICALASSEMBLY</DefineConstants>
+ <OutputPath>bin\Release\</OutputPath>
+ <Optimize>true</Optimize>
+ <DebugType>pdbonly</DebugType>
+ <DebugSymbols>false</DebugSymbols>
+ </PropertyGroup>
+ <PropertyGroup>
+ <AllowUnsafeBlocks>false</AllowUnsafeBlocks>
+ <NoStdLib>false</NoStdLib>
+ <WarningLevel>4</WarningLevel>
+ <NoWarn>1591</NoWarn>
+ <ErrorReport>prompt</ErrorReport>
+ </PropertyGroup>
+ <ItemGroup>
+ <Reference Include="System" />
+ <Reference Include="System.Core" />
+ <Reference Include="System.Data" />
+ <Reference Include="System.Xml" />
+ </ItemGroup>
+ <ItemGroup>
+ <Compile Include="**/*.cs" />
+ </ItemGroup>
+ <ItemGroup>
+ <ProjectReference Include="..\..\..\Core\Castle.Core\Castle.Core-vs2008.csproj">
+ <Project>{E4FA5B53-7D36-429E-8E5C-53D5479242BA}</Project>
+ <Name>Castle.Core-vs2008</Name>
+ </ProjectReference>
+ </ItemGroup>
+ <Import Project="$(MSBuildBinPath)\Microsoft.CSharp.targets" />
+</Project>
+
diff --git a/dev-dotnet/castle-dynamicproxy/metadata.xml b/dev-dotnet/castle-dynamicproxy/metadata.xml
new file mode 100644
index 0000000..1d64acf
--- /dev/null
+++ b/dev-dotnet/castle-dynamicproxy/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>dotnet@gentoo.org</email>
+ <description>Gentoo Dotnet Project</description>
+ </maintainer>
+ <longdescription lang="en">
+ simple set of tools to speed up the development
+ </longdescription>
+ <longdescription lang="ru">
+ набор утилит для упрощения процесса разработки
+ </longdescription>
+</pkgmetadata>