aboutsummaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorArsenShnurkov <Arsen.Shnurkov@gmail.com>2015-08-19 17:50:02 +0300
committerArsenShnurkov <Arsen.Shnurkov@gmail.com>2015-08-19 17:50:02 +0300
commit387761d3c9b28ca7d1b07016025a3b742c3c2408 (patch)
tree854ea9329c1118f32a7a86dc8c38a940e5ded624 /eclass
parentadd nunit-console-runner.dll to gac for 2.6.4 (diff)
downloaddotnet-387761d3c9b28ca7d1b07016025a3b742c3c2408.tar.gz
dotnet-387761d3c9b28ca7d1b07016025a3b742c3c2408.tar.bz2
dotnet-387761d3c9b28ca7d1b07016025a3b742c3c2408.zip
repoman warning about use removed
Diffstat (limited to 'eclass')
-rw-r--r--eclass/dotnet.eclass27
1 files changed, 22 insertions, 5 deletions
diff --git a/eclass/dotnet.eclass b/eclass/dotnet.eclass
index 2bf9f72..85a1521 100644
--- a/eclass/dotnet.eclass
+++ b/eclass/dotnet.eclass
@@ -38,13 +38,16 @@ done
# @FUNCTION: dotnet_pkg_setup
# @DESCRIPTION: This function set FRAMEWORK
dotnet_pkg_setup() {
+ EBUILD_FRAMEWORK=""
for x in ${USE_DOTNET} ; do
+# elog "Cycle, start, x=""${x}"""
case ${x} in
- net45) if use net45; then F="4.5"; fi;;
- net40) if use net40; then F="4.0"; fi;;
- net35) if use net35; then F="3.5"; fi;;
- net20) if use net20; then F="2.0"; fi;;
+ net45) EBF="4.5"; if use net45; then F="${EBF}";fi;;
+ net40) EBF="4.0"; if use net40; then F="${EBF}";fi;;
+ net35) EBF="3.5"; if use net35; then F="${EBF}";fi;;
+ net20) EBF="2.0"; if use net20; then F="${EBF}";fi;;
esac
+# elog "Cycle, after switch, F=""${F}"", EBF=""${EBF}"""
if [[ -z ${FRAMEWORK} ]]; then
if [[ ${F} ]]; then
FRAMEWORK="${F}";
@@ -52,9 +55,23 @@ dotnet_pkg_setup() {
else
version_is_at_least "${F}" "${FRAMEWORK}" || FRAMEWORK="${F}"
fi
+ if [[ -z ${EBUILD_FRAMEWORK} ]]; then
+ if [[ ${EBF} ]]; then
+ EBUILD_FRAMEWORK="${EBF}";
+ fi
+ else
+ version_is_at_least "${EBF}" "${EBUILD_FRAMEWORK}" || EBUILD_FRAMEWORK="${EBF}"
+ fi
+# elog "Cycle, the end, FRAMEWORK=""${FRAMEWORK}"", EBUILD_FRAMEWORK=""${EBUILD_FRAMEWORK}"" "
done
if [[ -z ${FRAMEWORK} ]]; then
- FRAMEWORK="4.0"
+ if [[ -z ${EBUILD_FRAMEWORK} ]]; then
+ FRAMEWORK="4.0"
+ elog "Ebuild doesn't contain USE_DOTNET="
+ else
+ FRAMEWORK="${EBUILD_FRAMEWORK}"
+ elog "User did not set any netNN use-flags in make.conf or profile, .ebuild demands USE_DOTNET=""${USE_DOTNET}"""
+ fi
fi
einfo " -- USING .NET ${FRAMEWORK} FRAMEWORK -- "
}