aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorlayman <layman@localhost>2016-06-15 14:02:56 +0300
committerlayman <layman@localhost>2016-06-15 14:02:56 +0300
commitcb2aeee2183d76c5ecf229d5217accf0e2e04883 (patch)
treeea51f48a971711af5446a10637d8f60befaeff2c /net-irc
parentdev-lang/mono: 4.4.0.182 (diff)
downloaddotnet-cb2aeee2183d76c5ecf229d5217accf0e2e04883.tar.gz
dotnet-cb2aeee2183d76c5ecf229d5217accf0e2e04883.tar.bz2
dotnet-cb2aeee2183d76c5ecf229d5217accf0e2e04883.zip
prev code
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/smuxi/smuxi-1.0.5.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-irc/smuxi/smuxi-1.0.5.ebuild b/net-irc/smuxi/smuxi-1.0.5.ebuild
new file mode 100644
index 0000000..5f010fc
--- /dev/null
+++ b/net-irc/smuxi/smuxi-1.0.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils mono-env
+
+DESCRIPTION="A flexible, irssi-like and user-friendly IRC client for the Gnome Desktop"
+HOMEPAGE="http://www.smuxi.org/main/"
+SRC_URI="http://www.smuxi.org/jaws/data/files/${P}.tar.gz"
+#SRC_URI="https://github.com/meebey/smuxi/archive/${PV}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus debug gtk libnotify spell"
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+RDEPEND=">=dev-lang/mono-4.0.2.5
+ >=dev-dotnet/smartirc4net-1.0
+ dev-libs/stfl
+ >=dev-dotnet/log4net-1.2.10
+ >=dev-dotnet/nini-1.1.0-r2
+ gtk? ( >=dev-dotnet/gtk-sharp-2.12.21:2 )
+ libnotify? ( >=dev-dotnet/notify-sharp-0.4 )
+ libnotify? ( <dev-dotnet/notify-sharp-3 )
+ dbus? ( >=dev-dotnet/dbus-sharp-glib-0.6 )
+ spell? ( >=app-text/gtkspell-2.0.9:2 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.25
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # Our dev-dotnet/db4o is completely unmaintained
+ # We don't have ubuntu stuff
+ econf \
+ --enable-engine-irc \
+ --without-indicate \
+ --with-vendor-package-version="Gentoo ${PV}" \
+ --with-db4o=included \
+ --with-messaging-menu=no \
+ --with-indicate=no \
+ $(use_enable debug) \
+ $(use_enable gtk frontend-gnome) \
+ $(use_with libnotify notify) \
+ $(use_with spell gtkspell)
+
+ touch README
+}