summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2014-06-05 18:59:34 +0200
committerUlrich Müller <ulm@gentoo.org>2014-06-05 18:59:34 +0200
commit36a7bc3ebe65a379d41da0cb5ea6d48f5ff62c3b (patch)
tree5d3c3525b486df0432a8683a87f4d90ba26ad653
parentEbuild for BBDB version 3, bug 511572. Work in progress. (diff)
downloademacs-36a7bc3ebe65a379d41da0cb5ea6d48f5ff62c3b.tar.gz
emacs-36a7bc3ebe65a379d41da0cb5ea6d48f5ff62c3b.tar.bz2
emacs-36a7bc3ebe65a379d41da0cb5ea6d48f5ff62c3b.zip
Add missing dependency on app-misc/getopt for BSD. Update GETOPT variable in script if necessary.
Package-Manager: portage-2.2.10
-rw-r--r--app-admin/emacs-updater/ChangeLog4
-rw-r--r--app-admin/emacs-updater/emacs-updater-9999.ebuild11
2 files changed, 13 insertions, 2 deletions
diff --git a/app-admin/emacs-updater/ChangeLog b/app-admin/emacs-updater/ChangeLog
index 6008477..0ac3e3b 100644
--- a/app-admin/emacs-updater/ChangeLog
+++ b/app-admin/emacs-updater/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 05 Jun 2014; Ulrich Müller <ulm@gentoo.org> emacs-updater-9999.ebuild:
+ Add missing dependency on app-misc/getopt for BSD. Update GETOPT variable in
+ script if necessary.
+
19 Jan 2014; Ulrich Müller <ulm@gentoo.org> emacs-updater-9999.ebuild:
Switch from package.mask to empty KEYWORDS.
diff --git a/app-admin/emacs-updater/emacs-updater-9999.ebuild b/app-admin/emacs-updater/emacs-updater-9999.ebuild
index 9b96598..b24787e 100644
--- a/app-admin/emacs-updater/emacs-updater-9999.ebuild
+++ b/app-admin/emacs-updater/emacs-updater-9999.ebuild
@@ -16,15 +16,22 @@ HOMEPAGE="http://wiki.gentoo.org/wiki/Project:Emacs"
LICENSE="GPL-2+"
SLOT="0"
-RDEPEND=">=app-portage/portage-utils-0.3
+DEPEND="|| ( sys-apps/util-linux app-misc/getopt )"
+RDEPEND="${DEPEND}
+ >=app-portage/portage-utils-0.3
virtual/emacs"
S="${WORKDIR}/${PN}"
src_prepare() {
+ if ! has_version sys-apps/util-linux; then
+ # BSD ships a dumb getopt(1), so use getopt-long instead
+ sed -i -e '/^GETOPT=/s/getopt/&-long/' emacs-updater || die
+ fi
+
if [[ -n ${EPREFIX} ]]; then
sed -i -e "1s:/:${EPREFIX%/}/:" \
- -e "s:^\(EMACS\|SITELISP\)=:&${EPREFIX%/}:" \
+ -e "s:^\([[:upper:]]*=\)/:\1${EPREFIX%/}/:" \
emacs-updater || die
fi
}