summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-09-24 16:09:38 +0200
committerUlrich Müller <ulm@gentoo.org>2019-09-24 16:09:38 +0200
commitb86704a0f60b53b1227352335140f4ad5f34d758 (patch)
treeecf79d293feb41f42b602362b93840b97459d90f
parentvirtual/emacs-flim removed 2019-07-26 (diff)
downloademacs-b86704a0.tar.gz
emacs-b86704a0.tar.bz2
emacs-b86704a0.zip
thumbs removed 2019-09-24 bug 692882
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--app-emacs/thumbs/Manifest1
-rw-r--r--app-emacs/thumbs/files/50thumbs-gentoo.el11
-rw-r--r--app-emacs/thumbs/metadata.xml9
-rw-r--r--app-emacs/thumbs/thumbs-2.0-r1.ebuild19
4 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/thumbs/Manifest b/app-emacs/thumbs/Manifest
new file mode 100644
index 0000000..955f5c1
--- /dev/null
+++ b/app-emacs/thumbs/Manifest
@@ -0,0 +1 @@
+DIST thumbs-2.0.el.bz2 6521 BLAKE2B f37154658fdc660698a28ac01d0b266ff6cc4f86f30d93a9e0929e565a6666ccd168d861122d5ff893073f9aaa4a3c7412a3f96758b044faad11f13ec7000533 SHA512 d4bca861ed5db620a2319659e255bef14241a68067be994402d2d36bb7fe34ab5a22b6b76dea5631aa5288d03caadb3a8163a8ecf439144d8d50cc410cfe078d
diff --git a/app-emacs/thumbs/files/50thumbs-gentoo.el b/app-emacs/thumbs/files/50thumbs-gentoo.el
new file mode 100644
index 0000000..12627d3
--- /dev/null
+++ b/app-emacs/thumbs/files/50thumbs-gentoo.el
@@ -0,0 +1,11 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'thumbs-find-thumb "thumbs" "Display the thumbnail for IMG." t)
+(autoload 'thumbs-show-all-from-dir "thumbs"
+ "Make a preview buffer for all images in DIR." t)
+(autoload 'thumbs-dired-show-marked "thumbs"
+ "In Dired, make a thumbs buffer with all marked files." t)
+(autoload 'thumbs-dired-show-all "thumbs"
+ "In dired, make a thumbs buffer with all files in current directory." t)
+(defalias 'thumbs 'thumbs-show-all-from-dir)
+(autoload 'thumbs-dired-setroot "thumbs"
+ "In dired, Call the setroot program on the image at point." t)
diff --git a/app-emacs/thumbs/metadata.xml b/app-emacs/thumbs/metadata.xml
new file mode 100644
index 0000000..c918cde
--- /dev/null
+++ b/app-emacs/thumbs/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+</pkgmetadata>
diff --git a/app-emacs/thumbs/thumbs-2.0-r1.ebuild b/app-emacs/thumbs/thumbs-2.0-r1.ebuild
new file mode 100644
index 0000000..85ffa76
--- /dev/null
+++ b/app-emacs/thumbs/thumbs-2.0-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit elisp
+
+DESCRIPTION="Emacs thumbnail previewer for image files"
+HOMEPAGE="https://www.emacswiki.org/emacs/ThumbsMode"
+SRC_URI="mirror://gentoo/${P}.el.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc sparc x86"
+IUSE=""
+
+RDEPEND="virtual/imagemagick-tools"
+
+SITEFILE="50${PN}-gentoo.el"