summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-02-15 21:47:31 +0100
committerUlrich Müller <ulm@gentoo.org>2019-02-15 21:47:31 +0100
commitd4abfa347f2b4ad6252d335c000282b18485d0dc (patch)
treea7f8f46ea3c1fa12dc9bfaee40d136037d31ac58
parentcmail removed 2018-09-13 bug 663030 (diff)
downloademacs-d4abfa34.tar.gz
emacs-d4abfa34.tar.bz2
emacs-d4abfa34.zip
tdtd removed 2019-02-15 bug 675814
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--app-emacs/tdtd/Manifest1
-rw-r--r--app-emacs/tdtd/files/50tdtd-gentoo.el28
-rw-r--r--app-emacs/tdtd/metadata.xml9
-rw-r--r--app-emacs/tdtd/tdtd-0.7.1-r1.ebuild22
4 files changed, 60 insertions, 0 deletions
diff --git a/app-emacs/tdtd/Manifest b/app-emacs/tdtd/Manifest
new file mode 100644
index 0000000..055fd77
--- /dev/null
+++ b/app-emacs/tdtd/Manifest
@@ -0,0 +1 @@
+DIST tdtd071.zip 37673 BLAKE2B 0bc5be6e8c9050a06b233b1645fe3bb3ad9bb89ba087309d75afd63af28ce1d4873c88447fcd6e654f50728682d5156e1a795865f11f5e2e54607e630687ed0a SHA512 3de529178718352bc437a3e91d3102990a88314d1dc5ad3d3120c6dfcbb1aef008edc00e46ee051fd5c968c698230393a301dd645484aa748b5b982df84e0556
diff --git a/app-emacs/tdtd/files/50tdtd-gentoo.el b/app-emacs/tdtd/files/50tdtd-gentoo.el
new file mode 100644
index 0000000..3867c8f
--- /dev/null
+++ b/app-emacs/tdtd/files/50tdtd-gentoo.el
@@ -0,0 +1,28 @@
+
+;;; tdtd site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'dtd-mode "tdtd" "Major mode to edit DTD files." t)
+(autoload 'dtd-etags "tdtd"
+ "Execute etags on FILESPEC and match on DTD-specific regular expressions."
+ t)
+(autoload 'dtd-grep "tdtd" "Grep for PATTERN in files matching FILESPEC." t)
+
+;; Turn on font lock when in DTD mode
+(add-hook 'dtd-mode-hooks
+ 'turn-on-font-lock)
+
+(setq auto-mode-alist
+ (append
+ (list
+ '("\\.dcl$" . dtd-mode)
+ '("\\.dec$" . dtd-mode)
+ '("\\.dtd$" . dtd-mode)
+ '("\\.ele$" . dtd-mode)
+ '("\\.ent$" . dtd-mode)
+ '("\\.mod$" . dtd-mode))
+ auto-mode-alist))
+
+;; To use resize-minibuffer-mode, uncomment this and include in your .emacs:
+;;(resize-minibuffer-mode)
diff --git a/app-emacs/tdtd/metadata.xml b/app-emacs/tdtd/metadata.xml
new file mode 100644
index 0000000..c918cde
--- /dev/null
+++ b/app-emacs/tdtd/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+</pkgmetadata>
diff --git a/app-emacs/tdtd/tdtd-0.7.1-r1.ebuild b/app-emacs/tdtd/tdtd-0.7.1-r1.ebuild
new file mode 100644
index 0000000..0d8bb44
--- /dev/null
+++ b/app-emacs/tdtd/tdtd-0.7.1-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+inherit elisp
+
+DESCRIPTION="Emacs Major Mode for SGML and XML DTDs"
+HOMEPAGE="http://www.menteith.com/wiki/tdtd"
+SRC_URI="http://www.menteith.com/raw-attachment/wiki/tdtd/data/${PN}${PV//./}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}"
+SITEFILE=50${PN}-gentoo.el
+DOCS="TODO changelog.txt readme.txt tutorial.txt"