aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-05-12 13:09:04 -0400
committerMike Gilbert <floppym@gentoo.org>2016-05-12 13:09:04 -0400
commitbd0a7291f9813f7dcdf9ff69e18d47ebbc8cdb74 (patch)
tree51ee9cb91b6a8986e7b15d82a0838284fb5a30f5
parentebuild-test/inherit-unused: new test (diff)
downloadgen-b0rk-bd0a7291.tar.gz
gen-b0rk-bd0a7291.tar.bz2
gen-b0rk-bd0a7291.zip
ebuild-test/upstream-workaround: new test
-rw-r--r--ebuild-test/upstream-workaround/metadata.xml26
-rw-r--r--ebuild-test/upstream-workaround/upstream-workaround-0.ebuild19
2 files changed, 45 insertions, 0 deletions
diff --git a/ebuild-test/upstream-workaround/metadata.xml b/ebuild-test/upstream-workaround/metadata.xml
new file mode 100644
index 0000000..da7c4a8
--- /dev/null
+++ b/ebuild-test/upstream-workaround/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!--
+# $Id$
+
+This is the example metadata file.
+The root element of this file is <pkgmetadata>. Within this element a
+number of subelements are allowed, the most common being maintainer.
+
+For a full description look at:
+https://devmanual.gentoo.org/ebuild-writing/misc-files/metadata/
+
+Before committing, please remove the comments from this file. They are
+not relevant for general metadata.xml files.
+-->
+<pkgmetadata>
+<maintainer type="person">
+ <email>exampledev@gentoo.org</email>
+ <description>Primary maintainer</description>
+</maintainer>
+<maintainer type="project">
+ <email>exampleproject@gentoo.org</email>
+ <name>Gentoo Example Project</name>
+</maintainer>
+<longdescription>Test for ???</longdescription>
+</pkgmetadata>
diff --git a/ebuild-test/upstream-workaround/upstream-workaround-0.ebuild b/ebuild-test/upstream-workaround/upstream-workaround-0.ebuild
new file mode 100644
index 0000000..a8078b2
--- /dev/null
+++ b/ebuild-test/upstream-workaround/upstream-workaround-0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Various workarounds for broken code upstream"
+HOMEPAGE="http://example.com/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ addpredict /foo
+ emake -j1
+ MAKEOPTS="-j1" emake
+ emake LDFLAGS="$(no-as-needed)"
+}