aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-05-10 23:11:06 -0400
committerMike Gilbert <floppym@gentoo.org>2016-05-10 23:23:21 -0400
commitc22cdfedd52b4dc16588176b92cff9392ff93b70 (patch)
treec137915163bf5aaae9202e20befcf932a6ee5f85
parentebuild-test/badheader: test for bad header in ebuilds (diff)
downloadgen-b0rk-c22cdfedd52b4dc16588176b92cff9392ff93b70.tar.gz
gen-b0rk-c22cdfedd52b4dc16588176b92cff9392ff93b70.tar.bz2
gen-b0rk-c22cdfedd52b4dc16588176b92cff9392ff93b70.zip
ebuild-test/minorsyn: test for minor syntax errors
-rw-r--r--ebuild-test/minorsyn/metadata.xml26
-rw-r--r--ebuild-test/minorsyn/minorsyn-0.ebuild44
2 files changed, 70 insertions, 0 deletions
diff --git a/ebuild-test/minorsyn/metadata.xml b/ebuild-test/minorsyn/metadata.xml
new file mode 100644
index 0000000..da7c4a8
--- /dev/null
+++ b/ebuild-test/minorsyn/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!--
+# $Id$
+
+This is the example metadata file.
+The root element of this file is <pkgmetadata>. Within this element a
+number of subelements are allowed, the most common being maintainer.
+
+For a full description look at:
+https://devmanual.gentoo.org/ebuild-writing/misc-files/metadata/
+
+Before committing, please remove the comments from this file. They are
+not relevant for general metadata.xml files.
+-->
+<pkgmetadata>
+<maintainer type="person">
+ <email>exampledev@gentoo.org</email>
+ <description>Primary maintainer</description>
+</maintainer>
+<maintainer type="project">
+ <email>exampleproject@gentoo.org</email>
+ <name>Gentoo Example Project</name>
+</maintainer>
+<longdescription>Test for ???</longdescription>
+</pkgmetadata>
diff --git a/ebuild-test/minorsyn/minorsyn-0.ebuild b/ebuild-test/minorsyn/minorsyn-0.ebuild
new file mode 100644
index 0000000..45c2609
--- /dev/null
+++ b/ebuild-test/minorsyn/minorsyn-0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Minor syntax errors"
+HOMEPAGE="http://example.com/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+ # leading space
+: trailing space
+: unquoted variable: ${S}
+
+WANT_AUTOMAKE=latest
+
+src_unpack() {
+ # quoted ${A}
+ unpack "${A}"
+ epatch
+}
+
+src_compile() {
+ econf
+ built_with_use foo
+ useq foo
+ hasq foo
+}
+
+src_install() {
+ cd "${S}"
+ dodoc COPYING
+ preserve_old_lib foo
+ bindnow-flags foo
+}
+
+# blank line in the middle
+
+
+# blank line at the end
+