summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorvitalogy <vitalogy_github@milaw.biz>2015-07-18 18:24:21 +0200
committervitalogy <vitalogy_github@milaw.biz>2015-07-18 18:24:21 +0200
commitea99ef28d7971696884fb9c31e5d0aea0ba0b509 (patch)
treec76368562a03dab75254e8fe68e204a6d7afab3f
parentadd ebuild for grub2-theme-ask-larry (diff)
downloadgrub2-themes-ea99ef28d7971696884fb9c31e5d0aea0ba0b509.tar.gz
grub2-themes-ea99ef28d7971696884fb9c31e5d0aea0ba0b509.tar.bz2
grub2-themes-ea99ef28d7971696884fb9c31e5d0aea0ba0b509.zip
add ask-larry-0.2.0.ebuild
-rw-r--r--grub2-themes/ask-larry/Manifest1
-rw-r--r--grub2-themes/ask-larry/ask-larry-0.2.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/grub2-themes/ask-larry/Manifest b/grub2-themes/ask-larry/Manifest
index c0051cb..f196e52 100644
--- a/grub2-themes/ask-larry/Manifest
+++ b/grub2-themes/ask-larry/Manifest
@@ -1 +1,2 @@
DIST ask-larry-0.1.0.tar.gz 2463597 SHA256 60a869b2aa1082280d5ae6a0d61268ac8c642aa052c731b237052ce3b03deb56 SHA512 26d35162da495da5becabe974934b77e0e31b5a672c6e0c79a581ccded0877d7e402935f4ca31cd2e7b43ac0bbc90383c97fb487d1898f5a42ce3deb90da38d4 WHIRLPOOL 64948b7ae98a90fd9a6634dc6dd608b886b660d7ee23dd73ec6b8ecfbfceb9441d8ec946241f7018da8e4307add652766d506c8900ab183523103f29ccf87893
+DIST ask-larry-0.2.0.tar.gz 3697573 SHA256 dfe46d6b30b0ec08774890652e9f063e2de988023bba9d4e5d9e0c5566353eb6 SHA512 3a35c0530c4a3e6a78df8e37c50da91778ba2de3268b0cb20e6cbb7bd0ed1f18d35b13b71580dd0e4de4f654ccd36d8460347aeef638b0dccf41b00d397bd90d WHIRLPOOL 9ecab7d93b14fb41add693e9f66f1a6ac8047dd4e0432bdd7c9d3f4c87ff03663426d3dcf8d14ce6baac54f80839fc95a4d905bc8d64cc7d9087c4969d7265f1
diff --git a/grub2-themes/ask-larry/ask-larry-0.2.0.ebuild b/grub2-themes/ask-larry/ask-larry-0.2.0.ebuild
new file mode 100644
index 0000000..47ec700
--- /dev/null
+++ b/grub2-themes/ask-larry/ask-larry-0.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+inherit grub2-theme
+
+DESCRIPTION="Grub2 GFX theme ask-larry"
+HOMEPAGE="https://github.com/vitalogy/grub2-theme-ask-larry"
+SRC_URI="https://github.com/vitalogy/grub2-theme-${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT BitstreamVera ArevFonts public-domain CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="widescreen"
+
+S="${WORKDIR}"/grub2-theme-${PN}-${PV}
+
+RESTRICT="bindist mirror"
+
+src_prepare() {
+ rm -r screenshot || die
+}
+
+src_install() {
+ insinto "${GRUB2_THEME_DIR}/${PN}"
+ doins -r .
+ if use widescreen ; then
+ dosym theme_widescreen.txt ${GRUB2_THEME_DIR}/${PN}/theme.txt
+ else
+ dosym theme_normal.txt ${GRUB2_THEME_DIR}/${PN}/theme.txt
+ fi
+}