aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2020-08-28 01:41:49 +0100
committerAlexey Sokolov <alexey+gentoo@asokolov.org>2020-08-28 01:41:49 +0100
commit0440fcbb0022573e2d5e9de0e6949522257a9a86 (patch)
tree0d8df15366cd7449553f62f8f1b12eb52badc41e
parentdev-vcs/lazygit: 0.22.1 version bump (diff)
downloadguru-0440fcbb.tar.gz
guru-0440fcbb.tar.bz2
guru-0440fcbb.zip
app-misc/liquidctl: new package
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org>
-rw-r--r--app-misc/liquidctl/Manifest1
-rw-r--r--app-misc/liquidctl/liquidctl-1.4.1.ebuild36
-rw-r--r--app-misc/liquidctl/metadata.xml11
3 files changed, 48 insertions, 0 deletions
diff --git a/app-misc/liquidctl/Manifest b/app-misc/liquidctl/Manifest
new file mode 100644
index 000000000..373b6da80
--- /dev/null
+++ b/app-misc/liquidctl/Manifest
@@ -0,0 +1 @@
+DIST liquidctl-1.4.1.tar.gz 149114 BLAKE2B eee91d82cd31021aa8a290844c74ff117024383f85eaa83ef89bf4f1d3e9d1af29b6b530497c356fb51aaca6f686522768eb1df0c7fb85ecdc34b630109a1db9 SHA512 f5f1e1e9f4f03ab2bc1252a65a118a1cfd2203f4cbde7e7ddb45667b20ec7757d35eff9f69922395efb1461d660b104531230942f4d537428f30ae3e59ed2594
diff --git a/app-misc/liquidctl/liquidctl-1.4.1.ebuild b/app-misc/liquidctl/liquidctl-1.4.1.ebuild
new file mode 100644
index 000000000..162b49f19
--- /dev/null
+++ b/app-misc/liquidctl/liquidctl-1.4.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1 udev
+
+DESCRIPTION="Cross-platform tool and drivers for liquid coolers and other devices"
+HOMEPAGE="https://github.com/jonasmalacofilho/liquidctl"
+SRC_URI="https://github.com/jonasmalacofilho/liquidctl/releases/download/v${PV}/${P}.tar.gz"
+#S="${WORKDIR}/${P}"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/docopt[${PYTHON_USEDEP}]
+ dev-python/hidapi[${PYTHON_USEDEP}]
+ dev-python/pyusb[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ # Without this variable, it attempts to write to /var/run and fails
+ XDG_RUNTIME_DIR="${T}/xdg" distutils-r1_src_test || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc docs/*.md || die
+ dodoc -r docs/linux/
+ udev_dorules extra/linux/71-liquidctl.rules
+}
diff --git a/app-misc/liquidctl/metadata.xml b/app-misc/liquidctl/metadata.xml
new file mode 100644
index 000000000..8e9aedf81
--- /dev/null
+++ b/app-misc/liquidctl/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alexey+gentoo@asokolov.org</email>
+ <name>Alexey Sokolov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jonasmalacofilho/liquidctl</remote-id>
+ </upstream>
+</pkgmetadata>