aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLev Babiev <harley@hosers.org>2020-12-30 20:50:07 +0000
committerLev Babiev <harley@hosers.org>2020-12-30 20:50:07 +0000
commit060f7f3498e6abf31a0d2ff7f72fb4273cc2ef69 (patch)
treecfdc0c3145b12889530048df4632bf9647313c03
parentx11-misc/i3lock-color: fix pam/i3lock (diff)
downloadguru-060f7f34.tar.gz
guru-060f7f34.tar.bz2
guru-060f7f34.zip
gui-apps/sfwbar: new ebuild
Signed-off-by: Lev Babiev <harley@hosers.org>
-rw-r--r--gui-apps/sfwbar/Manifest1
-rw-r--r--gui-apps/sfwbar/metadata.xml13
-rw-r--r--gui-apps/sfwbar/sfwbar-0.9.4.ebuild31
3 files changed, 45 insertions, 0 deletions
diff --git a/gui-apps/sfwbar/Manifest b/gui-apps/sfwbar/Manifest
new file mode 100644
index 000000000..10d8700af
--- /dev/null
+++ b/gui-apps/sfwbar/Manifest
@@ -0,0 +1 @@
+DIST v0.9.4.tar.gz 90159 BLAKE2B c1f0fdd77469c231f8bb7e0862049979354e076427ad08ca5fe6383fac44b424b5583041a21425bfaa490f872fa0757214e7796d187f9fc7cb62b22d6b65c039 SHA512 e2cbe1bb6f89dd9632e21d9f008267bae2ef62c63e54021c791d3f24c09c817b3670509d3be29a23795c50e63e78330fdbbc1ab6b527c012585e28950958171d
diff --git a/gui-apps/sfwbar/metadata.xml b/gui-apps/sfwbar/metadata.xml
new file mode 100644
index 000000000..e277680b5
--- /dev/null
+++ b/gui-apps/sfwbar/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>harley@hosers.org</email>
+ <name>Lev Babiev</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">LBCrion/sfwbar</remote-id>
+ <bugs-to>https://github.com/LBCrion/sfwbar/issues</bugs-to>
+ <changelog>https://github.com/LBCrion/sfwbar/releases</changelog>
+ </upstream>
+</pkgmetadata>
diff --git a/gui-apps/sfwbar/sfwbar-0.9.4.ebuild b/gui-apps/sfwbar/sfwbar-0.9.4.ebuild
new file mode 100644
index 000000000..15741a72e
--- /dev/null
+++ b/gui-apps/sfwbar/sfwbar-0.9.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Sway Floating Window Bar"
+HOMEPAGE="https://github.com/LBCrion/sfwbar"
+SRC_URI="https://github.com/LBCrion/sfwbar/archive/v${PV}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ >=x11-libs/gtk+-3.22.0:3[introspection,wayland]
+ gui-libs/gtk-layer-shell
+ >=dev-libs/json-c-0.13:0=
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ )
+ meson_src_configure
+}