aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenri Gasc <gasc@eurecom.fr>2024-04-12 19:13:59 +0200
committerHenri Gasc <gasc@eurecom.fr>2024-04-12 19:17:11 +0200
commit06c7e828b21868e0cd354ded91ec5e568dc868b4 (patch)
tree7c80808a63585ce08a06f0bef1825cc9e677d372
parentdev-libs/libtypec: new package, add 0.5 (diff)
downloadguru-06c7e828.tar.gz
guru-06c7e828.tar.bz2
guru-06c7e828.zip
app-editors/imhex: Remove Werror, scrub patches
Closes: https://bugs.gentoo.org/921663 Signed-off-by: Henri Gasc <gasc@eurecom.fr>
-rw-r--r--app-editors/imhex/files/remove_Werror.patch24
-rw-r--r--app-editors/imhex/files/remove_dotnet.patch12
-rw-r--r--app-editors/imhex/imhex-1.33.2-r1.ebuild (renamed from app-editors/imhex/imhex-1.33.2.ebuild)2
3 files changed, 32 insertions, 6 deletions
diff --git a/app-editors/imhex/files/remove_Werror.patch b/app-editors/imhex/files/remove_Werror.patch
new file mode 100644
index 000000000..1a35f9e92
--- /dev/null
+++ b/app-editors/imhex/files/remove_Werror.patch
@@ -0,0 +1,24 @@
+Remove the different Werror flags we can find used
+Should fix https://bugs.gentoo.org/921663
+--- a/lib/external/pattern_language/cli/CMakeLists.txt
++++ b/lib/external/pattern_language/cli/CMakeLists.txt
+@@ -29,7 +29,7 @@ else()
+ find_package(CLI11 CONFIG QUIET)
+ endif()
+
+-target_compile_options(plcli PRIVATE -Wall -Wextra -Werror -Wno-unknown-pragmas -Wno-array-bounds)
++target_compile_options(plcli PRIVATE -Wall -Wextra -Wno-unknown-pragmas -Wno-array-bounds)
+ target_include_directories(plcli PUBLIC include ${CLI11_INCLUDE_DIRS})
+ target_link_libraries(plcli PRIVATE ${CLI11_LIBRARIES} ${NLOHMANN_JSON_LIBRARIES} libpl libpl-gen ${FMT_LIBRARIES})
+
+--- a/lib/external/pattern_language/lib/CMakeLists.txt
++++ b/lib/external/pattern_language/lib/CMakeLists.txt
+@@ -86,7 +86,7 @@ if (LIBPL_ENABLE_PRECOMPILED_HEADERS)
+ endif ()
+
+ if(CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
+- target_compile_options(libpl PRIVATE -Wall -Wextra -Werror -Wpedantic -Wno-unknown-pragmas -Wno-array-bounds)
++ target_compile_options(libpl PRIVATE -Wall -Wextra -Wpedantic -Wno-unknown-pragmas -Wno-array-bounds)
+ if(CMAKE_CXX_COMPILER_ID MATCHES "GNU")
+ target_compile_options(libpl PRIVATE -Wno-stringop-overflow)
+ endif()
diff --git a/app-editors/imhex/files/remove_dotnet.patch b/app-editors/imhex/files/remove_dotnet.patch
index 30ab50f64..88d5c9700 100644
--- a/app-editors/imhex/files/remove_dotnet.patch
+++ b/app-editors/imhex/files/remove_dotnet.patch
@@ -1,14 +1,14 @@
-diff --git a/plugins/script_loader/CMakeLists.txt b/plugins/script_loader/CMakeLists.txt
-index af0f6c79..cddc0e14 100644
+Remove the compilation step that needs dotnet
+https://bugs.gentoo.org/926761
--- a/plugins/script_loader/CMakeLists.txt
+++ b/plugins/script_loader/CMakeLists.txt
-@@ -46,7 +46,4 @@ if (CoreClrEmbed_FOUND)
+@@ -45,8 +45,4 @@ if (CoreClrEmbed_FOUND)
+ if (IMHEX_BUNDLE_DOTNET)
install(FILES ${CoreClrEmbed_SHARED_LIBRARIES} DESTINATION ${CMAKE_INSTALL_LIBDIR})
endif ()
-
+-
- add_subdirectory(dotnet)
- add_dependencies(script_loader AssemblyLoader)
-
--endif ()
+ endif ()
\ No newline at end of file
-+endif ()
diff --git a/app-editors/imhex/imhex-1.33.2.ebuild b/app-editors/imhex/imhex-1.33.2-r1.ebuild
index 046b7d893..93f9baee0 100644
--- a/app-editors/imhex/imhex-1.33.2.ebuild
+++ b/app-editors/imhex/imhex-1.33.2-r1.ebuild
@@ -25,6 +25,8 @@ PATCHES=(
# will use it at some point and try to access internet.
# Because it did not cause any issue, we can disable it
"${FILESDIR}/remove_dotnet.patch"
+ # Remove the different -Werror flags
+ "${FILESDIR}/remove_Werror.patch"
)
DEPEND="