aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2022-10-30 01:29:56 +0300
committerSergey Torokhov <torokhov-s-a@yandex.ru>2022-10-30 01:29:56 +0300
commit0777f0dc276b89703771680de03426ad694b51d8 (patch)
tree53c3e788cf58de31a859623a808ef60b5bc0a92e
parentx11-lib/gtk-fortran: fix test fail due to DISPLAY absence (diff)
downloadguru-0777f0dc.tar.gz
guru-0777f0dc.tar.bz2
guru-0777f0dc.zip
x11-libs/gtk-fortran: 3.24.31 and 4.2.1 versions bump
Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
-rw-r--r--x11-libs/gtk-fortran/Manifest2
-rw-r--r--x11-libs/gtk-fortran/gtk-fortran-3.24.31.ebuild71
-rw-r--r--x11-libs/gtk-fortran/gtk-fortran-4.2.1.ebuild71
3 files changed, 144 insertions, 0 deletions
diff --git a/x11-libs/gtk-fortran/Manifest b/x11-libs/gtk-fortran/Manifest
index e7bda029d..a55470946 100644
--- a/x11-libs/gtk-fortran/Manifest
+++ b/x11-libs/gtk-fortran/Manifest
@@ -1,2 +1,4 @@
DIST gtk-fortran-3.24.30.tar.gz 4276622 BLAKE2B 4b18d21e0479496caea386450fc16c12d20ad3491932b331890b5d7328c704799f8dd288c4a1d0d2e34f0957f0bdca316f820850b80c4ff8d2b66ce3673fe5ec SHA512 4e1cd522ca80db01a1058d6c58b4a6e3e63e6b1d510e2ee5fd0b8f8aa9f9dc8e433d203781c908065571c4c1a6d9686c22eec879b396352b12fa82b604855c86
+DIST gtk-fortran-3.24.31.tar.gz 4287676 BLAKE2B 9fe3f83158ea504d492978ddd0b3a6d4aad5f5325df7c6ebbeb6d11ecb48d1097ee3c7b213c8824a5e4adb15da9af1da64c72b9089746dd0bb5d1d91dc76c766 SHA512 3d1a62837f4750b5c284a1548ede0ecfe8ad2f2619ca7ee2eb75e4cb7fcc739de90d67ff61d406b1f13fe0a2a9f1e23a1baa50afdc8caaaf1b3866e5640cb3f1
DIST gtk-fortran-4.1.0.tar.gz 4100843 BLAKE2B c11658472c4f2ad9916f8f421f0d1c48b9ec7874e9e4075f2247e7cfb33ed69946e644aa9a460d63ff676c075b76caf4c70bd09532dda53b4d2035c88b3c1c61 SHA512 cd4628a56b2a03f7e958d4284c595b573ab84ac6c630cfae4f3ed13bb6d19a66246cb6adac8b05104f562406a467c03841cf350f8482e7e9f8fd596de4f4c873
+DIST gtk-fortran-4.2.1.tar.gz 4111001 BLAKE2B 9cfeb8ef0fff6ab215cc421107ad643370d96ccfdfaac062af46e1793742d53ffcb11169db88a12711fea5309f2d339c2716be20e3e36fe3cc762864c611e732 SHA512 ea2650208f453e8292df1d4e05460b221146ff44e50513702eb5ad4b689d40f6bbd0935d1d617845e3927d25ff3f069a08032b89035d06e5ad688f7d281a2cd9
diff --git a/x11-libs/gtk-fortran/gtk-fortran-3.24.31.ebuild b/x11-libs/gtk-fortran/gtk-fortran-3.24.31.ebuild
new file mode 100644
index 000000000..3fce2073d
--- /dev/null
+++ b/x11-libs/gtk-fortran/gtk-fortran-3.24.31.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_MAKEFILE_GENERATOR="emake"
+FORTRAN_STANDARD=2003
+VIRTUALX_REQUIRED="test"
+
+inherit cmake fortran-2 virtualx
+
+DESCRIPTION="A GTK+ binding to build Graphical User Interfaces in Fortran"
+HOMEPAGE="https://github.com/vmagnin/gtk-fortran"
+SRC_URI="https://github.com/vmagnin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="3"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="examples high-level plplot static-libs test"
+REQUIRED_USE="plplot? ( high-level )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ x11-libs/gtk+:3
+ plplot? ( >=sci-libs/plplot-5.15.0[cairo,fortran] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/fortran
+ virtual/pkgconfig
+"
+
+DOCS=( "README.md" "README-high-level.md" "CHANGELOG.md" )
+
+pkg_setup() {
+ fortran-2_pkg_setup
+}
+
+src_prepare() {
+ default
+ # Fix library installation path, disable 'sketcher' build, pass LDFLAGS
+ sed -i -e "s:CMAKE_INSTALL_LIBDIR lib:CMAKE_INSTALL_LIBDIR $(get_libdir):" \
+ -e "s: add_subdirectory(sketcher)::" \
+ -e 's:"-rdynamic":"-rdynamic '"${LDFLAGS}"'":' CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ mycmakeargs+=(
+ -DEXCLUDE_PLPLOT=$(usex plplot false true)
+ -DNO_BUILD_HL=$(usex high-level false true)
+ -DINSTALL_EXAMPLES=$(usex examples)
+ -DNO_BUILD_EXAMPLES=true
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ virtx cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+
+ # Remove static library here as it's used to build additional tools
+ if use !static-libs ; then
+ rm "${ED}/usr/$(get_libdir)/libgtk-${SLOT}-fortran.a" || die
+ fi
+}
diff --git a/x11-libs/gtk-fortran/gtk-fortran-4.2.1.ebuild b/x11-libs/gtk-fortran/gtk-fortran-4.2.1.ebuild
new file mode 100644
index 000000000..01663bcd6
--- /dev/null
+++ b/x11-libs/gtk-fortran/gtk-fortran-4.2.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_MAKEFILE_GENERATOR="emake"
+FORTRAN_STANDARD=2003
+VIRTUALX_REQUIRED="test"
+
+inherit cmake fortran-2 virtualx
+
+DESCRIPTION="A GTK+ binding to build Graphical User Interfaces in Fortran"
+HOMEPAGE="https://github.com/vmagnin/gtk-fortran"
+SRC_URI="https://github.com/vmagnin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="examples high-level plplot static-libs test"
+REQUIRED_USE="plplot? ( high-level )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ gui-libs/gtk:4
+ plplot? ( >=sci-libs/plplot-5.15.0[cairo,fortran] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/fortran
+ virtual/pkgconfig
+"
+
+DOCS=( "README.md" "README-high-level.md" "CHANGELOG.md" )
+
+pkg_setup() {
+ fortran-2_pkg_setup
+}
+
+src_prepare() {
+ default
+ # Fix library installation path, disable 'sketcher' build, pass LDFLAGS
+ sed -i -e "s:CMAKE_INSTALL_LIBDIR lib:CMAKE_INSTALL_LIBDIR $(get_libdir):" \
+ -e "s: add_subdirectory(sketcher)::" \
+ -e 's:"-rdynamic":"-rdynamic '"${LDFLAGS}"'":' CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ mycmakeargs+=(
+ -DEXCLUDE_PLPLOT=$(usex plplot false true)
+ -DNO_BUILD_HL=$(usex high-level false true)
+ -DINSTALL_EXAMPLES=$(usex examples)
+ -DNO_BUILD_EXAMPLES=true
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ virtx cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+
+ # Remove static library here as it's used to build additional tools
+ if use !static-libs ; then
+ rm "${ED}/usr/$(get_libdir)/libgtk-${SLOT}-fortran.a" || die
+ fi
+}