aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-05-03 05:20:33 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-05-03 05:32:24 +0200
commit0a0939c244e2b9da8b137af5648f5d1435ce792c (patch)
tree064e7b16da6f9ea08dbc98098e03ed31d4b7bd4d
parentdev-R/fs: new package, add 1.5.2 (diff)
downloadguru-0a0939c2.tar.gz
guru-0a0939c2.tar.bz2
guru-0a0939c2.zip
dev-R/googlesheets4: new package, add 1.0.0
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-R/googlesheets4/Manifest1
-rw-r--r--dev-R/googlesheets4/googlesheets4-1.0.0.ebuild43
-rw-r--r--dev-R/googlesheets4/metadata.xml24
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-R/googlesheets4/Manifest b/dev-R/googlesheets4/Manifest
new file mode 100644
index 0000000000..57a9c3527c
--- /dev/null
+++ b/dev-R/googlesheets4/Manifest
@@ -0,0 +1 @@
+DIST googlesheets4_1.0.0.tar.gz 222038 BLAKE2B a393298911dd0f50c6b298f98c18f5ab85432ca416d444a532cd01006e43a2cde5c5fd31b69d0a38efb315a7e14e153e8cdcba5618685528c6ef608956d0cd98 SHA512 2c2be5ad134fc5eae823b1341b1ebebd334fa2f975b2145c9dd771b77a3f09b9d71f13878722c04b66c17232c35cb196ffa049c3cff9482c5787374562481217
diff --git a/dev-R/googlesheets4/googlesheets4-1.0.0.ebuild b/dev-R/googlesheets4/googlesheets4-1.0.0.ebuild
new file mode 100644
index 0000000000..3c6e072d89
--- /dev/null
+++ b/dev-R/googlesheets4/googlesheets4-1.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit R-packages
+
+DESCRIPTION='Access Google Sheets using the Sheets API V4'
+HOMEPAGE="
+ https://cran.r-project.org/package=googlesheets4
+ https://googlesheets4.tidyverse.org/
+ https://github.com/tidyverse/googlesheets4
+"
+KEYWORDS="~amd64"
+LICENSE='MIT'
+
+DEPEND="
+ dev-R/cellranger
+ dev-R/ids
+ dev-R/magrittr
+ >=dev-R/googledrive-2.0.0
+ >=dev-R/glue-1.3.0
+ dev-R/purrr
+ >=dev-R/rlang-0.4.11
+ >=dev-lang/R-3.3
+ >=dev-R/cli-3.0.0
+ dev-R/curl
+ >=dev-R/gargle-1.2.0
+ dev-R/httr
+ dev-R/rematch2
+ >=dev-R/tibble-2.1.1
+ >=dev-R/vctrs-0.2.3
+"
+RDEPEND="${DEPEND}"
+
+SUGGESTED_PACKAGES="
+ dev-R/covr
+ dev-R/readr
+ dev-R/rmarkdown
+ dev-R/spelling
+ >=dev-R/testthat-3.0.0
+ dev-R/withr
+"
diff --git a/dev-R/googlesheets4/metadata.xml b/dev-R/googlesheets4/metadata.xml
new file mode 100644
index 0000000000..7e116083f5
--- /dev/null
+++ b/dev-R/googlesheets4/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <description>co-maintainers welcome</description>
+ <name>Alessandro Barbieri</name>
+ <email>lssndrbarbieri@gmail.com</email>
+ </maintainer>
+ <longdescription lang="en">Interact with Google Sheets through the Sheets API v4
+&lt;https://developers.google.com/sheets/api&gt;. "API" is an acronym for
+"application programming interface"; the Sheets API allows users to
+interact with Google Sheets programmatically, instead of via a web
+browser. The "v4" refers to the fact that the Sheets API is currently
+at version 4. This package can read and write both the metadata and
+the cell data in a Sheet.</longdescription>
+ <upstream>
+ <maintainer>
+ <name>Jennifer Bryan</name>
+ <email>jenny@rstudio.com</email>
+ </maintainer>
+ <bugs-to>https://github.com/tidyverse/googlesheets4/issues</bugs-to>
+ <remote-id type="github">tidyverse/googlesheets4</remote-id>
+ </upstream>
+</pkgmetadata>