aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Smaniotto <smaniotto.nicola@gmail.com>2021-12-29 10:45:15 +0100
committerNicola Smaniotto <smaniotto.nicola@gmail.com>2021-12-29 10:45:38 +0100
commit0a210e9a8d83d773ab640bcdf3895a0fe1100990 (patch)
tree934daa1750c034d75cca4dcc07f722e8cd304d48
parentnet-libs/dpdk: add static linker patch (diff)
downloadguru-0a210e9a.tar.gz
guru-0a210e9a.tar.bz2
guru-0a210e9a.zip
games-arcade/SpaceCadetPinball: bump to 2.0.1
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Nicola Smaniotto <smaniotto.nicola@gmail.com>
-rw-r--r--games-arcade/SpaceCadetPinball/Manifest1
-rw-r--r--games-arcade/SpaceCadetPinball/SpaceCadetPinball-2.0.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/games-arcade/SpaceCadetPinball/Manifest b/games-arcade/SpaceCadetPinball/Manifest
index ae7dcfd5f..95cb3a26e 100644
--- a/games-arcade/SpaceCadetPinball/Manifest
+++ b/games-arcade/SpaceCadetPinball/Manifest
@@ -1 +1,2 @@
+DIST SpaceCadetPinball-2.0.1.tar.gz 1882629 BLAKE2B 55b2c4232880b065bad30371ad4c170ee2fbc485d2673d25d3afa82144d17bc6a74f70cee7dcc365992df61e95d65a97b57924e54a140b98790ee6e75b06cefd SHA512 b8a23c650a6251838c531a7f1427284199ba859fbdf8715a974404dbef3485503dffa723839f6b41d335e2afc73a85bd0fe0d670ebb7fc1462f089250f1f546f
DIST SpaceCadetPinball-2.0.tar.gz 933826 BLAKE2B b4a079ca856ebf315202eaae59a825d4c7022acfff7f38907ffd750f0e146da6d7c4f03286ef5c59ee5e3c725d938e30c2aad2f7269d9f18e8ae8f6807af80e1 SHA512 29b3f886d6ec6507c12a59b0c2877cbb51c54eee0163d0537588bb1e0fa0eb08b530d5684e8753598a823430559d5b3b9490be40ca9a3310043dac71912994c7
diff --git a/games-arcade/SpaceCadetPinball/SpaceCadetPinball-2.0.1.ebuild b/games-arcade/SpaceCadetPinball/SpaceCadetPinball-2.0.1.ebuild
new file mode 100644
index 000000000..004213635
--- /dev/null
+++ b/games-arcade/SpaceCadetPinball/SpaceCadetPinball-2.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="Decompilation of 3D Pinball for Windows - Space Cadet"
+HOMEPAGE="https://github.com/k4zmu2a/SpaceCadetPinball"
+SRC_URI="https://github.com/k4zmu2a/${PN}/archive/refs/tags/Release_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ media-libs/libsdl2
+ media-libs/sdl2-mixer[midi]
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-Release_${PV}"
+
+src_prepare(){
+ # the paths should be relative
+ sed -i "s|/Platform|Platform|g" CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+pkg_postinst(){
+ ewarn "This game is distributed without the data files."
+ ewarn "To play, copy the original DAT and SOUND files from a Windows or"
+ ewarn 'Full Tilt! installation and place them in $XDG_DATA_HOME/'"${PN}/"
+ ewarn "(usually: ~/.local/share/${PN}/)"
+
+ xdg_pkg_postinst
+}