aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Smaniotto <smaniotto.nicola@gmail.com>2023-02-27 12:36:43 +0100
committerNicola Smaniotto <smaniotto.nicola@gmail.com>2023-02-27 16:13:32 +0100
commit0d154d51a4bb8f5f4196468af75f74fd9f1b3acb (patch)
treefb4222261f305ce9720903fdda0cc15d4e53eefb
parentapp-admin/oet: Removed obsolete .sh suffix from install script (diff)
downloadguru-0d154d51.tar.gz
guru-0d154d51.tar.bz2
guru-0d154d51.zip
mpv-plugin/autoload: add 0.35.1
Signed-off-by: Nicola Smaniotto <smaniotto.nicola@gmail.com>
-rw-r--r--mpv-plugin/autoload/Manifest1
-rw-r--r--mpv-plugin/autoload/autoload-0.35.1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/mpv-plugin/autoload/Manifest b/mpv-plugin/autoload/Manifest
index 081911f37..de69fca51 100644
--- a/mpv-plugin/autoload/Manifest
+++ b/mpv-plugin/autoload/Manifest
@@ -1,2 +1,3 @@
DIST mpv-0.34.1.tar.gz 3288356 BLAKE2B c0e5dc3cd23307449a526bd2cf0df5d870322aa1914a139784fd50d77274d42648a769ee4da3ba74e34a7a080700a5740dae13ed0827df1b3cfef36846f983ab SHA512 77ea349d6999f8cce9b5cce4cebd3506a224fc18ab08d22dd16bd34c34d012bb170879b268ddd62db40d116b4cc0b2d9d651b8097f387ed9115c426834cac77e
DIST mpv-0.35.0.tar.gz 3365752 BLAKE2B 9b8dca943fc60a68f8474549d75c021dd9157195253c5ec09721969e500b2756c033e86975499f5632f0c943ac7bb54699f47340f0dee73d7284668d4419b17f SHA512 d5c1f734057f6b6c27e7f59de43cf7c0e7f813d842b8c7fd2ae1073dbe649c8187b7686df4efe928db2952e9f1efc171245e6f8780c1d9f174f4d7abff1e073a
+DIST mpv-0.35.1.tar.gz 3367913 BLAKE2B 706a2031a2ca973eb3a092ec7f62ba40ca4dfd78e3ffe5d6e432486b0018852b034152a21805be594054178ccb17856dafe2b860cddcc22d27df895d163871de SHA512 42f3564a9ed4d972d14b2c697b0163f06a8bb68a0606a86c34935181247c783e3cb62286b445799998def0919fb13fce8b8f6453f82652d5bfaea5929119127a
diff --git a/mpv-plugin/autoload/autoload-0.35.1.ebuild b/mpv-plugin/autoload/autoload-0.35.1.ebuild
new file mode 100644
index 000000000..e46627eca
--- /dev/null
+++ b/mpv-plugin/autoload/autoload-0.35.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_MPV="rdepend"
+MPV_REQ_USE="lua"
+inherit mpv-plugin
+
+DESCRIPTION="Loads playlist entries before and after the the currently played file"
+HOMEPAGE="https://github.com/mpv-player/mpv/tree/master/TOOLS/lua"
+
+# use the already available mpv tarball
+SRC_URI="https://github.com/mpv-player/mpv/archive/v${PV}.tar.gz -> mpv-${PV}.tar.gz"
+
+# since this comes from mpv, use its licenses
+LICENSE="LGPL-2.1+ GPL-2+ BSD ISC MIT"
+KEYWORDS="~amd64"
+
+# lock mpv version
+RDEPEND="~media-video/mpv-${PV}"
+
+S="${WORKDIR}/mpv-${PV}/TOOLS/lua"
+
+MPV_PLUGIN_FILES=( ${PN}.lua )