aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-11-01 21:37:49 +0100
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-11-02 04:40:36 +0100
commit0d624671aae30a75d7fc3a7858d907ca1c5eefee (patch)
tree40da860fc599b567b711449afe02cb38992570e5
parentdev-python/pytest-randomly: add 3.10.1, drop 3.8.0 (diff)
downloadguru-0d624671.tar.gz
guru-0d624671.tar.bz2
guru-0d624671.zip
dev-python/pip-api: new version
Closes: https://bugs.gentoo.org/799458 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/pip-api/Manifest2
-rw-r--r--dev-python/pip-api/pip-api-0.0.23.ebuild (renamed from dev-python/pip-api/pip-api-0.0.20.ebuild)12
2 files changed, 6 insertions, 8 deletions
diff --git a/dev-python/pip-api/Manifest b/dev-python/pip-api/Manifest
index 032d2721b..27482f2ae 100644
--- a/dev-python/pip-api/Manifest
+++ b/dev-python/pip-api/Manifest
@@ -1 +1 @@
-DIST pip-api-0.0.20.tar.gz 111267 BLAKE2B 9cbb1087f93008ca94d35c5e83d9e159a460a8eae26261c3efc2eeded9b68d627045b1506c5b4c868a8782ad7e0b535a120ad9e2c56df8d6d3b81f51f273deb8 SHA512 c447d986ef4003221d3ed5b020bfe0f8330d969c9bda0af2eab2665712dbed5b3e2e5d05ca2d47ed6d217d180d4231afea46627886968803620cffa5e0979ca4
+DIST pip-api-0.0.23.tar.gz 106534 BLAKE2B c608260c16281015d26881ed959d0f6712af8971d8e1f1a8128d6bc651c434e574bce3bacf0d773cd4dab1d89cc1dda478448079b1591ddb09eb0e3fe0c44ef1 SHA512 68ac25fc8c3f4dccbd9895900141291aab033a67def7b2da333331b96e3dcfd06ebda90ebe679938e8d126fa6e108f3c7c0805c9e0bf46af55da2f14894d680c
diff --git a/dev-python/pip-api/pip-api-0.0.20.ebuild b/dev-python/pip-api/pip-api-0.0.23.ebuild
index e0b8e1f8a..08b587052 100644
--- a/dev-python/pip-api/pip-api-0.0.20.ebuild
+++ b/dev-python/pip-api/pip-api-0.0.23.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+EPYTEST_DESELECT=( tests/test_installed_distributions.py::test_installed_distributions_legacy_version )
DISTUTILS_SETUPTOOLS="pyproject.toml"
PYTHON_COMPAT=( python3_{8..10} pypy3 )
@@ -16,8 +17,9 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
-DEPEND="
- dev-python/pip[${PYTHON_USEDEP}]
+DEPEND="<=dev-python/pip-21.3.1[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+BDEPEND="
test? (
dev-python/pretend[${PYTHON_USEDEP}]
>=dev-python/virtualenv-20[${PYTHON_USEDEP}]
@@ -25,7 +27,3 @@ DEPEND="
"
distutils_enable_tests pytest
-
-python_test() {
- epytest -vv --deselect tests/test_installed_distributions.py::test_installed_distributions_legacy_version || die
-}