aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-08-19 17:46:33 +0200
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-08-19 17:46:33 +0200
commit0e70dbcc07413a6f106b7462c277ce919db08099 (patch)
treea23aaea7459697541ee4ff353b9ca4f30b34c7d7
parentdev-cpp/drogon: drop 1.7.4, 1.7.5 (diff)
downloadguru-0e70dbcc.tar.gz
guru-0e70dbcc.tar.bz2
guru-0e70dbcc.zip
dev-libs/mtxclient: work around LTO build failure
Closes: https://bugs.gentoo.org/861731 Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
-rw-r--r--dev-libs/mtxclient/mtxclient-0.8.0.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-libs/mtxclient/mtxclient-0.8.0.ebuild b/dev-libs/mtxclient/mtxclient-0.8.0.ebuild
index 7b9d756dc..a3e74c2c7 100644
--- a/dev-libs/mtxclient/mtxclient-0.8.0.ebuild
+++ b/dev-libs/mtxclient/mtxclient-0.8.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="Client API library for Matrix, built on top of Boost.Asio"
HOMEPAGE="https://github.com/Nheko-Reborn/mtxclient"
@@ -33,6 +33,14 @@ PATCHES=(
"${FILESDIR}/0.6.0_remove_network_tests.patch"
)
+src_prepare() {
+ if use test; then
+ filter-lto # bug #861731
+ fi
+
+ cmake_src_prepare
+}
+
src_configure() {
local -a mycmakeargs=(
-DBUILD_LIB_TESTS="$(usex test)"