aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Flogeras <dflogeras2@gmail.com>2020-06-25 14:01:44 -0300
committerDavid Flogeras <dflogeras2@gmail.com>2020-06-25 14:03:05 -0300
commit117f9db5c9ded669ac23966171cfc98ef052df59 (patch)
treebc78849064d2c4af52bba902c9571fb3023f9eeb
parentx11-libs/kcolorpicker: Bump to 0.1.4 (diff)
downloadguru-117f9db5.tar.gz
guru-117f9db5.tar.bz2
guru-117f9db5.zip
x11-libs/kimageannotator: Bump to 0.3.0
Signed-off-by: David Flogeras <dflogeras2@gmail.com>
-rw-r--r--x11-libs/kimageannotator/Manifest1
-rw-r--r--x11-libs/kimageannotator/files/fix-undo-command-delete-items-that-are-required.patch10
-rw-r--r--x11-libs/kimageannotator/files/include-gnuinstalldirs-before-use.patch36
-rw-r--r--x11-libs/kimageannotator/kimageannotator-0.3.0.ebuild31
4 files changed, 78 insertions, 0 deletions
diff --git a/x11-libs/kimageannotator/Manifest b/x11-libs/kimageannotator/Manifest
index ba05e37be..539d692fd 100644
--- a/x11-libs/kimageannotator/Manifest
+++ b/x11-libs/kimageannotator/Manifest
@@ -1 +1,2 @@
DIST kImageAnnotator-0.2.1.tar.gz 107027 BLAKE2B 247ea31f3dfd90fd175b879c3fe06a50ee2ce8f3f2ce395efa1882fe8abc4be4e5a739782054682336cf327fe288d24b17971c89dfaf7f5202ba3f607165b0f2 SHA512 6f9d03b6d0d020c90fa050ac6be30b680db8dd3a2035db80856bb69c9e6ef0228b2d152c5f234caf6d3fe2d8433b17fbdfee728246f2a8c339936b6ba051a52b
+DIST kImageAnnotator-0.3.0.tar.gz 128019 BLAKE2B 412748b432e41e6bdc01aa7270cbb32342016423beeca537c92096641e06f9a82a0ce7d1779fb25aec51e6e4c9451778fc339bb3c82edcdc56657ac810859447 SHA512 0d9e4ab5bdef1554e3b476e0d0e8f2ad08387abd94d9167c2b4987b0857294618b7a6626640381dade10c7eedaa5dec9e449715b46437c1d9a044142c15b7617
diff --git a/x11-libs/kimageannotator/files/fix-undo-command-delete-items-that-are-required.patch b/x11-libs/kimageannotator/files/fix-undo-command-delete-items-that-are-required.patch
new file mode 100644
index 000000000..39aa7590c
--- /dev/null
+++ b/x11-libs/kimageannotator/files/fix-undo-command-delete-items-that-are-required.patch
@@ -0,0 +1,10 @@
+--- a/src/annotations/undo/AddCommand.cpp
++++ b/src/annotations/undo/AddCommand.cpp
+@@ -29,7 +29,6 @@ AddCommand::AddCommand(AbstractAnnotationItem *item, AnnotationArea *annotationA
+
+ AddCommand::~AddCommand()
+ {
+- delete mItem;
+ }
+
+ void AddCommand::undo()
diff --git a/x11-libs/kimageannotator/files/include-gnuinstalldirs-before-use.patch b/x11-libs/kimageannotator/files/include-gnuinstalldirs-before-use.patch
new file mode 100644
index 000000000..c5c7677d8
--- /dev/null
+++ b/x11-libs/kimageannotator/files/include-gnuinstalldirs-before-use.patch
@@ -0,0 +1,36 @@
+From 94b08e1a3cef1d826ccae09a1287c2d5e327a293 Mon Sep 17 00:00:00 2001
+From: Dave Flogeras <dflogeras2@gmail.com>
+Date: Fri, 19 Jun 2020 09:23:29 -0300
+Subject: [PATCH] Include GNUInstallDirs before using variables that rely on
+ it.
+
+This was subtle because when building by hand, and running cmake
+multiple times, it seems to cache the variable. However when building
+for Gentoo in an ebuild, cmake makes one pass, and the
+CMAKE_INSTALL_DATAROOTDIR variable is empty. This results in the
+translation files going in the wrong place.
+---
+ CMakeLists.txt | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 12ad227..5c14937 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -11,6 +11,8 @@ set(CMAKE_AUTORCC ON)
+ option(BUILD_TESTS "Build Unit Tests" OFF)
+ option(BUILD_EXAMPLE "Build Example Application" ON)
+
++include(GNUInstallDirs)
++
+ if (WIN32)
+ set(KIMAGEANNOTATOR_LANG_INSTAL_DIR "translations")
+ elseif (APPLE)
+@@ -27,7 +29,6 @@ if (UNIX)
+ find_package(X11 REQUIRED)
+ endif ()
+
+-include(GNUInstallDirs)
+ include(FeatureSummary)
+
+ set(KCOLORPICKER_MIN_VERSION "0.1.4")
diff --git a/x11-libs/kimageannotator/kimageannotator-0.3.0.ebuild b/x11-libs/kimageannotator/kimageannotator-0.3.0.ebuild
new file mode 100644
index 000000000..d1dd0cb22
--- /dev/null
+++ b/x11-libs/kimageannotator/kimageannotator-0.3.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Tool for annotating images"
+HOMEPAGE="https://github.com/ksnip/kImageAnnotator"
+MY_PN=kImageAnnotator
+MY_P="${MY_PN}-${PV}"
+SRC_URI="https://github.com/ksnip/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtsvg:5
+ >=x11-libs/kcolorpicker-0.1.4"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/fix-undo-command-delete-items-that-are-required.patch
+ eapply "${FILESDIR}"/include-gnuinstalldirs-before-use.patch
+ cmake_src_prepare
+}