aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2021-04-28 13:55:17 +1200
committerTheo Anderson <telans@posteo.de>2021-04-28 13:55:17 +1200
commit1507b769827356f2960c80ec827fadc28d9295cc (patch)
treeef26980759c9e11f9b4f3280ba32412d0ef2ecad
parentnet-p2p/monero: add 0.17.2.0 (diff)
downloadguru-1507b769827356f2960c80ec827fadc28d9295cc.tar.gz
guru-1507b769827356f2960c80ec827fadc28d9295cc.tar.bz2
guru-1507b769827356f2960c80ec827fadc28d9295cc.zip
net-p2p/monero: drop 0.17.1.9
Signed-off-by: Theo Anderson <telans@posteo.de>
-rw-r--r--net-p2p/monero/Manifest1
-rw-r--r--net-p2p/monero/monero-0.17.1.9.ebuild116
2 files changed, 0 insertions, 117 deletions
diff --git a/net-p2p/monero/Manifest b/net-p2p/monero/Manifest
index cfe934532..2161c94fc 100644
--- a/net-p2p/monero/Manifest
+++ b/net-p2p/monero/Manifest
@@ -1,2 +1 @@
-DIST monero-0.17.1.9.tar.gz 10607015 BLAKE2B 2746fa1d8feafead39f10d1c8800ecd82e4049930b7acae42e946474558114422703e8cb37f1bd3833e57ec9987ccdff2fd530a632693cab206420153f8e6ab4 SHA512 b529d1c691584a5bf1e1fa342909dbb296ef57b0b7d018d95dd40ee418257a15f8f94ec74f780762f28f57f5db4a953becce97558af407f89828d55da88e61d8
DIST monero-0.17.2.0.tar.gz 10622184 BLAKE2B c439e447f524a08a7ee79420873b7cf393f5cd3269460944aac30a315ac7c273c12fd809d86d41445bfc7e8c2feb0538d4e9fc1dadeb55f7e09f2920778f07a7 SHA512 85b764f1fc25127e7ca4ada67b1d832a9604c4cf65b160d689650e7ca7bbc36b73d8b26c5409fabdaad7369684997447cd812d1c521fad19d24f5b35f4789a1e
diff --git a/net-p2p/monero/monero-0.17.1.9.ebuild b/net-p2p/monero/monero-0.17.1.9.ebuild
deleted file mode 100644
index 2cfccaa2d..000000000
--- a/net-p2p/monero/monero-0.17.1.9.ebuild
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake systemd
-
-DESCRIPTION="The secure, private, untraceable cryptocurrency"
-HOMEPAGE="https://github.com/monero-project/monero"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/monero-project/monero.git"
-else
- SRC_URI="https://github.com/monero-project/monero/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~x86"
-fi
-
-LICENSE="BSD MIT"
-SLOT="0"
-IUSE="+daemon readline +tools +wallet-cli +wallet-rpc"
-REQUIRED_USE="|| ( daemon tools wallet-cli wallet-rpc )"
-RESTRICT="test"
-
-DEPEND="
- acct-group/monero
- acct-user/monero
- dev-libs/boost:=[nls,threads]
- dev-libs/libsodium:=
- dev-libs/openssl:=
- dev-libs/randomx
- dev-libs/rapidjson
- dev-libs/supercop
- net-dns/unbound:=[threads]
- net-libs/czmq:=
- net-libs/miniupnpc
- readline? ( sys-libs/readline:0= )
-"
-RDEPEND="${DEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.17.1.7-linkjobs.patch"
- "${FILESDIR}/${PN}-0.17.1.7-unbundle-dependencies.patch"
-)
-
-src_configure() {
- local mycmakeargs=(
- # TODO: Update CMake to install built libraries (help wanted)
- -DBUILD_SHARED_LIBS=OFF
- -DMANUAL_SUBMODULES=ON
- -DMONERO_PARALLEL_LINK_JOBS=1
- -DUSE_DEVICE_TREZOR=OFF
- )
-
- cmake_src_configure
-}
-
-src_compile() {
- local targets=()
- use daemon && targets+=(daemon)
- use tools && targets+=(blockchain_{ancestry,blackball,db,depth,export,import,prune,prune_known_spent_data,stats,usage})
- use wallet-cli && targets+=(simplewallet)
- use wallet-rpc && targets+=(wallet_rpc_server)
- cmake_build ${targets[@]}
-}
-
-src_install() {
- einstalldocs
-
- # Install all binaries.
- find "${BUILD_DIR}/bin/" -type f -executable -print0 |
- while IFS= read -r -d '' line; do
- dobin "$line"
- done
-
- if use daemon; then
- dodoc utils/conf/monerod.conf
-
- # data-dir
- keepdir /var/lib/monero
- fowners monero:monero /var/lib/monero
- fperms 0755 /var/lib/monero
-
- # log-file dir
- keepdir /var/log/monero
- fowners monero:monero /var/log/monero
- fperms 0755 /var/log/monero
-
- # /etc/monero/monerod.conf
- insinto /etc/monero
- doins "${FILESDIR}/monerod.conf"
-
- # OpenRC
- newconfd "${FILESDIR}/monerod.confd" monerod
- newinitd "${FILESDIR}/monerod.initd" monerod
-
- # systemd
- systemd_dounit "${FILESDIR}/monerod.service"
- fi
-}
-
-pkg_postinst() {
- if use daemon; then
- elog "Start the Monero P2P daemon as a system service with"
- elog "'rc-service monerod start'. Enable it at startup with"
- elog "'rc-update add monerod default'."
- elog
- elog "Run monerod status as any user to get sync status and other stats."
- elog
- elog "The Monero blockchain can take up a lot of space (80 GiB) and is stored"
- elog "in /var/lib/monero by default. You may want to enable pruning by adding"
- elog "'prune-blockchain=1' to /etc/monero/monerod.conf to prune the blockchain"
- elog "or move the data directory to another disk."
- fi
-}