aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-11-04 04:46:42 +0100
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-11-04 04:46:42 +0100
commit156798cb93afb69453e3cc62f5fe58a51db45742 (patch)
tree95a43022816678d08d3c60e10b4e10d2b7e201bd
parentgames-util/legendary: drop 0.20.28 (diff)
downloadguru-156798cb.tar.gz
guru-156798cb.tar.bz2
guru-156798cb.zip
x11-misc/autotiling: add 1.8
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
-rw-r--r--x11-misc/autotiling/Manifest1
-rw-r--r--x11-misc/autotiling/autotiling-1.8.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/x11-misc/autotiling/Manifest b/x11-misc/autotiling/Manifest
index b944764da..2bc15017a 100644
--- a/x11-misc/autotiling/Manifest
+++ b/x11-misc/autotiling/Manifest
@@ -1 +1,2 @@
DIST autotiling-1.7.tar.gz 17675 BLAKE2B e2e220aca96c9d218b96c8dcb98bd37d5b481df11a9513bb1ba8604a268a2b93ffc030f172023b86adca2768597f91ef1d6afb83b65f37c5b4ad192a839b0253 SHA512 ea6d84f033d2148cd46d0b754a15bc09847997856a73374d477e4abfd761e0df5e96bc30a24d5b0cd92bc1836a480b4c9fd71734a1707ef8877de66e4120abc7
+DIST autotiling-1.8.tar.gz 18245 BLAKE2B 7d2230a4e5895ca495d72dcc2c2ebc5128dc40278f8c948b880887f158e51e847dfbd02988551065ef2b87f49bc87a6452ba67fa7a52894c8ec251024b6036b6 SHA512 b96a171a926f9e248b5899481f3355f52e9fcfd328d2843d76381f72c404923a0c63db7e2a2bfd514c94f7809f39326b097578eb22af6ac6577bbedc5a142016
diff --git a/x11-misc/autotiling/autotiling-1.8.ebuild b/x11-misc/autotiling/autotiling-1.8.ebuild
new file mode 100644
index 000000000..5040f5f73
--- /dev/null
+++ b/x11-misc/autotiling/autotiling-1.8.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="Script for sway and i3 to automatically switch the window split orientation"
+HOMEPAGE="https://github.com/nwg-piotr/autotiling"
+SRC_URI="https://github.com/nwg-piotr/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="$(python_gen_cond_dep '>=dev-python/i3ipc-2.0.1[${PYTHON_USEDEP}]')"
+DEPEND="${RDEPEND}"
+BDEPEND="$(python_gen_cond_dep 'dev-python/wheel[${PYTHON_USEDEP}]')"