aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-04-30 13:13:11 -0400
committerAisha Tammy <gentoo@aisha.cc>2020-04-30 13:13:11 -0400
commit15df1b747096cc3f97394e2afbcb8557b61c1246 (patch)
treef58f30737fcb89009225af64bb4124569c2923b6
parentdev-cpp/usockets: tiny, ultra fast, async sockets framework (diff)
downloadguru-15df1b74.tar.gz
guru-15df1b74.tar.bz2
guru-15df1b74.zip
dev-cpp/uwebsockets: async tcp, udp websockets framework
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
-rw-r--r--dev-cpp/uwebsockets/Manifest1
-rw-r--r--dev-cpp/uwebsockets/files/uwebsockets-Makefile.patch24
-rw-r--r--dev-cpp/uwebsockets/files/uwebsockets-src_Loop.h.patch13
-rw-r--r--dev-cpp/uwebsockets/metadata.xml12
-rw-r--r--dev-cpp/uwebsockets/uwebsockets-0.17.4.ebuild34
5 files changed, 84 insertions, 0 deletions
diff --git a/dev-cpp/uwebsockets/Manifest b/dev-cpp/uwebsockets/Manifest
new file mode 100644
index 0000000000..a34d17f33b
--- /dev/null
+++ b/dev-cpp/uwebsockets/Manifest
@@ -0,0 +1 @@
+DIST uwebsockets-0.17.4.tar.gz 206285 BLAKE2B bf1394dc2c1e2bbb557238089443ab99e7de5fd73a2998ec5b1f392d80254ec0858a5ed58d94b98aeb0094ad0a1883772d41548583e3beafd12f263adbf4ccf1 SHA512 5d40003d69b0541e9f73b028ca1630f0840fc40495a88de23656829169088f7c5ce23ec2f6d0da07a9a1cd42b5be3a47fb719f4c98e546eb9a4a80e29010889d
diff --git a/dev-cpp/uwebsockets/files/uwebsockets-Makefile.patch b/dev-cpp/uwebsockets/files/uwebsockets-Makefile.patch
new file mode 100644
index 0000000000..bc6ba5cc03
--- /dev/null
+++ b/dev-cpp/uwebsockets/files/uwebsockets-Makefile.patch
@@ -0,0 +1,24 @@
+diff --git a/Makefile b/Makefile
+index ae71753..d057e96 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,3 +1,9 @@
++DESTDIR ?=
++
++prefix ?= "/usr/local"
++exec_prefix ?= "$(prefix)"
++includedir?= "$(exec_prefix)/include/uWebSockets"
++
+ EXAMPLE_FILES := HelloWorld EchoServer BroadcastingEchoServer
+ THREADED_EXAMPLE_FILES := HelloWorldThreaded EchoServerThreaded
+ override CXXFLAGS += -lpthread -Wconversion -std=c++17 -Isrc -IuSockets/src
+@@ -38,3 +44,9 @@ all:
+ clean:
+ rm -rf $(EXAMPLE_FILES) $(THREADED_EXAMPLE_FILES)
+ rm -rf fuzzing/*.o benchmarks/*.o
++install:
++ # create the folder for the header files
++ install -d "$(DESTDIR)$(includedir)/f2"
++ # now install the header files
++ install -m 644 src/*.h "$(DESTDIR)$(includedir)/"
++ install -m 644 src/f2/function2.hpp "$(DESTDIR)$(includedir)/f2/"
diff --git a/dev-cpp/uwebsockets/files/uwebsockets-src_Loop.h.patch b/dev-cpp/uwebsockets/files/uwebsockets-src_Loop.h.patch
new file mode 100644
index 0000000000..d4bded9f04
--- /dev/null
+++ b/dev-cpp/uwebsockets/files/uwebsockets-src_Loop.h.patch
@@ -0,0 +1,13 @@
+diff --git a/src/Loop.h b/src/Loop.h
+index 3681dad..03d8a75 100644
+--- a/src/Loop.h
++++ b/src/Loop.h
+@@ -21,7 +21,7 @@
+ /* The loop is lazily created per-thread and run with uWS::run() */
+
+ #include "LoopData.h"
+-#include <libusockets.h>
++#include <uSockets/libusockets.h>
+
+ namespace uWS {
+ struct Loop {
diff --git a/dev-cpp/uwebsockets/metadata.xml b/dev-cpp/uwebsockets/metadata.xml
new file mode 100644
index 0000000000..cfbacced23
--- /dev/null
+++ b/dev-cpp/uwebsockets/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-cpp/uwebsockets/uwebsockets-0.17.4.ebuild b/dev-cpp/uwebsockets/uwebsockets-0.17.4.ebuild
new file mode 100644
index 0000000000..994c5699d3
--- /dev/null
+++ b/dev-cpp/uwebsockets/uwebsockets-0.17.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="ultra fast, simple, secure & standards compliant web I/O"
+HOMEPAGE="https://github.com/uNetworking/uWebSockets"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/uNetworking/uWebSockets.git"
+else
+ SRC_URI="https://github.com/uNetworking/uWebSockets/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ S="${WORKDIR}/uWebSockets-${PV}"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+RDEPEND="~dev-cpp/usockets-0.3.5"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-Makefile.patch"
+ "${FILESDIR}/${PN}-src_Loop.h.patch"
+)
+
+src_compile() {
+ return 0
+}
+
+src_install() {
+ emake prefix="/usr" DESTDIR="${D}" install
+}