aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortastytea <gentoo@tastytea.de>2024-05-07 19:42:45 +0200
committertastytea <gentoo@tastytea.de>2024-05-07 19:42:45 +0200
commit17dd1aa8a9de906722aa55e15d0880371de6145f (patch)
tree6745c387a2a3f8f74e82303eb6dc63f06a1842c1
parentmedia-libs/raylib: new package, add 5.0, 9999 (diff)
downloadguru-17dd1aa8a9de906722aa55e15d0880371de6145f.tar.gz
guru-17dd1aa8a9de906722aa55e15d0880371de6145f.tar.bz2
guru-17dd1aa8a9de906722aa55e15d0880371de6145f.zip
x11-misc/autotiling: add 1.9.2
switch back to github because version on PyPi is outdated again Closes: https://bugs.gentoo.org/931489 Signed-off-by: tastytea <gentoo@tastytea.de>
-rw-r--r--x11-misc/autotiling/Manifest1
-rw-r--r--x11-misc/autotiling/autotiling-1.9.2.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/x11-misc/autotiling/Manifest b/x11-misc/autotiling/Manifest
index d450c9a26e..a243374160 100644
--- a/x11-misc/autotiling/Manifest
+++ b/x11-misc/autotiling/Manifest
@@ -1,2 +1,3 @@
DIST autotiling-1.9.1.tar.gz 18084 BLAKE2B 42d3ed0400d997dea2a1ab3c1f1e581678c8ff9171c492adbacb10f3269f1859f15dbfd0ec7ffe23aeb915f2922f1d278b4219fcfda7bba6b1122363fbb9d6ec SHA512 39ffc97b27c9ade5b988462393f42cd45b5283cc3c4d03efe8ba46729ca8aaf5602e036abde2158d6ffa674ed0daed48b917d86ed97b33865e0c38ef2a475143
+DIST autotiling-1.9.2.gh.tar.gz 18989 BLAKE2B 0c4aba21b214473fc58ee3286c62f17bc48b81db6b83d3afc402576514c8a4837563c3695440a7159365fb4503800c86dca493f8aa44ba5bfde826ccbde4961e SHA512 84a9a1328b1c4cc599219f2a1d9e08ede56d5cf926d7f0f3539f0de4ffdfd397354f7b25385f663bcb7526acd5da762a8624f6e0b661ebd82737c3c574d8bd9d
DIST autotiling-1.9.tar.gz 18931 BLAKE2B c3035a78abff9de2fad6e0ffb53cbf9e19e5dfebbb5fc1f78d5d54de89f8856287dd6439b2fba7c5ca027dfbc3d2826ee8d2c0593d0098fccfde7cab718537ab SHA512 5850bc3cf11bdfc69ea9fdc42f5f1eb7ead5b726bf3f6f52cf3335e83fb9ef5cac7d062b38a75b95307fe0f1a8e3f024b65bf7d42bcfd5ebf7a6fb891d97b99f
diff --git a/x11-misc/autotiling/autotiling-1.9.2.ebuild b/x11-misc/autotiling/autotiling-1.9.2.ebuild
new file mode 100644
index 0000000000..72c7e0731b
--- /dev/null
+++ b/x11-misc/autotiling/autotiling-1.9.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="Script for sway and i3 to automatically switch the window split orientation"
+HOMEPAGE="https://github.com/nwg-piotr/autotiling"
+SRC_URI="https://github.com/nwg-piotr/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="$(python_gen_cond_dep '>=dev-python/i3ipc-2.0.1[${PYTHON_USEDEP}]')"
+DEPEND="${RDEPEND}"
+BDEPEND="$(python_gen_cond_dep 'dev-python/wheel[${PYTHON_USEDEP}]')"