aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-07-29 08:39:04 -0400
committerAisha Tammy <gentoo@aisha.cc>2020-07-29 08:44:37 -0400
commit19fdfeaf817d60d06fe851d301f4f1ad6ca4a238 (patch)
treef678f3445dcaa6be52d5be3dfb803106584fb76a
parentnet-libs/usockets: drop old version (diff)
downloadguru-19fdfeaf.tar.gz
guru-19fdfeaf.tar.bz2
guru-19fdfeaf.zip
www-apps/uwebsockets: update to 18.10.0
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
-rw-r--r--www-apps/uwebsockets/Manifest1
-rw-r--r--www-apps/uwebsockets/uwebsockets-18.10.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/www-apps/uwebsockets/Manifest b/www-apps/uwebsockets/Manifest
index 026f06539..2eedfa00f 100644
--- a/www-apps/uwebsockets/Manifest
+++ b/www-apps/uwebsockets/Manifest
@@ -1 +1,2 @@
+DIST uwebsockets-18.10.0.tar.gz 265369 BLAKE2B 1ddd16f1793144c4e89681c2eae56e66db711fe94d17120222bf652df9616376fd1194baa0b7b10a89f6551ad1b62998c9993681b60ac5924e9b28500737fe46 SHA512 93d97ac45aabad5be4b8a5ba91e04c360e83a82e9d781aebeb5b325b8f11d2f25fb4d07dbce105978b947f7324d06d2e3877d07c14482961feed4171529248d1
DIST uwebsockets-18.9.0.tar.gz 265223 BLAKE2B c7112040e699eeba4aaa753637a4039597979962c6e4815c2f10af993dd0724e5c18c99d3438e3efec5a18878be33cfd7eb641489a4d3546c92c3ad8e7551647 SHA512 c34f7ace7ab5c077ce5f6cc3fbc38323ad34ccf639a77c4b82ee0905ac2910b584140333d9a7afeb53596619baa15ba890ba25c34c3dbcb49e646f9ecff1f362
diff --git a/www-apps/uwebsockets/uwebsockets-18.10.0.ebuild b/www-apps/uwebsockets/uwebsockets-18.10.0.ebuild
new file mode 100644
index 000000000..2738b66dd
--- /dev/null
+++ b/www-apps/uwebsockets/uwebsockets-18.10.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="ultra fast, simple, secure & standards compliant web I/O"
+HOMEPAGE="https://github.com/uNetworking/uWebSockets"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/uNetworking/uWebSockets.git"
+else
+ SRC_URI="https://github.com/uNetworking/uWebSockets/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ S="${WORKDIR}/uWebSockets-${PV}"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+RDEPEND=">=net-libs/usockets-0.4.1"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-src_Loop.h.patch"
+)
+
+src_prepare() {
+ default
+ mv src uWebSockets
+}
+
+src_compile() {
+ return 0
+}
+
+src_install() {
+ doheader -r uWebSockets
+}