aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2022-03-06 00:17:59 +0100
committerOliver Freyermuth <o.freyermuth@googlemail.com>2022-03-06 00:17:59 +0100
commit1a0ab44edcf9cf6ea1abe63e3146f5150b783cb7 (patch)
tree9479a300c82f01de7a45e0c7c87e915201972726
parentmedia-video/mpv-mpris: Fix broken library install path. (diff)
downloadguru-1a0ab44edcf9cf6ea1abe63e3146f5150b783cb7.tar.gz
guru-1a0ab44edcf9cf6ea1abe63e3146f5150b783cb7.tar.bz2
guru-1a0ab44edcf9cf6ea1abe63e3146f5150b783cb7.zip
media-video/mpv-mpris: bump to 0.7.
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com>
-rw-r--r--media-video/mpv-mpris/Manifest1
-rw-r--r--media-video/mpv-mpris/mpv-mpris-0.7.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/media-video/mpv-mpris/Manifest b/media-video/mpv-mpris/Manifest
index fe3bc469b..e4703e19a 100644
--- a/media-video/mpv-mpris/Manifest
+++ b/media-video/mpv-mpris/Manifest
@@ -1,2 +1,3 @@
DIST mpv-mpris-0.5.tar.gz 8559 BLAKE2B 7eef231ab3855ed3f0a708484881f1df93152d9b79be491986ed0da2cd54870101d5fd90a35d95344b886a6af930c303b3f8c0bc480b55c8799ec8b96e7acdab SHA512 9c28b4f3fdcd6bddf3824125f994807d7a31f8e7398178296dab9d4422d3cc71a0b798ae75fe68c890556c993fb04bf5d7ffa379676312840fdf219bf4a974f7
DIST mpv-mpris-0.6.tar.gz 8910 BLAKE2B 44888f9a0945bf850ba48a4b2a5b2d03325e05b17111a6184c3540eaf15745c7bb18006b03dd018599e017837c005bf10dafc910b3e031e440a511a5496d6ab4 SHA512 da92e4cf6541f0f18fc1c779ab87eef914e6e76a94bfe1259b323953a11654b228d02c4d352ea0c588308bedc8aa807bdaa41023917629a90d50269f454e256d
+DIST mpv-mpris-0.7.tar.gz 12982 BLAKE2B db919cdad6528519211725694f63871e371a33a331c46eebb202fa87d452d1cf30cecf3d4c2b26cb187cfa2c4cdd53411b88e6e7855510ffbaeef28ab3eb8346 SHA512 b370c9550622302cfdd07c21ae2f03a4e66e80da02e8f38c68d447ef273ae582ad6d918e207a9fb8c917a851163c6aadc08d3d68ad8e70ec85b37732c0cac96f
diff --git a/media-video/mpv-mpris/mpv-mpris-0.7.ebuild b/media-video/mpv-mpris/mpv-mpris-0.7.ebuild
new file mode 100644
index 000000000..8814420b5
--- /dev/null
+++ b/media-video/mpv-mpris/mpv-mpris-0.7.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="MPRIS plugin for mpv"
+HOMEPAGE="https://github.com/hoyon/mpv-mpris"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hoyon/${PN}.git"
+else
+ SRC_URI="https://github.com/hoyon/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+SLOT="0"
+LICENSE="MIT"
+IUSE="+autoload test"
+
+RDEPEND="
+ dev-libs/glib:2
+ media-video/mpv:=[cplugins,libmpv]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ test? (
+ app-misc/jq
+ app-shells/bash
+ app-text/jo
+ media-sound/playerctl
+ net-misc/socat
+ sys-apps/dbus
+ virtual/awk
+ x11-apps/xauth
+ x11-misc/xvfb-run
+ x11-themes/sound-theme-freedesktop
+ )
+"
+RESTRICT="!test? ( test )"
+
+src_compile() {
+ tc-export CC
+ emake PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ insinto "/usr/$(get_libdir)/mpv"
+ doins mpris.so
+ use autoload && dosym -r /usr/$(get_libdir)/mpv/mpris.so /etc/mpv/scripts/mpris.so
+ einstalldocs
+}
+
+pkg_postinst() {
+ if ! use autoload; then
+ elog
+ elog "The plugin has not been installed to /etc/mpv/scripts for autoloading."
+ elog "You have to activate it manually by passing"
+ elog " '${EPREFIX}/usr/$(get_libdir)/mpv/mpris.so' "
+ elog "as a script option to mpv or symlinking the library to 'scripts' in your mpv"
+ elog "config directory."
+ elog "Alternatively, activate the autoload use flag."
+ elog
+ fi
+}