aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-12-07 12:49:37 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-12-07 12:49:37 +0100
commit1ae78248f78feb4fbdf8baf0d21c63c294d1def2 (patch)
tree4ea8f8a68d6194ec68f5e4992fcb46f25251d43e
parentdev-python/bracex: version bump (diff)
downloadguru-1ae78248.tar.gz
guru-1ae78248.tar.bz2
guru-1ae78248.zip
dev-python/pyspelling: version bump
Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--dev-python/pyspelling/Manifest2
-rw-r--r--dev-python/pyspelling/pyspelling-2.7.0.ebuild (renamed from dev-python/pyspelling/pyspelling-2.6.0.ebuild)22
2 files changed, 14 insertions, 10 deletions
diff --git a/dev-python/pyspelling/Manifest b/dev-python/pyspelling/Manifest
index b85191184..b85ac18e5 100644
--- a/dev-python/pyspelling/Manifest
+++ b/dev-python/pyspelling/Manifest
@@ -1 +1 @@
-DIST pyspelling-2.6.0.tar.gz 147740 BLAKE2B 277bd24f74fb670d44f027a9fce4fe0e4964318d8f3dccf796e3a6c09490f344fc2d2b9508a77c09aa6eecedf059b9e6bb27baa99bc0b938a8ad58c4fba14824 SHA512 41ca9265931b4c857c719cabbfbb79443a27d93b927941212ba1735eb2ab00643556bbc811fce26ca0b4d2d169d62c1d2ad2f86918daddd10c7636d8c664ca5e
+DIST pyspelling-2.7.0.tar.gz 149425 BLAKE2B f8e600a41ebd4ec290562307306e7fd5c67d384b9186de037b98d50d58016ded19c426caa892497ca44e309fb3db04292b890612afbe25a34f9f6b06985d3740 SHA512 2fcd225a66cb02fff10d5ca652e523a01bd0488a005dafa32ba1151fba9afe73809781501c957d6df00927baa9fb6779872973b32e2d3fe8a09306fdc4191995
diff --git a/dev-python/pyspelling/pyspelling-2.6.0.ebuild b/dev-python/pyspelling/pyspelling-2.7.0.ebuild
index dbc1eaa10..f350d6f38 100644
--- a/dev-python/pyspelling/pyspelling-2.6.0.ebuild
+++ b/dev-python/pyspelling/pyspelling-2.7.0.ebuild
@@ -9,8 +9,10 @@ DISTUTILS_USE_SETUPTOOLS=rdepend
DOCS_BUILDER="mkdocs"
DOCS_DEPEND="
- dev-python/mkdocs_pymdownx_material_extras
- ~dev-python/mkdocs-material-5.0.0_rc2"
+ ~dev-python/mkdocs_pymdownx_material_extras-1.1.3
+ dev-python/mkdocs-git-revision-date-localized-plugin
+ dev-python/mkdocs-minify-plugin
+"
inherit distutils-r1 docs
@@ -31,18 +33,20 @@ RDEPEND="
dev-python/markdown[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
>=dev-python/soupsieve-1.8[${PYTHON_USEDEP}]
- >=dev-python/wcmatch-4.0[${PYTHON_USEDEP}]
+ >=dev-python/wcmatch-6.0.3[${PYTHON_USEDEP}]
"
-PATCHES="${FILESDIR}/${P}-do-not-install-tests.patch"
-
distutils_enable_tests pytest
python_prepare_all() {
- # git revision data plugin needs git repo to build
- # do not depend on this
- sed -i -e '/git-revision-date-localized/d' \
- mkdocs.yml || die
+ # mkdocs-git-revision-date-localized-plugin needs git repo
+ if use doc; then
+ git init
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ git add .
+ git commit -m 'init'
+ fi
distutils-r1_python_prepare_all
}