aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTakuya Wakazono <pastalian46@gmail.com>2024-01-08 12:40:35 +0900
committerTakuya Wakazono <pastalian46@gmail.com>2024-01-08 12:40:35 +0900
commit1b195185cc8d151f877d583e3dc7ff40cadcead9 (patch)
treeaa54f59a7ba2cbf745ad096c7b9b24f6ab6f6599
parentdev-util/find-work: fix license (diff)
downloadguru-1b195185cc8d151f877d583e3dc7ff40cadcead9.tar.gz
guru-1b195185cc8d151f877d583e3dc7ff40cadcead9.tar.bz2
guru-1b195185cc8d151f877d583e3dc7ff40cadcead9.zip
app-emulation/looking-glass: keyword 1_beta6 for ~amd64
Signed-off-by: Takuya Wakazono <pastalian46@gmail.com>
-rw-r--r--app-emulation/looking-glass/Manifest1
-rw-r--r--app-emulation/looking-glass/looking-glass-1_beta6.ebuild64
2 files changed, 43 insertions, 22 deletions
diff --git a/app-emulation/looking-glass/Manifest b/app-emulation/looking-glass/Manifest
new file mode 100644
index 000000000..bab5816a5
--- /dev/null
+++ b/app-emulation/looking-glass/Manifest
@@ -0,0 +1 @@
+DIST looking-glass-1_beta6.tar.gz 2774858 BLAKE2B 351d7805447552d9945ae9a4e24cb853eda8f5bbff32d882355aa634ad67912881830dd36e5c48b1796b2f26f83f6db061004bfb6af4dfbc7704162190629efe SHA512 558981d6b32098076ef0775a748da349941551352cbef836e37310e43e5cd6072df3dec6fa2418a9abecc7729ef0c1c6869e3168d05a3d76bea46c6eb8c4e82c
diff --git a/app-emulation/looking-glass/looking-glass-1_beta6.ebuild b/app-emulation/looking-glass/looking-glass-1_beta6.ebuild
index 90b1c633e..8e9108ef0 100644
--- a/app-emulation/looking-glass/looking-glass-1_beta6.ebuild
+++ b/app-emulation/looking-glass/looking-glass-1_beta6.ebuild
@@ -1,21 +1,31 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake git-r3 desktop xdg-utils
+inherit cmake desktop xdg
+
+MY_PV="${PV/1_beta/B}"
-EGIT_REPO_URI="https://github.com/gnif/LookingGlass.git"
-EGIT_BRANCH="Release/B6"
DESCRIPTION="A low latency KVM FrameRelay implementation for guests with VGA PCI Passthrough"
HOMEPAGE="https://looking-glass.io https://github.com/gnif/LookingGlass"
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gnif/LookingGlass.git"
+else
+ SRC_URI="https://looking-glass.io/artifact/${MY_PV}/source -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+ KEYWORDS="~amd64"
+fi
+
LICENSE="GPL-2"
SLOT="0"
IUSE="binutils gnome pipewire pulseaudio wayland X"
-REQUIRED_USE="|| ( binutils gnome pipewire pulseaudio wayland X ) pipewire? ( !pulseaudio ) pulseaudio? ( !pipewire ) "
+REQUIRED_USE="|| ( wayland X )"
-RDEPEND="dev-libs/libconfig
+RDEPEND="
+ dev-libs/libconfig
dev-libs/nettle
media-libs/freetype
media-libs/fontconfig
@@ -24,35 +34,44 @@ RDEPEND="dev-libs/libconfig
virtual/glu
media-libs/libsamplerate
binutils? ( sys-devel/binutils )
- X? ( x11-libs/libX11 x11-libs/libXfixes x11-libs/libXi x11-libs/libXScrnSaver x11-libs/libXpresent )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXScrnSaver
+ x11-libs/libXpresent
+ )
wayland? ( dev-libs/wayland )
media-libs/libpulse
pipewire? ( media-video/pipewire )
gnome? ( gui-libs/libdecor )
"
-DEPEND="${RDEPEND}
+DEPEND="
+ ${RDEPEND}
app-emulation/spice-protocol
wayland? ( dev-libs/wayland-protocols )
"
-BDEPEND="virtual/pkgconfig"
+BDEPEND="
+ virtual/pkgconfig
+ wayland? ( dev-util/wayland-scanner )
+"
CMAKE_USE_DIR="${S}"/client
-src_prepare () {
- default
-
+src_configure () {
# Base on build.rst from the project
# doc/build.rst
- MYCMAKEARGS=(
- -DENABLE_BACKTRACE=$(usex binutils) \
- -DENABLE_X11=$(usex X) -DENABLE_WAYLAND=$(usex wayland) \
- -DENABLE_PIPEWIRE=$(usex pipewire) \
- -DENABLE_PULSEAUDIO=$(usex pulseaudio) \
+ local mycmakeargs=(
+ -DENABLE_BACKTRACE=$(usex binutils)
+ -DENABLE_X11=$(usex X)
+ -DENABLE_WAYLAND=$(usex wayland)
+ -DENABLE_PIPEWIRE=$(usex pipewire)
+ -DENABLE_PULSEAUDIO=$(usex pulseaudio)
-DENABLE_LIBDECOR=$(usex gnome)
)
-
- cmake_src_prepare
+ cmake_src_configure
}
src_install() {
@@ -71,12 +90,13 @@ src_install() {
}
pkg_postinst() {
- xdg_icon_cache_update
+ xdg_pkg_postinst
+
if use X && ! use wayland || ! use X && use wayland; then
- ewarn "The desktop file located located at /usr/share/applications/LookingGlass.desktop"
+ ewarn "The desktop file located at /usr/share/applications/LookingGlass.desktop"
fi
if use X && use wayland; then
- ewarn "The desktop files located located at /usr/share/applications/LookingGlass-X.desktop /usr/share/applications/LookingGlass-Wayland.desktop"
+ ewarn "The desktop files located at /usr/share/applications/LookingGlass-X.desktop /usr/share/applications/LookingGlass-Wayland.desktop"
fi
ewarn "Use the Right Control (Control_R) as the modifier key to control the action in LookingGlass"
ewarn "Note: Key was change because my laptop dosent have ScrLk"