aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-05-30 23:55:39 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-05-31 00:25:54 +0500
commit1b1c481893ac0141dcf08f8a69229fb3eed45d68 (patch)
treedd7a0da1c3fa3d05964f800d234f60448329af29
parentnet-mail/remail: enable py3.10 (diff)
downloadguru-1b1c4818.tar.gz
guru-1b1c4818.tar.bz2
guru-1b1c4818.zip
dev-util/reuse: add 1.0.0
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
-rw-r--r--dev-util/reuse/Manifest1
-rw-r--r--dev-util/reuse/reuse-1.0.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/reuse/Manifest b/dev-util/reuse/Manifest
index 33925e9887..92f7ca9dcf 100644
--- a/dev-util/reuse/Manifest
+++ b/dev-util/reuse/Manifest
@@ -1 +1,2 @@
DIST reuse-0.14.0.tar.gz 200682 BLAKE2B 6645cc6fc643ef3c19008d20dad065c1f362bda4106e731cfd780552b4cae1ced769ac49ee58c0ca519058f6764d4fd10ca6a33a70050365ae3f074e3981d276 SHA512 d376030e0be75f7cd70846c74409fba5f8266827cb1cc944c2fbda413002a3279f2efaf4598be4372df4a6d50f29a5038366c9ef709867dac7a0815efe071117
+DIST reuse-1.0.0.tar.gz 253938 BLAKE2B 72eabecfb866b3a2b1828b307fc0620bb9b362223b23408accde250f625a1d15794c3678fe8d24c7cd9dbf667b2ae453d4215e98be15075a0e6542b72607d970 SHA512 5d0b0fc57a983f544cbc40aaca813dce540712f9bfb7ef3065abb2fbd7a30f65216f50dbf2369e36198794cd944285498c5a2a7c4affcacefb12a01b6c7d7571
diff --git a/dev-util/reuse/reuse-1.0.0.ebuild b/dev-util/reuse/reuse-1.0.0.ebuild
new file mode 100644
index 0000000000..91dfcab6eb
--- /dev/null
+++ b/dev-util/reuse/reuse-1.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..10} )
+DISTUTILS_USE_PEP517=poetry
+inherit distutils-r1
+
+DESCRIPTION="A tool for compliance with the REUSE recommendations"
+HOMEPAGE="
+ https://reuse.software/
+ https://pypi.org/project/reuse/
+ https://github.com/fsfe/reuse-tool
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0 CC0-1.0 CC-BY-SA-4.0 GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/boolean-py[${PYTHON_USEDEP}]
+ dev-python/binaryornot[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/license-expression[${PYTHON_USEDEP}]
+ dev-python/python-debian[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+DOCS=( AUTHORS.rst CHANGELOG.md CODE_OF_CONDUCT.md CONTRIBUTING.md README.md )
+
+distutils_enable_tests pytest
+
+# [Errno 2] No such file or directory: '../README.md'
+#distutils_enable_sphinx docs \
+ #dev-python/recommonmark \
+ #dev-python/sphinx-autodoc-typehints \
+ #dev-python/sphinx_rtd_theme \
+ #dev-python/sphinxcontrib-apidoc