aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJian Lin <jlin.gentoo@outlook.com>2021-02-01 17:10:03 +0800
committerJian Lin <jlin.gentoo@outlook.com>2021-02-01 17:10:03 +0800
commit1c0df8f3b40ac72b2aadcde2edf3dbb1522ba2a7 (patch)
treeb74bf5bad660e7ed6c6449f1ddbd01133366876b
parentdev-python/bitbox02: cleanup old version (diff)
downloadguru-1c0df8f3.tar.gz
guru-1c0df8f3.tar.bz2
guru-1c0df8f3.zip
media-video/qliveplayer: bump to 3.21.1
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Jian Lin <jlin.gentoo@outlook.com>
-rw-r--r--media-video/qliveplayer/Manifest1
-rw-r--r--media-video/qliveplayer/qliveplayer-3.21.1.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/media-video/qliveplayer/Manifest b/media-video/qliveplayer/Manifest
index fd0ee97a5..aaa546508 100644
--- a/media-video/qliveplayer/Manifest
+++ b/media-video/qliveplayer/Manifest
@@ -1,2 +1,3 @@
DIST QLivePlayer-3.20.2.tar.gz 638142 BLAKE2B f9b7f6f69a4d751b57441e61b670a909408317801463415c8b0c311766bdbf16913c811e11c7a31096a6609b2e5e6f8ae64688d03d04dd1ebab97ebdf1644e08 SHA512 9ea868c59ff15ee6efa4a9c02578fee628c0f2985203d2696496512f9e1fd05b5d1642d4812711ef3be3843077b6f655288f07d48da7ceb80add20e7442cbf5b
DIST QLivePlayer-3.21.0.tar.gz 639005 BLAKE2B 254257cbab62b2578be5a2980c95b982b2da9223756a1efaf3098df1a313d4a252aac70bc032bc13f4e6e330e67d3525a6615d61cec494eab3d666b0ccfc3208 SHA512 755d975b37488979c257ecb8473a3702ee20859d1e1c10c42a7077b84e6b9a890dfb5af442c7a4a30c73bf2a088671ec14c1a4a95c849a724cabf88e6a407ec3
+DIST QLivePlayer-3.21.1.tar.gz 639098 BLAKE2B 956edafc652d5124ea14357a8015450c6678d1fa46b9701b5e65e23ca824bcc4e2b2598ff9c5441210afaa32c21c21affb432b323b452053fa5a548816765c56 SHA512 8aca7a62ff4839ff0640b3d982fa6f498996add39d6ed7e4904db2530347c35a56c524cb3c75c85d3de7c635142ff1dc8e3ac69644eef19f4aa55d77a21dd2f1
diff --git a/media-video/qliveplayer/qliveplayer-3.21.1.ebuild b/media-video/qliveplayer/qliveplayer-3.21.1.ebuild
new file mode 100644
index 000000000..6a725132d
--- /dev/null
+++ b/media-video/qliveplayer/qliveplayer-3.21.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit xdg cmake optfeature python-single-r1
+
+MY_P="QLivePlayer-${PV}"
+
+DESCRIPTION="A cute and useful Live Stream Player with danmaku support"
+HOMEPAGE="https://github.com/IsoaSFlus/QLivePlayer"
+SRC_URI="https://github.com/IsoaSFlus/QLivePlayer/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="
+ ${PYTHON_DEPS}
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtgraphicaleffects-5.15:5
+ >=dev-qt/qtquickcontrols-5.15:5
+ >=dev-qt/qtquickcontrols2-5.15:5
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ ')
+ media-video/ffmpeg
+ media-video/mpv
+ net-misc/curl
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ kde-frameworks/extra-cmake-modules:5
+"
+
+src_prepare()
+{
+ cmake_src_prepare
+ # fix python version
+ sed -i "s/python3/${EPYTHON}/" src/qlphelper/bilivideo.cpp \
+ || die "Sed failed to set python version!"
+ sed -i "s/python3/${EPYTHON}/" src/qlphelper/danmakulauncher.cpp \
+ || die "Sed failed to set python version!"
+ sed -i "s/python3/${EPYTHON}/" src/qlphelper/streamfinder.cpp \
+ || die "Sed failed to set python version!"
+}
+
+pkg_postinst()
+{
+ xdg_pkg_postinst
+ optfeature "twitch support" "net-misc/streamlink"
+ optfeature "youtube support" "net-misc/streamlink dev-python/protobuf-python"
+}