aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac.paragon@gmail.com>2022-01-27 15:41:10 +0200
committerViorel Munteanu <ceamac.paragon@gmail.com>2022-01-27 15:42:25 +0200
commit1c2ca44d53ae9e56fb49284842b975ff4d089e4f (patch)
tree16c4124e0daee0aeec38bdd94f1ec1e3bf87dde6
parentmedia-sound/spotify_dl: drop 7.6.0-r1 (diff)
downloadguru-1c2ca44d.tar.gz
guru-1c2ca44d.tar.bz2
guru-1c2ca44d.zip
dev-python/stone: add 3.3.1
Signed-off-by: Viorel Munteanu <ceamac.paragon@gmail.com>
-rw-r--r--dev-python/stone/Manifest1
-rw-r--r--dev-python/stone/stone-3.3.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/stone/Manifest b/dev-python/stone/Manifest
index 34da4bbdb..e2d3ffe41 100644
--- a/dev-python/stone/Manifest
+++ b/dev-python/stone/Manifest
@@ -1 +1,2 @@
DIST stone-3.2.1.tar.gz 280856 BLAKE2B 496d235c9afa4723d2e705425c243ffcae1550cf1b9cb1950a72401b61b064fa0922e0a3fa4c3ff0bdbcb483872054024b1ceb8ea4d8ff320309d2d7f05b4f81 SHA512 446ad0aefd839795b66d65e18c54d79e91f3927558167631f26a35d749ccb433c587e33a15c1dca4dbfe4320c062fc4e09d5cd3c5d4a60465b208ed553649b74
+DIST stone-3.3.1.tar.gz 282831 BLAKE2B b9a866e43feedea28cd33b89f78100be520a2756fa78888e9a786ae27942a5c19df51010c0af952de70c782d3fc3588de1ae0f58450d807053989bb91d285f15 SHA512 ee07f01b6f10e771afbe6ca6f07d7efa24a5460e5c163f339ae84a8b7742a659f5cb535e674a2f315d1bfa95b7c02e56f46db1f397188b5b6705f6c00c1e9d73
diff --git a/dev-python/stone/stone-3.3.1.ebuild b/dev-python/stone/stone-3.3.1.ebuild
new file mode 100644
index 000000000..a02a6f116
--- /dev/null
+++ b/dev-python/stone/stone-3.3.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="The Official Api Spec Language for Dropbox"
+HOMEPAGE="
+ https://www.dropbox.com/developers
+ https://github.com/dropbox/stone
+ https://pypi.org/project/stone
+"
+SRC_URI="https://github.com/dropbox/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/ply-3.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Don't run tests via setup.py pytest
+ sed -i -e "/'pytest-runner .*',/d" setup.py || die
+
+ distutils-r1_python_prepare_all
+}