aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuciano Degni <degni.public@gmail.com>2022-01-07 20:50:40 +0100
committerLuciano Degni <degni.public@gmail.com>2022-01-07 20:50:40 +0100
commit1ea240c7217fa0d1fb3d63e082e9620ba0a533f5 (patch)
tree57b3b937aa3e735c1cfdf18e7e2bdc3e00922675
parentapp-editors/helix: modified installation method and removed useless line (diff)
downloadguru-1ea240c7.tar.gz
guru-1ea240c7.tar.bz2
guru-1ea240c7.zip
x11-wm/leftwm: add use and change deps format
Signed-off-by: Luciano Degni <degni.public@gmail.com>
-rw-r--r--x11-wm/leftwm/leftwm-0.2.9.ebuild24
1 files changed, 19 insertions, 5 deletions
diff --git a/x11-wm/leftwm/leftwm-0.2.9.ebuild b/x11-wm/leftwm/leftwm-0.2.9.ebuild
index bb1ada236..102e7ac96 100644
--- a/x11-wm/leftwm/leftwm-0.2.9.ebuild
+++ b/x11-wm/leftwm/leftwm-0.2.9.ebuild
@@ -160,13 +160,26 @@ SLOT="0"
KEYWORDS="~amd64"
IUSE="systemd"
+IUSE="systemd xinerama doc"
+
DEPEND="
- x11-libs/libXinerama:0=
- x11-apps/xrandr:0=
- x11-base/xorg-server:0=
+ x11-base/xorg-server[xorg,udev]
+ x11-apps/xrandr
+ xinerama? (
+ x11-libs/libXinerama
+ )
>=dev-lang/rust-1.52.0
+ systemd? (
+ sys-apps/systemd
+ )
+"
+BDEPEND="
+ $DEPEND
+"
+RDEPEND="
+ $DEPEND
+ !x11-wm/$PN-bin
"
-RDEPEND="${DEPEND}"
QA_FLAGS_IGNORED="usr/bin/.*"
@@ -177,7 +190,7 @@ src_compile() {
}
src_install() {
- dodoc README.md CHANGELOG
+ use doc && dodoc README.md CHANGELOG
make_desktop_entry leftwm.desktop /usr/share/xsessions/
cd target/release || die
dobin leftwm{,-worker,-state,-check,-command}
@@ -185,6 +198,7 @@ src_install() {
pkg_postinst() {
xdg_desktop_database_update
+ elog "Emerge 'x11-misc/leftwm-theme' to manage themes for $PN"
}
pkg_postrm() {