aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Pimentel <adam.pimentel@protonmail.com>2022-12-28 18:19:31 -0500
committerAdam Pimentel <adam.pimentel@protonmail.com>2022-12-28 18:19:31 -0500
commit1f6f6544b20f3350651f7d8c2e6141de9859a919 (patch)
treed8840076bdc77dddcae93c86918d798bed3350c3
parentnet-misc/FORT-validator: Don’t debug by default (diff)
downloadguru-1f6f6544.tar.gz
guru-1f6f6544.tar.bz2
guru-1f6f6544.zip
net-p2p/feather: add additional "die" to pushd/popd
Signed-off-by: Adam Pimentel <adam.pimentel@protonmail.com>
-rw-r--r--net-p2p/feather/feather-2.1.2.ebuild4
-rw-r--r--net-p2p/p2pool/p2pool-2.6-r1.ebuild1
2 files changed, 2 insertions, 3 deletions
diff --git a/net-p2p/feather/feather-2.1.2.ebuild b/net-p2p/feather/feather-2.1.2.ebuild
index 697aca1eb..1678afc9e 100644
--- a/net-p2p/feather/feather-2.1.2.ebuild
+++ b/net-p2p/feather/feather-2.1.2.ebuild
@@ -98,9 +98,9 @@ src_prepare() {
default
echo "#define FEATHER_VERSION \"${PV}\"" > "${WORKDIR}"/${PF}/src/config-feather.h || die
echo "#define TOR_VERSION \"NOT_EMBEDDED\"" >> "${WORKDIR}"/${PF}/src/config-feather.h || die
- pushd monero
+ pushd monero || die
eapply "${FILESDIR}"/monero_add_some_includes.patch
- popd
+ popd || die
cmake_src_prepare
}
diff --git a/net-p2p/p2pool/p2pool-2.6-r1.ebuild b/net-p2p/p2pool/p2pool-2.6-r1.ebuild
index 960bce71a..4d2e93547 100644
--- a/net-p2p/p2pool/p2pool-2.6-r1.ebuild
+++ b/net-p2p/p2pool/p2pool-2.6-r1.ebuild
@@ -71,7 +71,6 @@ src_prepare() {
# Stop their script from overriding flags:
cp "${FILESDIR}"/flags.cmake cmake/flags.cmake || die
- die
cmake_src_prepare
}