aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2022-11-01 14:08:41 +0100
committerOliver Freyermuth <o.freyermuth@googlemail.com>2022-11-01 14:08:41 +0100
commit20344e32c931b46f9b66ebc2f7479b96b95704c8 (patch)
treeb6cc8593a07408eedb646696ab6116ff59ac1b66
parentdev-cpp/scitokens-cpp: add 0.7.2 (diff)
downloadguru-20344e32.tar.gz
guru-20344e32.tar.bz2
guru-20344e32.zip
dev-cpp/scitokens-cpp: drop 0.7.0
Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com>
-rw-r--r--dev-cpp/scitokens-cpp/Manifest1
-rw-r--r--dev-cpp/scitokens-cpp/files/scitokens-cpp-0.7.0-install-when-testing.patch21
-rw-r--r--dev-cpp/scitokens-cpp/scitokens-cpp-0.7.0.ebuild55
3 files changed, 0 insertions, 77 deletions
diff --git a/dev-cpp/scitokens-cpp/Manifest b/dev-cpp/scitokens-cpp/Manifest
index 32bf633fd..56804bd76 100644
--- a/dev-cpp/scitokens-cpp/Manifest
+++ b/dev-cpp/scitokens-cpp/Manifest
@@ -1,3 +1,2 @@
-DIST scitokens-cpp-0.7.0.tar.gz 98971 BLAKE2B 3429ff89b5a5202f9892fc68fc558c8b64276977a396981af845f05f8eb3f638602cedd30ea97f3ab5e6d188de7249247854dd6281aeb138d6e304b5aa006bb9 SHA512 1be8a84b7d88c10ab7336c3c6bc8d7e7be5feb3253ef618cba1f3ed908aad3fc480f30dd2a292aa2774ec88ceba370af3fa7d96f228cba3df8f78b6face6991b
DIST scitokens-cpp-0.7.1.tar.gz 99411 BLAKE2B b89c63ad35105a064e6f8ecd7596ba51de43096828a756b7c64669a352784c56bcb9295638f173cdbeac833e9dfc14828daf775d60a6cd124abf639125cf5842 SHA512 5c73fcccfb2db92916caced118e2ab4e110f7a8331a9bd84d06bd059da5258d7e8423822356e1833bbce7b047d7f31e2cd20cf4c0eb064dc2d248d9febab35b5
DIST scitokens-cpp-0.7.2.tar.gz 99557 BLAKE2B 93b5a4e331004b8bcec9b9ad931d5de2bb5ecd69dc75b4100261110aa0488f4b4616e085235dc8703f492bb80cce2d7a8e90824c32f11d9db6dec65e2be87d1f SHA512 40e4bd8b14e040f748e8b7c00a32f26028b502d293c8d4ed77f20294fe7356a991d9d0a449731cde28a90556aeefd42e4ca63ec882b94697abeef2483544451c
diff --git a/dev-cpp/scitokens-cpp/files/scitokens-cpp-0.7.0-install-when-testing.patch b/dev-cpp/scitokens-cpp/files/scitokens-cpp-0.7.0-install-when-testing.patch
deleted file mode 100644
index c2b500810..000000000
--- a/dev-cpp/scitokens-cpp/files/scitokens-cpp-0.7.0-install-when-testing.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Bug: https://github.com/scitokens/scitokens-cpp/issues/82
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index ec5c878..611afb1 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -81,13 +81,12 @@ endif()
- enable_testing()
- add_subdirectory(test)
-
--else()
-+endif()
- get_directory_property(TARGETS BUILDSYSTEM_TARGETS)
- install(
- TARGETS ${TARGETS}
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
- RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR} )
--endif()
-
- install(
- FILES src/scitokens.h
diff --git a/dev-cpp/scitokens-cpp/scitokens-cpp-0.7.0.ebuild b/dev-cpp/scitokens-cpp/scitokens-cpp-0.7.0.ebuild
deleted file mode 100644
index 59eac5e9b..000000000
--- a/dev-cpp/scitokens-cpp/scitokens-cpp-0.7.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/scitokens/scitokens-cpp"
-else
- SRC_URI="https://github.com/scitokens/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-DESCRIPTION=" A C++ implementation of the SciTokens library with a C library interface"
-HOMEPAGE="https://scitokens.org/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-
-DEPEND="${RDEPEND}
- <dev-cpp/jwt-cpp-0.5.0
- dev-db/sqlite
- dev-libs/openssl
- net-misc/curl
- sys-apps/util-linux
- test? ( dev-cpp/gtest )"
-BDEPEND="virtual/pkgconfig"
-RESTRICT="!test? ( test )"
-
-PATCHES=(
- "${FILESDIR}"/"${PN}"-0.7.0-install-when-testing.patch
-)
-
-src_prepare() {
- # Unbundle dev-cpp/gtest, dev-cpp/jwt-cpp
- rm -rvf vendor
- # Fix include path for picojson.
- find src/ \( -name '*.cpp' -o -name '*.h' \) -type f -print0 | xargs -0 sed -r -e "s:picojson/picojson\.h:picojson.h:g" -i || die
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_UNITTESTS="$(usex test)"
- -DEXTERNAL_GTEST=YES
- )
- cmake_src_configure
-}
-
-src_test() {
- cmake_run_in "${BUILD_DIR}" ctest --verbose || die
-}