aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2022-10-30 01:17:01 +0300
committerSergey Torokhov <torokhov-s-a@yandex.ru>2022-10-30 01:17:01 +0300
commit20bd1b614f7adad2ebd07754514b524588dedc92 (patch)
tree61ca1e2485f134f82de5cf8833782679a58d6070
parentx11-libs/gtk-fortran: drop 3.24.18; fix 'https' in metadata.xml (diff)
downloadguru-20bd1b61.tar.gz
guru-20bd1b61.tar.bz2
guru-20bd1b61.zip
x11-lib/gtk-fortran: fix test fail due to DISPLAY absence
The issue bellow isn't related to 'lto' and was to absence of virtual DISPLAY while running test. Closes: https://bugs.gentoo.org/863935 Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
-rw-r--r--x11-libs/gtk-fortran/gtk-fortran-3.24.30-r1.ebuild (renamed from x11-libs/gtk-fortran/gtk-fortran-3.24.30.ebuild)14
-rw-r--r--x11-libs/gtk-fortran/gtk-fortran-4.1.0-r1.ebuild (renamed from x11-libs/gtk-fortran/gtk-fortran-4.1.0.ebuild)14
2 files changed, 20 insertions, 8 deletions
diff --git a/x11-libs/gtk-fortran/gtk-fortran-3.24.30.ebuild b/x11-libs/gtk-fortran/gtk-fortran-3.24.30-r1.ebuild
index f3ead5547..e8bf7a4aa 100644
--- a/x11-libs/gtk-fortran/gtk-fortran-3.24.30.ebuild
+++ b/x11-libs/gtk-fortran/gtk-fortran-3.24.30-r1.ebuild
@@ -1,12 +1,13 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
CMAKE_MAKEFILE_GENERATOR="emake"
FORTRAN_STANDARD=2003
+VIRTUALX_REQUIRED="test"
-inherit cmake fortran-2
+inherit cmake fortran-2 virtualx
DESCRIPTION="A GTK+ binding to build Graphical User Interfaces in Fortran"
HOMEPAGE="https://github.com/vmagnin/gtk-fortran"
@@ -16,8 +17,9 @@ LICENSE="GPL-3"
SLOT="3"
KEYWORDS="~amd64 ~x86"
-IUSE="examples high-level plplot static-libs"
+IUSE="examples high-level plplot static-libs test"
REQUIRED_USE="plplot? ( high-level )"
+RESTRICT="!test? ( test )"
RDEPEND="
x11-libs/gtk+:3
@@ -55,6 +57,10 @@ src_configure() {
cmake_src_configure
}
+src_test() {
+ virtx cmake_src_test
+}
+
src_install() {
cmake_src_install
diff --git a/x11-libs/gtk-fortran/gtk-fortran-4.1.0.ebuild b/x11-libs/gtk-fortran/gtk-fortran-4.1.0-r1.ebuild
index 3de8bf832..1e6bf531f 100644
--- a/x11-libs/gtk-fortran/gtk-fortran-4.1.0.ebuild
+++ b/x11-libs/gtk-fortran/gtk-fortran-4.1.0-r1.ebuild
@@ -1,12 +1,13 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
CMAKE_MAKEFILE_GENERATOR="emake"
FORTRAN_STANDARD=2003
+VIRTUALX_REQUIRED="test"
-inherit cmake fortran-2
+inherit cmake fortran-2 virtualx
DESCRIPTION="A GTK+ binding to build Graphical User Interfaces in Fortran"
HOMEPAGE="https://github.com/vmagnin/gtk-fortran"
@@ -16,8 +17,9 @@ LICENSE="GPL-3"
SLOT="4"
KEYWORDS="~amd64 ~x86"
-IUSE="examples high-level plplot static-libs"
+IUSE="examples high-level plplot static-libs test"
REQUIRED_USE="plplot? ( high-level )"
+RESTRICT="!test? ( test )"
RDEPEND="
gui-libs/gtk:4
@@ -55,6 +57,10 @@ src_configure() {
cmake_src_configure
}
+src_test() {
+ virtx cmake_src_test
+}
+
src_install() {
cmake_src_install