aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-03-28 17:41:06 +0100
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-03-28 17:41:37 +0100
commit20cd2d4c7650ce6ac883a512e3e15d3b631fbcaa (patch)
tree45e091a5e8502b871fc609d1cdca7a27f6625e84
parentdev-python/sphinx-autodoc-typehints: fix trailing whitespace (diff)
downloadguru-20cd2d4c.tar.gz
guru-20cd2d4c.tar.bz2
guru-20cd2d4c.zip
dev-python/glicko2: add version
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/glicko2/Manifest1
-rw-r--r--dev-python/glicko2/glicko2-2019.10.10.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/glicko2/Manifest b/dev-python/glicko2/Manifest
new file mode 100644
index 0000000000..9c9d826284
--- /dev/null
+++ b/dev-python/glicko2/Manifest
@@ -0,0 +1 @@
+DIST glicko2-2019.10.10.tar.gz 4684 BLAKE2B c21e3be87df4b3bff0b1ba6bece96587ad26807beab882c38829b782eb99f1e165013b403c6a690ec591daa1ea9d55bff876eb802af944ee25222e28e787146c SHA512 7665c3b81023a01ba2d835c3a0a4aedf5a6becff909f554a25c69537289f6ea75820d759035d540b297cd6414c6d465f79a7ef21a91f9f7e2cf394241811c89d
diff --git a/dev-python/glicko2/glicko2-2019.10.10.ebuild b/dev-python/glicko2/glicko2-2019.10.10.ebuild
new file mode 100644
index 0000000000..b9c531d005
--- /dev/null
+++ b/dev-python/glicko2/glicko2-2019.10.10.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{6,7} pypy3)
+
+inherit distutils-r1
+
+COMMIT="99285aa6b5250b91a837b842dc61b2a96007f3c5"
+
+DESCRIPTION="An implementation of the Glicko-2 rating system for Python"
+HOMEPAGE="https://github.com/sublee/glicko2"
+SRC_URI="https://github.com/sublee/glicko2/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+distutils_enable_tests setup.py
+
+src_prepare() {
+ sed -i -e "s/distribute/setuptools/g" setup.py
+ eapply_user
+}