aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2020-04-13 04:29:23 +0300
committerSergey Torokhov <torokhov-s-a@yandex.ru>2020-04-13 04:29:23 +0300
commit20d1209ac8b21eb5feeca206f0c78ffe0cac2f98 (patch)
tree96ade71a6b7c2a42c2d086e6b1a6d4860071a97c
parentremoved gtk-layer-shell as it is now in the main tree (diff)
downloadguru-20d1209a.tar.gz
guru-20d1209a.tar.bz2
guru-20d1209a.zip
x11-libs/gtk-fortran: Add DOCS with CHANGELOG.md. Remove "append-flags -no-pie"
Add "CAHNGELOG.md" to DOCS variable with explicit README* files. The using of "append-flags -no-pie" doesn't resove completely the issue with TEXTREL and prevent to use then package on hardened. The flag-o-matic.eclass removed as well. Fix quote the variables. Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
-rw-r--r--x11-libs/gtk-fortran/gtk-fortran-3.24.8.ebuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/x11-libs/gtk-fortran/gtk-fortran-3.24.8.ebuild b/x11-libs/gtk-fortran/gtk-fortran-3.24.8.ebuild
index 03e139169..174fb1c17 100644
--- a/x11-libs/gtk-fortran/gtk-fortran-3.24.8.ebuild
+++ b/x11-libs/gtk-fortran/gtk-fortran-3.24.8.ebuild
@@ -6,7 +6,7 @@ EAPI=7
CMAKE_MAKEFILE_GENERATOR="emake"
FORTRAN_STANDARD=2003
-inherit cmake flag-o-matic fortran-2
+inherit cmake fortran-2
DESCRIPTION="A GTK+ binding to build Graphical User Interfaces in Fortran"
HOMEPAGE="https://github.com/vmagnin/gtk-fortran"
@@ -35,6 +35,8 @@ BDEPEND="
virtual/pkgconfig
"
+DOCS=( "README.md" "README-high-level" "CHANGELOG.md" )
+
pkg_setup() {
fortran-2_pkg_setup
}
@@ -56,11 +58,6 @@ src_configure() {
-DINSTALL_EXAMPLES=$(usex examples)
-DNO_BUILD_EXAMPLES=true
)
- # Try to fix (fix similar warnings only for static library):
- # /usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: CMakeFiles/gtk-fortran_object.dir/gtk-hl-assistant.f90.o:
- # warning: relocation against `hl_gtk_assistant_destroy' in read-only section `.rodata'
- # /usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: warning: creating a DT_TEXTREL in object
- append-flags -no-pie
cmake_src_configure
}
@@ -71,5 +68,5 @@ src_compile() {
src_install() {
cmake_src_install
- use doc && dodoc -r ${BUILD_DIR}/html && rm ${D}/usr/share/doc/${P}/html/{*.map,*.md5}
+ use doc && dodoc -r "${BUILD_DIR}"/html && rm "${D}/usr/share/doc/${P}"/html/{*.map,*.md5}
}