aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-05-25 12:39:46 +0200
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-05-25 12:42:59 +0200
commit20db5ad751285ec579ad6c39343d9cce429197ff (patch)
tree5814accdd6b1427690216c06fcfca72b029338e1
parentdev-cpp/termcolor: New package. (diff)
downloadguru-20db5ad7.tar.gz
guru-20db5ad7.tar.bz2
guru-20db5ad7.zip
app-text/epubgrep: Version bump 0.2.0.
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
-rw-r--r--app-text/epubgrep/Manifest1
-rw-r--r--app-text/epubgrep/epubgrep-0.2.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-text/epubgrep/Manifest b/app-text/epubgrep/Manifest
index a6bef4a145..c8a012e969 100644
--- a/app-text/epubgrep/Manifest
+++ b/app-text/epubgrep/Manifest
@@ -1 +1,2 @@
DIST epubgrep-0.1.3.tar.gz 33668 BLAKE2B 717de938e4830dbf970b11e67dd361e619ab77c83bfe4e3cb94dc3654317099e7bafb8029ab7899e83c16eb0d25f6bd41ac28d72c28b8826c1d6cd25d24b401b SHA512 c321578607400e365143111324851497681cc0464e1ddc8362dbbc3b76096b379d080800efd11e217a643ced14b6032fd16b8f0e01922e248926ac2e3840d659
+DIST epubgrep-0.2.0.tar.gz 217269 BLAKE2B 4bf4065009ad4ee0f8963e692ad5c08d04950920b7f7a1ffab6ca8f24fadfc7f48486fe166799e1a984d683af962ef850cafab717eed9b068f1a0918a4faebbd SHA512 ab6d8433db63c7ab2e8c9ec334f573bb81f3d9390124f60d6619d52fe83d4df15abca240c55e74022abd17cf536fa00b31ac32f597a1370f99826bb8a6d5b904
diff --git a/app-text/epubgrep/epubgrep-0.2.0.ebuild b/app-text/epubgrep/epubgrep-0.2.0.ebuild
new file mode 100644
index 0000000000..46a105b76e
--- /dev/null
+++ b/app-text/epubgrep/epubgrep-0.2.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Search tool for EPUB ebooks"
+HOMEPAGE="https://schlomp.space/tastytea/epubgrep"
+SRC_URI="https://schlomp.space/tastytea/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/boost[nls]
+ app-arch/libarchive[bzip2,iconv,lzma,zlib]
+ dev-libs/libfmt
+"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/termcolor
+ test? ( dev-cpp/catch )
+"
+BDEPEND="
+ sys-devel/gettext
+ app-text/asciidoc
+"
+
+src_configure() {
+ local mycmakeargs=(
+ "-DWITH_TESTS=$(usex test)"
+ "-DFALLBACK_BUNDLED=NO"
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ BUILD_DIR="${BUILD_DIR}/tests" cmake_src_test
+}