aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortastytea <gentoo@tastytea.de>2023-09-09 16:00:20 +0200
committertastytea <gentoo@tastytea.de>2023-09-09 17:14:43 +0200
commit21a297ba2f6de53bf7200f3dbe415051c9dfd908 (patch)
tree952d946a4e722c8659be7a2c481c919752fa727b
parentdev-ruby/asciidoctor-pdf: enable ruby32 (diff)
downloadguru-21a297ba2f6de53bf7200f3dbe415051c9dfd908.tar.gz
guru-21a297ba2f6de53bf7200f3dbe415051c9dfd908.tar.bz2
guru-21a297ba2f6de53bf7200f3dbe415051c9dfd908.zip
app-shells/zsh-history-substring-search: add 1.1.0
Signed-off-by: tastytea <gentoo@tastytea.de>
-rw-r--r--app-shells/zsh-history-substring-search/Manifest1
-rw-r--r--app-shells/zsh-history-substring-search/zsh-history-substring-search-1.1.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-shells/zsh-history-substring-search/Manifest b/app-shells/zsh-history-substring-search/Manifest
index 73017df55d..69d7baf5ee 100644
--- a/app-shells/zsh-history-substring-search/Manifest
+++ b/app-shells/zsh-history-substring-search/Manifest
@@ -1 +1,2 @@
DIST zsh-history-substring-search-1.0.2.tar.gz 9074 BLAKE2B 26c6a080f82586eef9b33bfbe1da89951a6bb9d8e7362dca83d90b9d491e3cd497fb3b4be2ab1a94082351711b941bd7942cd554e7e4d93a69d4168ef13f80ee SHA512 9547cdd74f6bd5b102ca29b7b455cd4ce7450fe86864b5a149365de4c37d3da887edb403b195e80c142fe61861a3e4c063a5d8ba08ec0532b27a1207c80a023d
+DIST zsh-history-substring-search-1.1.0.tar.gz 9984 BLAKE2B c757f55be326c4aecdc05471940d66f70be596ca483f8c380bd0bc8e05920b70069200d5d865ee025d37cf079c0865d30eebc6952f9d7eaf4b7db71518e71a69 SHA512 267efc0960f6403b748e78734b43b8d997f05a2a2542520508e6ef028ef2e0a2c0805d24ae5ad4c30454742a08a7abf2e3baa591e60a660a0ca54aca0ad7175a
diff --git a/app-shells/zsh-history-substring-search/zsh-history-substring-search-1.1.0.ebuild b/app-shells/zsh-history-substring-search/zsh-history-substring-search-1.1.0.ebuild
new file mode 100644
index 0000000000..6222970da6
--- /dev/null
+++ b/app-shells/zsh-history-substring-search/zsh-history-substring-search-1.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="ZSH port of Fish history search (up arrow)"
+HOMEPAGE="https://github.com/zsh-users/zsh-history-substring-search"
+SRC_URI="https://github.com/zsh-users/zsh-history-substring-search/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+
+RDEPEND="app-shells/zsh"
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
+. /usr/share/zsh/site-functions/async.zsh
+at the end of your ~/.zshrc"
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins ${PN}.zsh
+
+ readme.gentoo_create_doc
+ einstalldocs
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}