aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuciano Degni <degni.public@gmail.com>2022-02-25 14:23:44 +0100
committerLuciano Degni <degni.public@gmail.com>2022-02-25 14:23:44 +0100
commit225469f21efc1dcad16d0b1bf48e78f7116cbc11 (patch)
tree9222f26a66eb119b4c046df6f4f4fdc91861e420
parentapp-misc/zellij: minor fixes to ebuild -> REQUIRED USE FLAGS and white space (diff)
downloadguru-225469f2.tar.gz
guru-225469f2.tar.bz2
guru-225469f2.zip
app-misc/xplr: add 0.17.2
Signed-off-by: Luciano Degni <degni.public@gmail.com>
-rw-r--r--app-misc/xplr/Manifest1
-rw-r--r--app-misc/xplr/xplr-0.17.2.ebuild189
2 files changed, 190 insertions, 0 deletions
diff --git a/app-misc/xplr/Manifest b/app-misc/xplr/Manifest
index 1be64ad09..73ff6f4c2 100644
--- a/app-misc/xplr/Manifest
+++ b/app-misc/xplr/Manifest
@@ -146,4 +146,5 @@ DIST winapi-x86_64-pc-windows-gnu-0.4.0.crate 2947998 BLAKE2B 2ad1ea8b5fa07d544e
DIST xplr-0.15.2.tar.gz 221475 BLAKE2B 05594d2f38d937d204fcbadbe3ba63c72dbf5957e014f944f1fdb0f60bab9730ee5196f1162ba42c1f2daaa2d36dc35e595515d1c0c6188f6ef3e9f535157422 SHA512 502ceb0661ac3cdde337d76a5eef5089902b2ad906cde0465b63a89141a554ddb56ef4a4747e7064eda48e58d4037e36e36dfe709d6a67da986b1f953033fc3c
DIST xplr-0.17.0.tar.gz 228181 BLAKE2B b1094007de1997b7c6e76afe7b457289bd358b2f24dc855bcc62ce7ad7bb09c0870fc7190781d68287e2871f615cbde18b50b1d6340e59a36065743875f05ce8 SHA512 fbf278097e2b5fb6e0a0d946cc234d6cc4b33989e3c24304ca3413a83ae56b245b8c37285fb8b9a77e41a5b97f472cc2139fe2768f3b025d75d4764bfa7429cd
DIST xplr-0.17.1.tar.gz 228698 BLAKE2B 13f6cd556b038267c6d64ff3f513c0d2daa28566267fa048f243b86ef6f1b7c0a72521e1916c30faf80099e40cd269050f185e6baf19658a3a5321a25e087de1 SHA512 fee46a68b2891c52e553ec35fe746fd95bcbaf45e21109a3395b1f43f656a5fbfe76352c6dcf3ae0473df7b3eed89aabba83294698113d478f5a21b48d87fd35
+DIST xplr-0.17.2.tar.gz 229009 BLAKE2B d2897003be656e17c48bfeab522fde7ed3446dde63ca4fc83740dc6f42e932039e57ec38ea6c870c157d805d8f3dd8b55f2e8aebc492634f0f55ef0caafb0120 SHA512 e222875e60b3fd25a4d42fd719b05db58f751f91c5f672f7ab0e1e2fd3760e9a8d1477278dcc41388193c5e01bfdf48d7f2253ca7c694ac43f0829fe7009f522
DIST yaml-rust-0.4.5.crate 47783 BLAKE2B 3e888c5cc7afb43eaf3aaab2b6f47b86df164a66eb54d4e166b965cc84b1e06cd17bd992a0d6ee175d9a73a76e2b44a13167246383ed054afcf3cc1710b309cb SHA512 7621dc8dfd5e7d4a7a8805b2a7e8319b63b852367655f2359d4e3e8fec6c4fad52d75c46ce1161e4c674eac0780b757ce9d34e664e304d8d2beec7afa0363ea0
diff --git a/app-misc/xplr/xplr-0.17.2.ebuild b/app-misc/xplr/xplr-0.17.2.ebuild
new file mode 100644
index 000000000..e4ede6418
--- /dev/null
+++ b/app-misc/xplr/xplr-0.17.2.ebuild
@@ -0,0 +1,189 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( luajit )
+
+CRATES="
+ ansi-to-tui-0.4.1
+ anyhow-1.0.52
+ assert_cmd-2.0.2
+ atty-0.2.14
+ autocfg-1.0.1
+ bitflags-1.3.2
+ bstr-0.2.17
+ bumpalo-3.9.1
+ cassowary-0.3.0
+ cast-0.2.7
+ cc-1.0.72
+ cfg-if-1.0.0
+ chrono-0.4.19
+ clap-2.34.0
+ criterion-0.3.5
+ criterion-plot-0.4.4
+ crossbeam-channel-0.5.2
+ crossbeam-deque-0.8.1
+ crossbeam-epoch-0.9.6
+ crossbeam-utils-0.8.6
+ crossterm-0.20.0
+ crossterm-0.22.1
+ crossterm_winapi-0.8.0
+ crossterm_winapi-0.9.0
+ csv-1.1.6
+ csv-core-0.1.10
+ difflib-0.4.0
+ dirs-4.0.0
+ dirs-sys-0.3.6
+ doc-comment-0.3.3
+ either-1.6.1
+ erased-serde-0.3.17
+ getrandom-0.2.3
+ half-1.8.2
+ hashbrown-0.11.2
+ hermit-abi-0.1.19
+ humansize-1.1.1
+ indexmap-1.8.0
+ instant-0.1.12
+ itertools-0.10.3
+ itoa-0.4.8
+ itoa-1.0.1
+ js-sys-0.3.55
+ lazy_static-1.4.0
+ libc-0.2.112
+ linked-hash-map-0.5.4
+ lock_api-0.4.5
+ log-0.4.14
+ lua-src-543.1.0
+ luajit-src-210.3.2+resty1085a4d
+ memchr-2.4.1
+ memoffset-0.6.5
+ mime-0.3.16
+ mime_guess-2.0.3
+ mio-0.7.14
+ miow-0.3.7
+ mlua-0.7.0
+ mlua-0.7.1
+ natord-1.0.9
+ ntapi-0.3.6
+ num-integer-0.1.44
+ num-traits-0.2.14
+ num_cpus-1.13.1
+ once_cell-1.9.0
+ oorandom-11.1.3
+ parking_lot-0.11.2
+ parking_lot_core-0.8.5
+ pkg-config-0.3.24
+ plotters-0.3.1
+ plotters-backend-0.3.2
+ plotters-svg-0.3.1
+ predicates-2.1.0
+ predicates-core-1.0.2
+ predicates-tree-1.0.4
+ proc-macro2-1.0.36
+ quote-1.0.14
+ rayon-1.5.1
+ rayon-core-1.9.1
+ redox_syscall-0.2.10
+ redox_users-0.4.0
+ regex-1.5.4
+ regex-automata-0.1.10
+ regex-syntax-0.6.25
+ rustc-hash-1.1.0
+ rustc_version-0.4.0
+ ryu-1.0.9
+ same-file-1.0.6
+ scopeguard-1.1.0
+ semver-1.0.4
+ serde-1.0.133
+ serde_cbor-0.11.2
+ serde_derive-1.0.133
+ serde_json-1.0.74
+ serde_yaml-0.8.23
+ signal-hook-0.3.13
+ signal-hook-mio-0.2.1
+ signal-hook-registry-1.4.0
+ smallvec-1.7.0
+ syn-1.0.85
+ termtree-0.2.4
+ textwrap-0.11.0
+ time-0.1.44
+ tinytemplate-1.2.1
+ tui-0.16.0
+ tui-input-0.1.2
+ unicase-2.6.0
+ unicode-segmentation-1.8.0
+ unicode-width-0.1.9
+ unicode-xid-0.2.2
+ version_check-0.9.4
+ wait-timeout-0.2.0
+ walkdir-2.3.2
+ wasi-0.10.0+wasi-snapshot-preview1
+ wasm-bindgen-0.2.78
+ wasm-bindgen-backend-0.2.78
+ wasm-bindgen-macro-0.2.78
+ wasm-bindgen-macro-support-0.2.78
+ wasm-bindgen-shared-0.2.78
+ web-sys-0.3.55
+ winapi-0.3.9
+ winapi-i686-pc-windows-gnu-0.4.0
+ winapi-util-0.1.5
+ winapi-x86_64-pc-windows-gnu-0.4.0
+ yaml-rust-0.4.5
+"
+
+inherit cargo lua-single
+
+DESCRIPTION="A hackable, minimal, fast TUI file explorer"
+HOMEPAGE="https://github.com/sayanarijit/xplr"
+SRC_URI="
+ https://github.com/sayanarijit/xplr/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ $(cargo_crate_uris)
+"
+
+LICENSE="
+ || ( Apache-2.0 )
+ || ( BSD )
+ || ( MIT )
+ || ( Unlicense )
+ Apache-2.0
+ BSD
+ MIT
+ Unlicense
+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RDEPEND="
+ ${LUA_DEPS}
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+QA_FLAGS_IGNORED="usr/bin/.*"
+
+src_configure() {
+ cargo_src_configure --bin xplr
+}
+
+src_prepare() {
+ sed -i Cargo.toml -e 's/"vendored"\s*,//' || die
+ # for dynamic linking with lua
+ default
+}
+
+src_compile() {
+ cargo_src_compile
+}
+
+src_install() {
+ if use doc; then
+ dodoc README.md
+ dodc -r docs/*
+ einstalldocs
+ fi
+ dobin target/release/xplr
+}